Imported Debian patch 0.63.0-6
[hcoop/debian/courier-authlib.git] / debian / courier-authlib-postgresql.postinst
index 5de5e6c..2684740 100644 (file)
@@ -1,6 +1,6 @@
 #! /bin/sh -e
 #
-# Copyright 2001,2005 by Stefan Hornburg (Racke) <racke@linuxia.de>
+# Copyright 2001,2005,2009 by Stefan Hornburg (Racke) <racke@linuxia.de>
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -21,8 +21,8 @@
 if [ "$1" = "configure" ]; then
        if [ -z "$2" ]; then
                # initial install of authpostgresql, we need to restart authdaemon
-               if [ -x /usr/sbin/authdaemond ]; then
-                       /usr/sbin/authdaemond restart
+               if which authdaemond >/dev/null 2>&1; then
+                       authdaemond restart
                fi
        fi
 fi