Merge branch 'debian'
[hcoop/debian/courier-authlib.git] / debian / changelog
index 6fcba6e..011269d 100644 (file)
@@ -1,3 +1,114 @@
+courier-authlib (0.69.0-2) unstable; urgency=medium
+
+  [ Andreas Henriksson ]
+  * Pass PS=/bin/ps to configure
+    - fixes redproducible build on merged-usr vs non-merged
+    Closes: #915226.
+
+  [ Markus Wanner ]
+  * Correct CI test pam, drop postgres-simple and postgres-complex
+    for now.
+  * Update symbols file to cover even more optional symbols.
+  * Bump Standards-Version to 4.3.0: no changes required.
+
+ -- Markus Wanner <markus@bluegap.ch>  Sat, 02 Feb 2019 23:17:27 +0100
+
+courier-authlib (0.69.0-1) unstable; urgency=medium
+
+  [ Ondřej Nový ]
+  * d/copyright: Use https protocol in Format field
+  * d/changelog: Remove trailing whitespaces
+  * d/watch: Use https protocol
+
+  [ Helmut Grohne ]
+  * Fix FTCBFS: (Closes: #884630)
+    + Do not try to guess the mail user/group from the build system.
+    + Use fcntl locking.
+    + Add 0009-cross.patch: Consider $ac_tool_prefix for pkg-config.
+
+  [ Markus Wanner ]
+  * New upstream release.
+  * Bump d/compat to 11.
+  * Add patch 0008-fix-perl-shebang.patch to fix perl shebang.
+  * Refresh patch 0001-Don-t-mangle-permissions....patch
+  * Drop patches 0003 and 0004, they have been integrated upstream.
+  * Increase verbosity in d/rules.
+  * Drop postinst call of invoke-rc.d and rely on debhelper, instead.
+  * Bump Standards-Version to 4.2.1: no further changes required.
+
+ -- Markus Wanner <markus@bluegap.ch>  Tue, 16 Oct 2018 18:43:27 +0200
+
+courier-authlib (0.68.0-4.1) unstable; urgency=medium
+
+  * Non-maintainer upload.
+  * Relax checks for C++ symbols (Closes: #897725)
+  * Update Vcs-* fields in debian/control
+
+ -- Dmitry Bogatov <KAction@gnu.org>  Wed, 10 Oct 2018 16:35:27 +0000
+
+courier-authlib (0.68.0-4) unstable; urgency=medium
+
+  [ Matthias Klose ]
+  * Update symbols file for -O3 builds. Closes: #875276.
+
+  [ Markus Wanner ]
+  * Correct build dependencies: require version 2.0 or newer of
+    courier-unicode, as per aclocal.m4.
+  * Use CONFIG_SHELL rather than just SHELL to enhance
+    reproducibility.
+
+ -- Markus Wanner <markus@bluegap.ch>  Mon, 11 Sep 2017 23:06:17 +0200
+
+courier-authlib (0.68.0-3) unstable; urgency=medium
+
+  * A few symbols from libcourierauthcommon.so.0 do not follow any
+    pattern. Mark them as optional. Closes: #868739.
+
+ -- Markus Wanner <markus@bluegap.ch>  Tue, 18 Jul 2017 17:14:27 +0200
+
+courier-authlib (0.68.0-2) unstable; urgency=medium
+
+  * Correct symbols file for 32-bit architectures. Closes: #866975.
+  * Tweak autopkgtests to work better.
+
+ -- Markus Wanner <markus@bluegap.ch>  Mon, 17 Jul 2017 22:36:26 +0200
+
+courier-authlib (0.68.0-1) unstable; urgency=medium
+
+  * New upstream release 0.68.0, upload to unstable.
+  * Drop patch 0006-Correct-CXXFLAGS.patch, it got applied upstream.
+  * Add three autopkgtests: pam, postgres-simple, postgres-custom.
+  * Add patch 0007-add-missing-include.patch so the rfc822 component
+    compiles again.
+
+ -- Markus Wanner <markus@bluegap.ch>  Sun, 02 Jul 2017 17:05:15 +0200
+
+courier-authlib (0.67.0-1) experimental; urgency=medium
+
+  * New upstream release 0.67.0.
+  * Take over the package. Closes: #848981.
+  * Update d/watch to ignore development snapshots.
+  * Bump S-V to 3.9.8, no changes required.
+  * Update d/copyright: adjust years, add myself, correct moved files.
+  * Refresh patches: 0001 and 0003.
+  * Adapt patch 0003-Fix-authdaemondprog-linking-missing-
+    libcourierauth.patch to apply, again.
+  * Add patch 0006-Correct-CXXFLAGS.patch.
+  * Update symbols: according to upstream, vanishing symbols are all
+    used for internal APIs only and shoul not affect library users.
+  * d/control: Use https for Vcs-* and Homepage fields.
+  * d/control: drop the deprecated or-ed dependency on libmysqlclient-dev.
+  * Use mailuser and mailgroup arguments for configure (as courier-base
+    with courier-config is not available at build time).
+  * Drop autotools-dev, use only dh_autoreconf.
+  * Enable basic hardening features, doesn't quite cover all libs, yet.
+  * Add a separate `set -e` line in postrm and postinst scripts, fixes
+    a lintian warning.
+  * Hard-wire $SHELL to /bin/sh in the hope for more reproducible builds.
+  * Drop now obsolete lintian overrides.
+
+ -- Markus Wanner <markus@bluegap.ch>  Sun, 09 Apr 2017 20:54:30 +0200
+
 courier-authlib (0.66.4-9+hcoop2) unstable; urgency=medium
 
   * HCoop release with fixed build
@@ -152,20 +263,20 @@ courier-authlib (0.63.0-6+hcoop1) unstable; urgency=medium
 courier-authlib (0.63.0-6) unstable; urgency=low
 
   [Martin Orr <martin@martinorr.name>]
-  
-  * Set SELinux context for runtime directories in init script 
-    (Closes: #668564) 
+
+  * Set SELinux context for runtime directories in init script
+    (Closes: #668564)
 
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Fri, 13 Apr 2012 08:53:02 +0200
 
 courier-authlib (0.63.0-5) unstable; urgency=low
 
   [ Moritz Muehlenhoff <jmm@debian.org> ]
-  
+
   * Enable hardened build flags (Closes: #655168)
-  
+
   [ Peter Eisentraut <petere@debian.org> ]
-  
+
   * Add support for "status" action to authdaemon init script
 
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Sat, 07 Apr 2012 16:48:52 +0200
@@ -202,7 +313,7 @@ courier-authlib (0.63.0-2) unstable; urgency=low
   * rebuild to really fix MySQL dependency (Closes: #574101)
   * recreation of directories in /var/run uses correct
     ownership/permissions now (Closes: #429866)
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Fri, 19 Mar 2010 14:28:14 +0100
 
 courier-authlib (0.63.0-1) unstable; urgency=low
@@ -215,10 +326,10 @@ courier-authlib (0.63.0-1) unstable; urgency=low
 
 courier-authlib (0.62.4-1) unstable; urgency=low
 
-  * new upstream release 
+  * new upstream release
     - satisfies courier-base reverse dependency (Closes: #558120,
       thanks to Julien Pinon <jpinon@free.fr> for the report)
-  * fix incorrect handling of init.d reload action by removing it 
+  * fix incorrect handling of init.d reload action by removing it
     (Closes: #527972, thanks to Peter Eisentraut <petere@debian.org>)
   * use upstream config.* files
   * lintian fixes
@@ -226,7 +337,7 @@ courier-authlib (0.62.4-1) unstable; urgency=low
     - eliminated commands with absolute paths in maintainer scripts
     - bumped up Standards-Version
     - bumped up debhelper comptability level to 5
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Thu, 26 Nov 2009 20:09:13 +0100
 
 courier-authlib (0.62.2-1) unstable; urgency=low
@@ -238,7 +349,7 @@ courier-authlib (0.62.2-1) unstable; urgency=low
     - copyright notice added to copyright
     - overrides for file permission of configuration files
     - reorder debhelper commands
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Mon, 02 Mar 2009 16:09:05 +0100
 
 courier-authlib (0.61.0-1+lenny1hcoop1) lenny; urgency=low
@@ -268,7 +379,7 @@ courier-authlib (0.61.0-1) unstable; urgency=low
   * lintian:
     - debian/compat file
     - don't ignore make clean errors
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Thu, 17 Jul 2008 12:59:36 +0200
 
 courier-authlib (0.60.1-2.1) unstable; urgency=high
@@ -354,7 +465,7 @@ courier-authlib (0.60.0-1) unstable; urgency=low
 
 courier-authlib (0.59.3-2) unstable; urgency=low
 
-  * dropped alternative build dependency on postgresql-dev 
+  * dropped alternative build dependency on postgresql-dev
     (Closes: #429964, thanks to Lior Kaplan <kaplan@debian.org> for the report
 
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Thu, 21 Jun 2007 20:26:38 +0200
@@ -392,11 +503,11 @@ courier-authlib (0.58-4) unstable; urgency=medium
   * call dh_makeshlibs during binary-arch target in order to get proper shlib
     information for libcourierauth.so (Closes: #378249, thanks to Charles
     Fry <cfry@debian.org> for the report and Steinar H. Gunderson
-    <sesse@debian.org> for the patch) 
+    <sesse@debian.org> for the patch)
   * ensure that courier-authdaemon is upgraded when switching to courier-authlib
   * switch to lsb logging functions (Closes: #384823, thanks to David Härdeman
     <david@2gen.com> for the patch)
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Sat,  9 Sep 2006 17:37:11 +0200
 
 courier-authlib (0.58-3.1) unstable; urgency=medium
@@ -455,7 +566,7 @@ courier-authlib (0.58-0.1) experimental; urgency=low
     Martin Pitt <mpitt@debian.org> for the report and the patch)
   * added courier-authlib-mysql/postgresql prerm/postinst scripts to
     restart courier-authdaemon
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Thu,  5 Jan 2006 14:58:19 +0100
 
 courier-authlib (0.57.20051004-2) experimental; urgency=low
@@ -476,7 +587,7 @@ courier-authlib (0.57.20051004-1) experimental; urgency=low
   * changed FSF address in copyright file
   * changed BuildDepends from libmysqlclient10-dev to libmysqlclient14-dev
   * use DH_COMPAT=4
-  
+
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Tue, 25 Oct 2005 11:04:45 +0200
 
 courier-authlib (0.56-0.5) experimental; urgency=low
@@ -508,7 +619,7 @@ courier-authlib (0.56-0.2) experimental; urgency=low
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Mon, 30 May 2005 13:23:02 +0200
 
 courier-authlib (0.56-0.1) experimental; urgency=low
-  
+
   * initial release
 
  -- Stefan Hornburg (Racke) <racke@linuxia.de>  Fri, 27 May 2005 23:20:21 +0200