Import Debian package 0.61.0-1+lenny1
[hcoop/debian/courier-authlib.git] / debian / rules
index 3a29bc2..2a13678 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 #
-# Copyright 2004,2005 by Stefan Hornburg (Racke) <racke@linuxia.de>
+# Copyright 2004,2005,2008 by Stefan Hornburg (Racke) <racke@linuxia.de>
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -23,9 +23,6 @@ RELUP=$(shell dpkg-parsechangelog | perl -ne 'print $$1 if /^Version: (.*?)-(.*)
 # Uncomment this to turn on verbose mode. 
 # export DH_VERBOSE=1
 
-# This is the debhelper compatability version to use.
-export DH_COMPAT=4
-
 # This has to be exported to make some magic below work.
 export DH_OPTIONS
 
@@ -55,7 +52,6 @@ COMMON_CONFOPTS=--prefix=/usr --mandir=\$${prefix}/share/man \
                --with-pgsql-libs=/usr/lib \
                --with-authpgsqlrc=/etc/courier/authpgsqlrc \
                --without-authshadow \
-               --without-authvchkpw \
                --with-authdaemonvar=/var/run/courier/authdaemon \
                --with-authldap \
                --with-authldaprc=/etc/courier/authldaprc \
@@ -96,7 +92,7 @@ clean: check
        rm -f stamp-build stamp-install
 
 # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
        dh_clean
 
 install: check stamp-build
@@ -117,7 +113,7 @@ install: check stamp-build
 #      pod2man --center='Debian GNU/Linux Documentation' --release='Debian GNU/Linux '`cat /etc/debian_version` --section=8 debian/courierauthtest.pod > $(BUILD)/usr/share/man/man8/courierauthtest.8
 
 # Symlinks for userdb manpages
-       (cd $(BUILD)/usr/share/man/man8 && ln -s makeuserdb.8.gz pw2userdb.8.gz && ln -s makeuserdb.8.gz vchkpw2userdb.8.gz)
+       (cd $(BUILD)/usr/share/man/man8 && ln -s makeuserdb.8.gz pw2userdb.8.gz)
 
        dh_installdocs
 # - change authentification default settings