Import Debian changes 0.66.4-9
[hcoop/debian/courier-authlib.git] / debian / courier-authlib-mysql.postinst
dissimilarity index 93%
index 3903e3c..3250b04 100644 (file)
@@ -1,30 +1,15 @@
-#! /bin/sh -e
-#
-# Copyright 2000,2001,2005,2009 by Stefan Hornburg (Racke) <racke@linuxia.de>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public
-# License along with this program; if not, write to the Free
-# Software Foundation, Inc., 59 Temple Place, Suite 330, Boston,
-# MA  02111-1307  USA.
-
-
-if [ "$1" = "configure" ]; then
-       if [ -z "$2" ]; then
-               # initial install of authmysql, we need to restart authdaemon
-               if which authdaemond >/dev/null 2>&1; then
-                       authdaemond restart
-               fi
-       fi
-fi
-
-#DEBHELPER#
+#! /bin/sh -e
+
+add_override() {
+    if ! dpkg-statoverride --list $4 >/dev/null; then
+       dpkg-statoverride --update --add $1 $2 $3 $4
+    fi
+}
+
+if [ "$1" = "configure" ]; then
+    add_override root courier 0640 /etc/courier/authmysqlrc
+fi
+
+#DEBHELPER#
+
+exit 0