Imported Debian patch 0.59.3-1
[hcoop/debian/courier-authlib.git] / debian / changelog
CommitLineData
426e7833 1courier-authlib (0.59.3-1) unstable; urgency=low
2
3 * new upstream release
4
5 -- Stefan Hornburg (Racke) <racke@linuxia.de> Mon, 23 Apr 2007 10:18:17 +0200
6
7courier-authlib (0.59.1-0.1) experimental; urgency=low
8
9 * new upstream release
10
11 -- Stefan Hornburg (Racke) <racke@linuxia.de> Wed, 17 Jan 2007 11:58:29 +0100
12
13courier-authlib (0.58-5) unstable; urgency=low
14
15 * added dependency and build dependency on expect (Closes: #400812,
16 thanks to Peter Troeger <peter@troeger.eu> for the report)
17
18 -- Stefan Hornburg (Racke) <racke@linuxia.de> Wed, 29 Nov 2006 11:42:45 +0100
19
20courier-authlib (0.58-4) unstable; urgency=medium
21
22 * call dh_makeshlibs during binary-arch target in order to get proper shlib
23 information for libcourierauth.so (Closes: #378249, thanks to Charles
24 Fry <cfry@debian.org> for the report and Steinar H. Gunderson
25 <sesse@debian.org> for the patch)
26 * ensure that courier-authdaemon is upgraded when switching to courier-authlib
27 * switch to lsb logging functions (Closes: #384823, thanks to David Härdeman
28 <david@2gen.com> for the patch)
29
30 -- Stefan Hornburg (Racke) <racke@linuxia.de> Sat, 9 Sep 2006 17:37:11 +0200
31
32courier-authlib (0.58-3.1) unstable; urgency=medium
33
34 * Non-Maintainer Upload to fix security bug, caused by
35 /var/run/courier/authdaemon being world executable. Thanks to Martin
36 Ferrari for the fix. (Closes: #378571)
37
38 -- Margarita Manterola <marga@debian.org> Tue, 1 Aug 2006 16:45:07 -0300
39
40courier-authlib (0.58-3) unstable; urgency=low
41
42 * remove all Courier runtime files on purge of courier-authdaemon
43
44 -- Stefan Hornburg (Racke) <racke@linuxia.de> Tue, 6 Jun 2006 04:48:20 +0200
45
46courier-authlib (0.58-2) unstable; urgency=low
47
48 * set ownership of /var/run/courier and /var/run/courier/authdaemon to
49 daemon.daemon (Closes: #368358, #368360)
50
51 -- Stefan Hornburg (Racke) <racke@linuxia.de> Tue, 23 May 2006 09:43:15 +0200
52
53courier-authlib (0.58-1.0) unstable; urgency=low
54
55 * first upload to unstable
56
57 -- Stefan Hornburg (Racke) <racke@linuxia.de> Fri, 12 May 2006 16:53:38 +0200
58
59courier-authlib (0.58-0.4) experimental; urgency=low
60
61 * changed alternative dependency for libmysqlclient-dev to
62 libmysqlclient15-dev (Closes: #356728, thanks to Stefan Huehner
63 <huehner@unix-ag.uni-kl.de> for the report)
64
65 -- Stefan Hornburg (Racke) <racke@linuxia.de> Tue, 14 Mar 2006 11:14:11 +0100
66
67courier-authlib (0.58-0.3) experimental; urgency=low
68
69 * courier-authlib-userdb conflicts with pre-authlib courier-base package
70
71 -- Stefan Hornburg (Racke) <racke@linuxia.de> Wed, 11 Jan 2006 09:33:10 +0100
72
73courier-authlib (0.58-0.2) experimental; urgency=low
74
75 * updated config.{guess,sub} to avoid FTBFS on some architectures
76 (Closes: #346105, thanks to Petr Salinger
77 <Petr.Salinger@t-systems.cz>)
78
79 -- Stefan Hornburg (Racke) <racke@linuxia.de> Fri, 6 Jan 2006 11:13:19 +0100
80
81courier-authlib (0.58-0.1) experimental; urgency=low
82
83 * new upstream release
84 * transition to new PostgreSQL architecture (Closes: #339297, thanks to
85 Martin Pitt <mpitt@debian.org> for the report and the patch)
86 * added courier-authlib-mysql/postgresql prerm/postinst scripts to
87 restart courier-authdaemon
88
89 -- Stefan Hornburg (Racke) <racke@linuxia.de> Thu, 5 Jan 2006 14:58:19 +0100
90
91courier-authlib (0.57.20051004-2) experimental; urgency=low
92
93 * ship configuration files with sane ownership/permissions
94 * restoring call to pam_acct_mgmt
95
96 -- Stefan Hornburg (Racke) <racke@linuxia.de> Fri, 11 Nov 2005 00:49:19 +0100
97
98courier-authlib (0.57.20051004-1) experimental; urgency=low
99
100 * new upstream release:
101 - contains authtest manual page and authpasswd script
102 * keep authtest name instead of renaming to courierauthtest, there are
103 currently no conflicts with other binaries
104 * separate package courier-authlib-pipe for authpipe module
105 * revive courier-authdaemon package to allow seamless upgrades from sarge
106 * changed FSF address in copyright file
107 * changed BuildDepends from libmysqlclient10-dev to libmysqlclient14-dev
108 * use DH_COMPAT=4
109
110 -- Stefan Hornburg (Racke) <racke@linuxia.de> Tue, 25 Oct 2005 11:04:45 +0200
111
112courier-authlib (0.56-0.5) experimental; urgency=low
113
114 * added build dependency on procps (Closes: #311976, thanks to Kurt
115 Roeckx <kurt@roeckx.be> for the report)
116
117 -- Stefan Hornburg (Racke) <racke@linuxia.de> Sat, 4 Jun 2005 22:03:43 +0200
118
119courier-authlib (0.56-0.4) experimental; urgency=low
120
121 * provide proper LDAP configuration file instead of an empty one (thanks
122 to Peter Mann <Peter.Mann@tuke.sk> for the report)
123
124 -- Stefan Hornburg (Racke) <racke@linuxia.de> Tue, 31 May 2005 14:48:04 +0200
125
126courier-authlib (0.56-0.3) experimental; urgency=low
127
128 * added dependency to courier-authlib-dev on courier-authlib
129 * versioned dependencies for courier-authlib-* packages
130
131 -- Stefan Hornburg (Racke) <racke@linuxia.de> Tue, 31 May 2005 11:13:01 +0200
132
133courier-authlib (0.56-0.2) experimental; urgency=low
134
135 * removed check for openssl binary (Closes: #311175, thanks to Kenshi
136 Muto <kmuto@debian.org> for the report)
137
138 -- Stefan Hornburg (Racke) <racke@linuxia.de> Mon, 30 May 2005 13:23:02 +0200
139
140courier-authlib (0.56-0.1) experimental; urgency=low
141
142 * initial release
143
144 -- Stefan Hornburg (Racke) <racke@linuxia.de> Fri, 27 May 2005 23:20:21 +0200
145