set properties for Id and Revision
[clinton/abcde.git] / debian / rules
index 3f517c1..b409981 100755 (executable)
@@ -22,7 +22,7 @@ clean:
        rm -f build-stamp install-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
 
        dh_clean
 
@@ -33,24 +33,22 @@ install-stamp: build-stamp
        dh_clean -k
        dh_installdirs
 
-       # Add here commands to install the package into debian/tmp.
-       $(MAKE) install DESTDIR=`pwd`/debian/tmp
+       # Add here commands to install the package into debian/abcde.
+       $(MAKE) install DESTDIR=`pwd`/debian/abcde
+       install -d `pwd`/debian/abcde/usr/share/doc/abcde/examples
+       install -m 644 examples/* `pwd`/debian/abcde/usr/share/doc/abcde/examples
 
        touch install-stamp
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
 #      dh_testversion
        dh_testdir
        dh_testroot
        dh_installdocs
        dh_installexamples
        dh_installmenu
-       dh_installmanpages
+       dh_installman
        dh_installchangelogs 
        dh_link
        dh_strip
@@ -63,6 +61,10 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
 source diff:                                                                  
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false