Fix broken range code, patch from Charles Steinkuehler
[clinton/abcde.git] / debian / rules
index 3303ad8..b409981 100755 (executable)
@@ -22,7 +22,7 @@ clean:
        rm -f build-stamp install-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
 
        dh_clean
 
@@ -42,10 +42,6 @@ install-stamp: build-stamp
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
 #      dh_testversion
        dh_testdir
        dh_testroot
@@ -65,6 +61,10 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
 source diff:                                                                  
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false