Add Recommends: atomicparsley in the Debian packaging for Debian/Ubuntu users. LP...
[clinton/abcde.git] / debian / rules
index 3303ad8..595d6f3 100755 (executable)
@@ -6,7 +6,9 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp:
        dh_testdir
 
 build-stamp:
        dh_testdir
 
@@ -22,7 +24,7 @@ clean:
        rm -f build-stamp install-stamp
 
        # Add here commands to clean up after the build process.
        rm -f build-stamp install-stamp
 
        # Add here commands to clean up after the build process.
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
 
        dh_clean
 
 
        dh_clean
 
@@ -42,10 +44,6 @@ install-stamp: build-stamp
 
 # Build architecture-independent files here.
 binary-indep: build install
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
 #      dh_testversion
        dh_testdir
        dh_testroot
 #      dh_testversion
        dh_testdir
        dh_testroot
@@ -65,6 +63,10 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
        dh_md5sums
        dh_builddeb
 
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
 source diff:                                                                  
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
 
 source diff:                                                                  
        @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false