Add support for freedb2
[clinton/abcde.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 build: build-stamp
10 build-stamp:
11 dh_testdir
12
13
14 # Add here commands to compile the package.
15 $(MAKE)
16
17 touch build-stamp
18
19 clean:
20 dh_testdir
21 dh_testroot
22 rm -f build-stamp install-stamp
23
24 # Add here commands to clean up after the build process.
25 [ ! -f Makefile ] || $(MAKE) clean
26
27 dh_clean
28
29 install: install-stamp
30 install-stamp: build-stamp
31 dh_testdir
32 dh_testroot
33 dh_clean -k
34 dh_installdirs
35
36 # Add here commands to install the package into debian/abcde.
37 $(MAKE) install DESTDIR=`pwd`/debian/abcde
38 install -d `pwd`/debian/abcde/usr/share/doc/abcde/examples
39 install -m 644 examples/* `pwd`/debian/abcde/usr/share/doc/abcde/examples
40
41 touch install-stamp
42
43 # Build architecture-independent files here.
44 binary-indep: build install
45 # dh_testversion
46 dh_testdir
47 dh_testroot
48 dh_installdocs
49 dh_installexamples
50 dh_installmenu
51 dh_installman
52 dh_installchangelogs
53 dh_link
54 dh_strip
55 dh_compress
56 dh_fixperms
57 dh_installdeb
58 dh_shlibdeps
59 dh_gencontrol
60 # dh_makeshlibs
61 dh_md5sums
62 dh_builddeb
63
64 # Build architecture-dependent files here.
65 binary-arch: build install
66 # We have nothing to do by default.
67
68 source diff:
69 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
70
71 binary: binary-indep binary-arch
72 .PHONY: build clean binary-indep binary-arch binary