Update debian packaging for new release
[clinton/abcde.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 build: build-arch build-indep
10 build-arch: build-stamp
11 build-indep: build-stamp
12 build-stamp:
13 dh_testdir
14
15
16 # Add here commands to compile the package.
17 $(MAKE)
18
19 touch build-stamp
20
21 clean:
22 dh_testdir
23 dh_testroot
24 rm -f build-stamp install-stamp
25
26 # Add here commands to clean up after the build process.
27 [ ! -f Makefile ] || $(MAKE) clean
28
29 dh_clean
30
31 install: install-stamp
32 install-stamp: build-stamp
33 dh_testdir
34 dh_testroot
35 dh_clean -k
36 dh_installdirs
37
38 # Add here commands to install the package into debian/abcde.
39 $(MAKE) install DESTDIR=`pwd`/debian/abcde
40 install -d `pwd`/debian/abcde/usr/share/doc/abcde/examples
41 install -m 644 examples/* `pwd`/debian/abcde/usr/share/doc/abcde/examples
42
43 touch install-stamp
44
45 # Build architecture-independent files here.
46 binary-indep: build install
47 # dh_testversion
48 dh_testdir
49 dh_testroot
50 dh_installdocs
51 dh_installexamples
52 dh_installmenu
53 dh_installman
54 dh_installchangelogs
55 dh_link
56 dh_strip
57 dh_compress
58 dh_fixperms
59 dh_installdeb
60 dh_shlibdeps
61 dh_gencontrol
62 # dh_makeshlibs
63 dh_md5sums
64 dh_builddeb
65
66 # Build architecture-dependent files here.
67 binary-arch: build install
68 # We have nothing to do by default.
69
70 source diff:
71 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
72
73 binary: binary-indep binary-arch
74 .PHONY: build clean binary-indep binary-arch binary