Many bug fixes went into this update:
[clinton/abcde.git] / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of dh_make, by Craig Small
3 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
4 # Some lines taken from debmake, by Cristoph Lameter.
5
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
8
9 build: build-stamp
10 build-stamp:
11 dh_testdir
12
13
14 # Add here commands to compile the package.
15 $(MAKE)
16
17 touch build-stamp
18
19 clean:
20 dh_testdir
21 dh_testroot
22 rm -f build-stamp install-stamp
23
24 # Add here commands to clean up after the build process.
25 -$(MAKE) clean
26
27 dh_clean
28
29 install: install-stamp
30 install-stamp: build-stamp
31 dh_testdir
32 dh_testroot
33 dh_clean -k
34 dh_installdirs
35
36 # Add here commands to install the package into debian/tmp.
37 $(MAKE) install DESTDIR=`pwd`/debian/tmp
38
39 touch install-stamp
40
41 # Build architecture-independent files here.
42 binary-indep: build install
43 # We have nothing to do by default.
44
45 # Build architecture-dependent files here.
46 binary-arch: build install
47 # dh_testversion
48 dh_testdir
49 dh_testroot
50 dh_installdocs
51 dh_installexamples
52 dh_installmenu
53 dh_installmanpages
54 dh_installchangelogs
55 dh_link
56 dh_strip
57 dh_compress
58 dh_fixperms
59 dh_installdeb
60 dh_shlibdeps
61 dh_gencontrol
62 # dh_makeshlibs
63 dh_md5sums
64 dh_builddeb
65
66 source diff:
67 @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
68
69 binary: binary-indep binary-arch
70 .PHONY: build clean binary-indep binary-arch binary