merged from lp:~donkult/apt/experimental
[ntk/apt.git] / debian / rules
index a466fbf..6a5c95d 100755 (executable)
@@ -5,6 +5,7 @@
 
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 # FOR AUTOCONF 2.52 AND NEWER ONLY
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -62,7 +63,7 @@ configure.in:
 endif
 
 # APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates
+APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -70,6 +71,10 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 # Find the libapt-pkg major version for use in other control files
 include buildlib/libversion.mak
 
+# Determine which library package names to use
+LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
+
 # do not fail as we are just experimenting with symbol files for now
 export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
@@ -93,6 +98,15 @@ build/configure-stamp: configure
 build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
        $(MAKE) binary
+       # compat symlink for the locale split
+       mkdir -p build/usr/share 
+       cd build/usr/share && ln -f -s ../../locale .
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
        touch $@
 
 build/build-doc-stamp: build/configure-stamp
@@ -105,9 +119,31 @@ clean:
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
+       rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+             debian/libapt-pkg-dev.install
+
+debian/%.install: debian/%.install.in
+       sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
-binary-indep: apt-doc libapt-pkg-doc
+binary-indep: libapt-common apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
+libapt-common: build
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
 libapt-pkg-doc: build-doc
        dh_testdir -p$@
        dh_testroot -p$@
@@ -116,9 +152,6 @@ libapt-pkg-doc: build-doc
 #
 # libapt-pkg-doc install
 #
-       # remove doxygen's embedded jquery as we don't use it anyway (#622147)
-       rm -f $(BLD)/doc/doxygen/html/jquery.js
-
        dh_installdocs -p$@ $(BLD)/docs/design* \
                            $(BLD)/docs/dpkg-tech* \
                            $(BLD)/docs/files* \
@@ -161,7 +194,7 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: libapt-pkg4.10 libapt-inst1.2 apt libapt-pkg-dev apt-utils apt-transport-https
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
 apt: build build-doc
        dh_testdir -p$@
@@ -181,7 +214,7 @@ apt: build build-doc
        dh_install -p$@ --sourcedir=$(BLD)
 
        # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
 
        # https has its own package
        rm debian/$@/usr/lib/apt/methods/https
@@ -202,12 +235,12 @@ apt: build build-doc
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-inst2.1/usr/lib:$(CURDIR)/debian/libapt-pkg4.10/usr/lib
+       dh_shlibdeps -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg-dev: build
+libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -222,7 +255,7 @@ libapt-pkg-dev: build
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@
+       dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
@@ -234,8 +267,10 @@ apt-utils: build
        dh_installdirs -p$@
 
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+       cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
 
        dh_install -p$@ --sourcedir=$(BLD)
+       dh_link -p$@
        dh_installdocs -p$@
        dh_installexamples -p$@
 
@@ -248,43 +283,45 @@ apt-utils: build
        dh_fixperms -p$@
        dh_makeshlibs -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-inst2.1/usr/lib:$(CURDIR)/debian/libapt-pkg4.10/usr/lib
+       dh_shlibdeps -p$@
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg4.10: build
+$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
        dh_installdirs -p$@
 
        dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_installdeb -p$@
        dh_makeshlibs -p$@
+       dh_installdeb -p$@
        dh_shlibdeps -p$@ 
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-inst1.2: build
+$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
        dh_installdirs -p$@
 
        dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_installdeb -p$@
        dh_makeshlibs -p$@
-       dh_shlibdeps -p$@ -l$(CURDIR)/debian/libapt-pkg4.10/usr/lib
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ 
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
@@ -307,7 +344,7 @@ apt-transport-https: build libapt-pkg-dev
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l$(CURDIR)/debian/apt/usr/lib:$(CURDIR)/debian/$@/usr/lib
+       dh_shlibdeps -p$@ 
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@