merged from lp:~donkult/apt/sid
[ntk/apt.git] / debian / changelog
index 18242e0..2f5a3dc 100644 (file)
@@ -1,7 +1,13 @@
-apt (0.9.2) unstable; urgency=low
+apt (0.9.2) UNRELEASED; urgency=low
+
+  [ Michael Vogt ]
+  * apt-inst/contrib/extracttar.cc:
+    - ensure that in StartGzip the InFd is set to "AutoClose" to ensure
+      that the pipe is closed when InFd is closed. This fixes a Fd leak
+      (LP: #985452)
 
   [ David Kalnischkies ]
-  * apt-pkg/deb/deblistparser.cc:
+   * apt-pkg/deb/deblistparser.cc:
     - only treat the native apt as essential by default (Closes: #669377)
   * apt-pkg/contrib/fileutl.cc:
     - redirect stderr from compressors to /dev/null
@@ -16,6 +22,12 @@ apt (0.9.2) unstable; urgency=low
     - actually return to the fallback modifier if we have detected we
       should for packagenames which look like modifiers (Closes: #669591)
 
+  [ Adam Conrad ]
+  * Set FD_CLOEXEC on history.log's FD (Closes: #610069, LP: #636010)
+
+  [ Thorsten Spindler ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - do not crash if (*I).Pkg is NULL (LP: #939867)
 
   [ Malcolm Scott ]
   * apt-pkg/packagemanager.cc: