merged from lp:~donkult/apt/experimental
[ntk/apt.git] / debian / rules
index 2fe6ed6..6a5c95d 100755 (executable)
@@ -2,20 +2,10 @@
 # Made with the aid of dh_make, by Craig Small
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
-# $Id: rules,v 1.68 2004/05/30 18:21:43 mdz Exp $
-
-# LD_LIBRARY_PATH=pwd/debian/apt/usr/lib dh_shlibdeps -papt
-# dpkg: /home/jgg/work/apt2/debian/apt/usr/lib/libapt-pkg.so.2.9 not found.
-
-# For the deb builder, you can run 'debian/rules cvs-build', which does all
-# steps nescessary to produce a proper source tarball with the CVS/ removed.
-# It builds in debian/cvs-build/apt-<VER>/, and places files in
-# debian/cvs-build/.  Optionally, you can run 'debian/rules cvs-mkul' to
-# create ../upload-<VER>, with all the files needed to be uploaded placed
-# in it.
 
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 # FOR AUTOCONF 2.52 AND NEWER ONLY
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -27,10 +17,14 @@ endif
 # See below
 -include build/environment.mak
 
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-  export CXXFLAGS = -O0 -g -Wall
+ifneq (,$(shell which dpkg-buildflags))
+  export CXXFLAGS = $(shell dpkg-buildflags --get CXXFLAGS)
 else
-  export CXXFLAGS = -O2 -g -Wall
+  ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+    export CXXFLAGS = -O0 -g -Wall
+  else
+    export CXXFLAGS = -O2 -g -Wall
+  endif
 endif
 
 # Default rule
@@ -47,7 +41,7 @@ BASE=.
 ifdef BUILD
 BUILD_POSSIBLE := $(BUILD) $(BASE)/$(BUILD)
 else
-BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname -m) $(BASE)/build
+BUILD_POSSIBLE := $(BASE) $(BASE)/build-$(shell uname --machine) $(BASE)/build
 endif
 BUILDX:= $(foreach i,$(BUILD_POSSIBLE),$(wildcard $(i)/environment.mak*))
 BUILDX:= $(patsubst %/,%,$(firstword $(dir $(BUILDX))))
@@ -69,7 +63,7 @@ configure.in:
 endif
 
 # APT Programs in apt-utils
-APT_UTILS=ftparchive sortpkgs extracttemplates
+APT_UTILS=ftparchive sortpkgs extracttemplates internal-solver
 
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
@@ -77,25 +71,15 @@ APT_UTILS=ftparchive sortpkgs extracttemplates
 # Find the libapt-pkg major version for use in other control files
 include buildlib/libversion.mak
 
-# Determine which package we should provide in the control files
-LIBAPTPKG_PROVIDE=libapt-pkg$(LIBAPTPKG_MAJOR)
-LIBAPTINST_PROVIDE=libapt-inst$(LIBAPTINST_MAJOR)
-
-debian/shlibs.local: apt-pkg/makefile
-       # We have 3 shlibs.local files.. One for 'apt', one for 'apt-utils' and
-       # one for the rest of the packages. This ensures that each package gets
-       # the right overrides.. 
-       rm -rf $@ $@.apt $@.apt-utils
-       echo "libapt-pkg $(LIBAPTPKG_MAJOR)" > $@.apt
+# Determine which library package names to use
+LIBAPT_PKG=libapt-pkg$(LIBAPTPKG_MAJOR)
+LIBAPT_INST=libapt-inst$(LIBAPTINST_MAJOR)
 
-       echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@.apt-utils
-       echo "libapt-inst $(LIBAPTINST_MAJOR)" >> $@.apt-utils
+# do not fail as we are just experimenting with symbol files for now
+export DPKG_GENSYMBOLS_CHECK_LEVEL=0
 
-       echo "libapt-pkg $(LIBAPTPKG_MAJOR) $(LIBAPTPKG_PROVIDE)" > $@
-       echo "libapt-inst $(LIBAPTINST_MAJOR) $(LIBAPTINST_PROVIDE)" >> $@
-
-build: build/build-stamp       
-build-doc: build/build-doc-stamp       
+build: build/build-stamp
+build-doc: build/build-doc-stamp
 
 # Note that this is unconditionally done first as part of loading environment.mak
 # The true is needed to force make to reload environment.mak after running
@@ -108,12 +92,21 @@ build/configure-stamp: configure
        dh_testdir
        -mkdir build
        cp COPYING debian/copyright
-       cd build && CXXFLAGS="$(confcxxflags)" ../configure $(confflags)
+       cd build && CXXFLAGS="$(CXXFLAGS)" ../configure $(confflags)
        touch $@
 
 build/build-stamp: build/configure-stamp
        # Add here commands to compile the package.
        $(MAKE) binary
+       # compat symlink for the locale split
+       mkdir -p build/usr/share 
+       cd build/usr/share && ln -f -s ../../locale .
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
        touch $@
 
 build/build-doc-stamp: build/configure-stamp
@@ -123,55 +116,72 @@ build/build-doc-stamp: build/configure-stamp
 
 clean:
        dh_testdir
-#      dh_testroot
-       [ -f Makefile ] && $(MAKE) clean
-       [ -f Makefile ] && $(MAKE) distclean
 
+       [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
+       rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+             debian/libapt-pkg-dev.install
 
-       # Add here commands to clean up after the build process.
-       dh_clean debian/copyright debian/shlibs.local debian/shlibs.local.apt debian/shlibs.local.apt-utils
+debian/%.install: debian/%.install.in
+       sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
-binary-indep: apt-doc libapt-pkg-doc
+binary-indep: libapt-common apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
-libapt-pkg-doc: build-doc debian/shlibs.local
+libapt-common: build
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+libapt-pkg-doc: build-doc
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 #
 # libapt-pkg-doc install
-#      
-       dh_installdocs -p$@ $(BLD)/docs/cache* $(BLD)/docs/design* $(BLD)/docs/dpkg-tech* \
-                            $(BLD)/docs/files* $(BLD)/docs/method* \
-                           doc/libapt-pkg2_to_3.txt doc/style.txt
+#
+       dh_installdocs -p$@ $(BLD)/docs/design* \
+                           $(BLD)/docs/dpkg-tech* \
+                           $(BLD)/docs/files* \
+                           $(BLD)/docs/method* \
+                           doc/libapt-pkg2_to_3.txt \
+                           doc/style.txt \
+                           $(BLD)/doc/doxygen/html
        dh_installexamples -p$@
-#      dh_installmenu -p$@
-#      dh_installinit -p$@
-#      dh_installcron -p$@
-#      dh_installman -p$@
 
-#      dh_undocumented -p$@
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+       dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
 apt-doc: build-doc
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
 #
 # apt-doc install
 #
        # Copy the guides
-       dh_installdocs -p$@ $(BLD)/docs/guide*.text $(BLD)/docs/guide*.html \
-                      $(BLD)/docs/offline*.text $(BLD)/docs/offline*.html
+       dh_installdocs -p$@ $(BLD)/docs/guide*.text \
+                           $(BLD)/docs/guide*.html \
+                           $(BLD)/docs/offline*.text \
+                           $(BLD)/docs/offline*.html
        dh_installchangelogs -p$@
        dh_compress -p$@
        dh_fixperms -p$@
@@ -184,102 +194,83 @@ apt-doc: build-doc
 
 # Build architecture-dependent files here.
 
-binary-arch: apt libapt-pkg-dev apt-utils apt-transport-https
+binary-arch: $(LIBAPT_PKG) $(LIBAPT_INST) apt libapt-pkg-dev apt-utils apt-transport-https
 apt_MANPAGES = apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build build-doc debian/shlibs.local
+apt: build build-doc
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 #
 # apt install
 #
-       cp $(BLD)/bin/apt-* debian/$@/usr/bin/
-
-       # Remove the bits that are in apt-utils
-       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS))
-
-       # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-pkg*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-
-       cp $(BLD)/bin/methods/* debian/$@/usr/lib/apt/methods/
-       # https has its own package
-       rm debian/$@/usr/lib/apt/methods/https
-
-       cp $(BLD)/scripts/dselect/* debian/$@/usr/lib/dpkg/methods/apt/
-       cp -r $(BLD)/locale debian/$@/usr/share/
-
-       cp debian/bugscript debian/$@/usr/share/bug/apt/script
-       cp debian/apt.logrotate debian/$@/etc/logrotate.d/apt
-
        cp debian/apt.conf.autoremove debian/$@/etc/apt/apt.conf.d/01autoremove
-#      head -n 500 ChangeLog > debian/ChangeLog
-
-       # copy lintian override
-       cp share/lintian-overrides debian/$@/usr/share/lintian/overrides/apt
 
        # make rosetta happy and remove pot files in po/ (but leave stuff
        # in po/domains/* untouched) and cp *.po into each domain dir
        rm -f build/po/*.pot
        rm -f po/*.pot
 
+       dh_install -p$@ --sourcedir=$(BLD)
+
+       # Remove the bits that are in apt-utils
+       rm $(addprefix debian/$@/usr/bin/apt-,$(APT_UTILS) dump-solver)
+
+       # https has its own package
+       rm debian/$@/usr/lib/apt/methods/https
+
+       # move the mirror failure script in place
+       #mv debian/$@/usr/bin/apt-report-mirror-failure \
+       #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
+
+       dh_bugfiles -p$@
+       dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
        dh_installman -p$@ $(wildcard $(patsubst %,doc/%.[158],$(apt_MANPAGES)) $(patsubst %,doc/*/%.*.[158],$(apt_MANPAGES)))
        dh_installcron -p$@
        dh_installdocs -p$@
        dh_installchangelogs -p$@
+       dh_installlogrotate -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -p$@ -m$(LIBAPTPKG_MAJOR) -V '$(LIBAPTPKG_PROVIDE)'
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE)
+       dh_shlibdeps -p$@
+       dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg-dev: build debian/shlibs.local
+libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 #
 # libapt-pkg-dev install
 #
-       cp -a $(BLD)/bin/libapt-pkg*.so debian/libapt-pkg-dev/usr/lib/
-       cp -a $(BLD)/bin/libapt-inst*.so debian/libapt-pkg-dev/usr/lib/
-#      ln -s libapt-pkg.so.$(LIBAPTPKG_MAJOR) debian/libapt-pkg-dev/usr/lib/libapt-pkg.so
-       cp $(BLD)/include/apt-pkg/*.h debian/libapt-pkg-dev/usr/include/apt-pkg/
-
+       dh_install -p$@ --sourcedir=$(BLD)
        dh_installdocs -p$@
-#      dh_installmenu -p$@
-#      dh_installinit -p$@
-#      dh_installcron -p$@
-#      dh_installman -p$@
-
        dh_installchangelogs -p$@
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-#      dh_suidregister -p$@
        dh_installdeb -p$@
-       dh_gencontrol -p$@ -u -Vlibapt-pkg:provides=$(LIBAPTPKG_PROVIDE) -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+       dh_gencontrol -p$@ -- -Vlibapt-pkg-name=$(LIBAPT_PKG) -Vlibapt-inst-name=$(LIBAPT_INST)
        dh_md5sums -p$@
        dh_builddeb -p$@
 
 apt-utils_MANPAGES = apt-sortpkgs apt-ftparchive apt-extracttemplates
-apt-utils: build debian/shlibs.local
+apt-utils: build
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 
-       # install the shared libs
-       find $(BLD)/bin/ -type f -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-       find $(BLD)/bin/ -type l -name "libapt-inst*.so.*" -exec cp -a "{}" debian/$@/usr/lib/ \;
-
        cp $(addprefix $(BLD)/bin/apt-,$(APT_UTILS)) debian/$@/usr/bin/
+       cp $(BLD)/bin/apt-dump-solver debian/$@/usr/lib/apt/solvers/dump
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_link -p$@
        dh_installdocs -p$@
        dh_installexamples -p$@
 
@@ -290,23 +281,58 @@ apt-utils: build debian/shlibs.local
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
-       dh_makeshlibs -m$(LIBAPTINST_MAJOR) -V '$(LIBAPTINST_PROVIDE)' -p$@
+       dh_makeshlibs -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
+$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_makeshlibs -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib -- -Ldebian/shlibs.local.apt-utils
-       dh_gencontrol -p$@ -u -Vlibapt-inst:provides=$(LIBAPTINST_PROVIDE)
+       dh_shlibdeps -p$@ 
+       dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-apt-transport-https: build debian/shlibs.local libapt-pkg-dev
+$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
        dh_testdir -p$@
        dh_testroot -p$@
-       dh_clean -p$@ -k
+       dh_prep -p$@
        dh_installdirs -p$@
 
-       # install the method
-       mkdir -p debian/$@/usr/lib/apt/methods
-       cp $(BLD)/bin/methods/https debian/$@/usr/lib/apt/methods
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_makeshlibs -p$@
+       dh_installdeb -p$@
+       dh_shlibdeps -p$@ 
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
 
+apt-transport-https: build libapt-pkg-dev
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
        dh_installdocs -p$@ debian/apt-transport-https.README
        dh_installexamples -p$@
 
@@ -318,61 +344,18 @@ apt-transport-https: build debian/shlibs.local libapt-pkg-dev
        dh_compress -p$@
        dh_fixperms -p$@
        dh_installdeb -p$@
-       dh_shlibdeps -p$@ -l`pwd`/debian/apt/usr/lib:`pwd`/debian/$@/usr/lib 
+       dh_shlibdeps -p$@ 
        dh_gencontrol -p$@
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-source diff:
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
-# Update from CVS
-l33ch: really-clean
-       cvs update
-       buildlib/mkChangeLog
-
-# Update from CVS and then configure for build
-super-l33ch: l33ch Makefile.in
-
 configure:
        $(MAKE) configure
 
-l33ch-stamp: super-l33ch
-       touch $@
-
 really-clean: clean
-       -find -name Makefile.in -print0 | xargs -0r rm -f
+       -find . -name Makefile.in -print0 | xargs --null --no-run-if-empty -- rm -f
        find -name ChangeLog | xargs rm -f
        rm -f l33ch-stamp
 
 binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary debian/shlibs.local
-
-
-# Done by the uploader.
-#cvs update.. 
-#edit debian/changelog
-# configure.in has the version automatically updated now.
-# edit configure.in
-# debian/rules cvs-build
-
-CVS_BUILDDIR=apt-$(APT_DEBVER)
-CVS_ROOT=$(shell cat CVS/Root)
-CVS_MODULE=$(shell cat CVS/Repository)
-cvs-build:
-       rm -rf debian/cvs-build
-       mkdir -p debian/cvs-build
-       (cd debian/cvs-build;cvs -d $(CVS_ROOT) export -r$(APT_CVSTAG) -d apt-$(APT_DEBVER) $(CVS_MODULE))
-       $(MAKE) -C debian/cvs-build/$(CVS_BUILDDIR) startup doc
-       (cd debian/cvs-build/$(CVS_BUILDDIR);$(DEB_BUILD_PROG))
-
-cvs-mkul:
-       -mkdir -p ../upload-$(APT_DEBVER)
-       cp `find debian/cvs-build -maxdepth 1 -type f` ../upload-$(APT_DEBVER)
-
-arch-build:
-       rm -rf debian/arch-build
-       mkdir -p debian/arch-build/apt-$(APT_DEBVER)
-       tar -c --exclude=arch-build --no-recursion -f - `bzr inventory` | (cd debian/arch-build/$(PKG)-$(APT_DEBVER);tar xf -)
-       $(MAKE) -C debian/arch-build/apt-$(APT_DEBVER) startup doc
-       (cd debian/arch-build/apt-$(APT_DEBVER); $(DEB_BUILD_PROG); dpkg-genchanges -S > ../apt_$(APT_DEBVER)_source.changes)
+.PHONY: build clean binary-indep binary-arch binary