* Fix compilation warnings:
[ntk/apt.git] / debian / changelog
index bbe4c02..a97018a 100644 (file)
@@ -1,5 +1,91 @@
+apt (0.7.4) UNRELEASED; urgency=low
+
+  * Fix a typo on 0.7.3 changelog entry about g++ (7.3 to 4.3)
+  * Fix compilation warnings:
+    - apt-pkg/contrib/configuration.cc: wrong argument type;
+    - apt-pkg/deb/dpkgpm.cc: wrong signess;
+    - apt-pkg-acquire-item.cc: wrong signess and orderned initializers;
+    - methods/https.cc:
+      - type conversion;
+      - unused variable;
+      - changed SetupProxy() method to void;
+
+ -- Otavio Salvador <otavio@ossystems.com.br>  Mon, 02 Jul 2007 13:27:54 -0300
+
+apt (0.7.3) unstable; urgency=low
+
+  * fixed compile errors with g++ 4.3 (thanks to 
+    Daniel Burrows, closes: #429378)
+  * fixes in the auto-mark code (thanks to Daniel
+    Burrows)
+  * fix FTFBFS by changing build-depends to
+    libcurl4-gnutls-dev (closes: #428363)
+  * cmdline/apt-get.cc:
+    - fix InstallTask code when a pkgRecord ends 
+      with a single '\n' (thanks to Soren Hansen for reporting)
+  * merged from Christian Perrier:
+       * vi.po: completed to 532t, again. Closes: #429899
+       * gl.po: completed to 532t. Closes: #429506
+       * vi.po: completed to 532t. Closes: #428672
+        * Update all PO and the POT. Gives 514t14f4u for formerly
+          complete translations
+        * fr.po: completed to 532t
+        * ku.po, uk.po, LINGUAS: reintegrate those translations
+          which disappeared from the BZR repositories
+
+ -- Michael Vogt <mvo@debian.org>  Sun, 01 Jul 2007 12:31:29 +0200
+
+apt (0.7.2-0.1) unstable; urgency=low
+
+  * Non-maintainer upload.
+  * Build-depend on libcurl4-gnutls-dev instead of the obsolete
+    libcurl3-gnutls-dev.  Closes: #428363.
+
+ -- Steve Langasek <vorlon@debian.org>  Thu, 28 Jun 2007 18:46:53 -0700
+
+apt (0.7.2) unstable; urgency=low
+  
+  * merged the debian/experimental changes back
+    into the debian/sid branch
+  * merged from Christian Perrier:
+    * mr.po: New Marathi translation  Closes: #416806
+    * zh_CN.po: Updated by Eric Pareja  Closes: #416822
+    * tl.po: Updated by Eric Pareja   Closes: #416638
+    * gl.po: Updated by Jacobo Tarrio
+            Closes: #412828
+    * da.po: Updated by Claus Hindsgaul
+            Closes: #409483
+    * fr.po: Remove a non-breakable space for usability
+            issues. Closes: #408877
+    * ru.po: Updated Russian translation. Closes: #405476
+    * *.po: Unfuzzy after upstream typo corrections
+  * buildlib/archtable:
+    - added support for sh3/sh4 (closes: #424870)
+    - added support for m32r (closes: #394096)
+  * buildlib/systemtable:
+    - added support for lpia
+  * configure.in:
+    - check systemtable for architecture mapping too
+  * fix error in AutocleanInterval, closes: #319339
+    (thanks to Israel G. Lugo for the patch)
+  * add "purge" commandline argument, closes: #133421)
+    (thanks to Julien Danjou for the patch)
+  * add "purge" commandline argument, closes: #133421)
+    (thanks to Julien Danjou for the patch)
+  * fix FTBFS with gcc 4.3, closes: #417090
+    (thanks to Martin Michlmayr for the patch)
+  * add --dsc-only option, thanks to K. Richard Pixley
+  * Removed the more leftover #pragma interface/implementation
+    closes: #306937 (thanks to Andreas Henriksson for the patch)
+  
+ -- Michael Vogt <mvo@debian.org>  Wed, 06 Jun 2007 23:19:50 +0200
+
 apt (0.7.1) experimental; urgency=low
 
+  * ABI library name change because its build against
+    new glibc
+  * implement SourceVer() in pkgRecords 
+     (thanks to Daniel Burrows for the patch!)
   * apt-pkg/algorithm.cc:
     - use clog for all debugging
     - only increase the score of installed applications if they 
@@ -33,6 +119,12 @@ apt (0.7.1) experimental; urgency=low
              issues. Closes: #408877
     * ru.po: Updated Russian translation. Closes: #405476
     * *.po: Unfuzzy after upstream typo corrections
+    * vi.po: Updated to 515t. Closes: #426976
+    * eu.po: Updated to 515t. Closes: #423766
+    * pt.po: 515t. Closes: #423111
+    * fr.po: Updated by Christian Perrier
+    * Update all PO and the POT. Gives 513t2f for formerly
+      complete translations
   * apt-pkg/policy.cc:
     - allow multiple packages (thanks to David Foerster)
 
@@ -154,9 +246,11 @@ apt (0.6.46.1) unstable; urgency=low
   * merged "install-task" branch (use with "apt-get install taskname^")
   * methods/gzip.cc:
     - deal with empty files 
-  * Applied patch from Daniel Schepler to make apt bin-NMU able.  
+  * Applied patch from Daniel Schepler to make apt bin-NMU able.
+    (closes: bug#359634)
   * rebuild against current g++ because of:
     http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29289
+    (closes: #390189)
   * fix broken i18n in the dpkg progress reporting, thanks to 
     Frans Pop and Steinar Gunderson. (closes: #389261)
   * Merged from Christian Perrier bzr branch:
@@ -209,7 +303,7 @@ apt (0.6.45) unstable; urgency=low
   * apt-pkg/contrib/sha256.cc:
     - fixed the sha256 generation (closes: #378183)
   * ftparchive/cachedb.cc:
-    - applied patch from ajt to fix Clean() function
+    - applied patch from Anthony Towns to fix Clean() function
       (closes: #379576)
   * doc/apt-get.8.xml:
     - fix path to the apt user build (Closes: #375640)
@@ -227,6 +321,9 @@ apt (0.6.45) unstable; urgency=low
     - fix for string mangling, closes: #373864
   * apt-pkg/acquire-item.cc:
     - check for bzip2 in /bin (closes: #377391)
+  * apt-pkg/tagfile.cc:
+    - make it work on non-mapable files again, thanks 
+      to James Troup for confirming the fix (closes: #376777)
   * Merged from Christian Perrier bzr branch:
     * ko.po: Updated to 512t. Closes: #378901
     * hu.po: Updated to 512t. Closes: #376330