merged from lp:~donkult/apt/experimental
[ntk/apt.git] / debian / rules
index ef30568..6a5c95d 100755 (executable)
@@ -5,6 +5,7 @@
 
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
 
 # FOR AUTOCONF 2.52 AND NEWER ONLY
 ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
@@ -100,7 +101,12 @@ build/build-stamp: build/configure-stamp
        # compat symlink for the locale split
        mkdir -p build/usr/share 
        cd build/usr/share && ln -f -s ../../locale .
-       # done here
+       # compile and run tests
+ifeq (,$(findstring nocheck, $(DEB_BUILD_OPTIONS)))
+       $(MAKE) test
+else
+       @echo "Tests DISABLED"
+endif
        touch $@
 
 build/build-doc-stamp: build/configure-stamp
@@ -113,9 +119,31 @@ clean:
 
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
+       rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
+             debian/libapt-pkg-dev.install
+
+debian/%.install: debian/%.install.in
+       sed 's/@DEB_HOST_MULTIARCH@/$(DEB_HOST_MULTIARCH)/g' $< > $@
 
-binary-indep: apt-doc libapt-pkg-doc
+binary-indep: libapt-common apt-doc libapt-pkg-doc
 # Build architecture-independent files here.
+libapt-common: build
+       dh_testdir -p$@
+       dh_testroot -p$@
+       dh_prep -p$@
+       dh_installdirs -p$@
+
+       dh_install -p$@ --sourcedir=$(BLD)
+       dh_installdocs -p$@
+       dh_installchangelogs -p$@
+       dh_strip -p$@
+       dh_compress -p$@
+       dh_fixperms -p$@
+       dh_installdeb -p$@
+       dh_gencontrol -p$@
+       dh_md5sums -p$@
+       dh_builddeb -p$@
+
 libapt-pkg-doc: build-doc
        dh_testdir -p$@
        dh_testroot -p$@
@@ -124,9 +152,6 @@ libapt-pkg-doc: build-doc
 #
 # libapt-pkg-doc install
 #
-       # remove doxygen's embedded jquery as we don't use it anyway (#622147)
-       rm -f $(BLD)/doc/doxygen/html/jquery.js
-
        dh_installdocs -p$@ $(BLD)/docs/design* \
                            $(BLD)/docs/dpkg-tech* \
                            $(BLD)/docs/files* \
@@ -215,7 +240,7 @@ apt: build build-doc
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-libapt-pkg-dev: build
+libapt-pkg-dev: build debian/libapt-pkg-dev.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -263,7 +288,7 @@ apt-utils: build
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_PKG): build
+$(LIBAPT_PKG): build debian/$(LIBAPT_PKG).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -282,7 +307,7 @@ $(LIBAPT_PKG): build
        dh_md5sums -p$@
        dh_builddeb -p$@
 
-$(LIBAPT_INST): build
+$(LIBAPT_INST): build debian/$(LIBAPT_INST).install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@