* apt-pkg/deb/dpkgpm.cc:
[ntk/apt.git] / debian / changelog
index 12c7088..a08dce9 100644 (file)
@@ -1,4 +1,66 @@
-apt (0.7.26~exp12) UNRELEASEDexperimental; urgency=low
+apt (0.8.0~pre2) UNRELEASED; urgency=low
+
+  [ David Kalnischkies ]
+  * apt-pkg/contrib/strutl.cc:
+    - fix error checking for vsnprintf in its safe variant
+  * methods/bzip2.cc:
+    - fix error checking for read in case of failing bzip2/lzma/whatever
+  * debian/apt.cron.daily:
+    - create backups for our extended_states file (Closes: #593430)
+  * apt-pkg/init.cc:
+    - set the default values for dir::etc::trusted options correctly
+  * ftparchive/writer.cc:
+    - init valid-until correctly to prevent garbage entering Release file
+  * apt-pkg/deb/debsystem.cc:
+    - set dir::state::status based at least on dir
+  * apt-pkg/deb/dpkgpm.cc:
+    - use the InstVer instead of the CurrentVer for the autobit transfer
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Fri, 20 Aug 2010 19:06:29 +0200
+
+apt (0.8.0~pre1) experimental; urgency=low
+
+  [ Programs translations ]
+  * Swedish translation update. Closes: #592366
+
+  [ Michael Vogt ]
+  * merge of the debian-expermental-ma branch
+  * refresh po/pot files in doc/ and po/
+  * apt-pkg/pkgcache.cc:
+    - re-evaluate the architectures cache when the cache is (re)opened
+
+  [ Colin Watson ]
+  * apt-pkg/cdrom.cc:
+    - fix off-by-one error in DropBinaryArch
+
+  [ Julian Andres Klode ]
+  * apt-pkg/contrib/fileutl.cc:
+    - Add WriteAtomic mode.
+    - Revert WriteEmpty to old behavior (LP: #613211)
+  * apt-pkg, methods:
+    - Convert users of WriteEmpty to WriteAtomic.
+  * apt-pkg/depcache.cc:
+    - Only try upgrade for Breaks if there is a newer version, otherwise
+      handle it as Conflicts (by removing it) (helps for #591882).
+  * debian/control:
+    - Add dependency on gnupg to apt, apt-key uses it.
+
+  [ David Kalnischkies ]
+  * apt-pkg/algorithms.cc:
+    - let the problem resolver install packages to fix or-groups
+      as a needed remove nuked another or-member (helps for #591882)
+    - change the debug outputs to display also arch of the
+      package and version dependencies information
+  * cmdline/apt-get.cc:
+    - let APT::Get::Arch-Only in build-dep default to false again
+      (Closes: #592628) Thanks Mohamed Amine IL Idrissi for report!
+    - purge packages in 'rc' state, thanks Rogier! (Closes: #150831)
+  * apt-pkg/pkgcache.cc:
+    - fix LongDesc handling in LANG=C environment
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 13 Aug 2010 17:00:49 +0200
+
+apt (0.7.26~exp12) experimental; urgency=low
 
   [ Michael Vogt ]
   * debian/control:
@@ -15,9 +77,8 @@ apt (0.7.26~exp12) UNRELEASEDexperimental; urgency=low
     - remove libcurl3-gnutls-dev alternative as the package is gone
     - increase needed version of libcurl4-gnutls-dev to >= 7.19.0
       as we use CURLOPT_{ISSUERCERT,CRLFILE} (Closes: #589642)
-  * 
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Fri, 30 Jul 2010 11:01:18 +0200
+ -- Michael Vogt <mvo@debian.org>  Fri, 30 Jul 2010 11:55:48 +0200
 
 apt (0.7.26~exp11) experimental; urgency=low
 
@@ -343,6 +404,7 @@ apt (0.7.26~exp5) experimental; urgency=low
   [ Christian Perrier ]
   * Slovak translation update. Closes: #581159
   * Italian translation update. Closes: #581742
+  * Swedish translation update. Closes: #592366
 
  -- Michael Vogt <mvo@debian.org>  Tue, 25 May 2010 16:01:42 +0200