* apt-pkg/deb/dpkgpm.cc:
[ntk/apt.git] / debian / changelog
index 142d835..a08dce9 100644 (file)
@@ -1,5 +1,279 @@
-apt (0.7.26~exp6) UNRELEASED; urgency=low
+apt (0.8.0~pre2) UNRELEASED; urgency=low
 
+  [ David Kalnischkies ]
+  * apt-pkg/contrib/strutl.cc:
+    - fix error checking for vsnprintf in its safe variant
+  * methods/bzip2.cc:
+    - fix error checking for read in case of failing bzip2/lzma/whatever
+  * debian/apt.cron.daily:
+    - create backups for our extended_states file (Closes: #593430)
+  * apt-pkg/init.cc:
+    - set the default values for dir::etc::trusted options correctly
+  * ftparchive/writer.cc:
+    - init valid-until correctly to prevent garbage entering Release file
+  * apt-pkg/deb/debsystem.cc:
+    - set dir::state::status based at least on dir
+  * apt-pkg/deb/dpkgpm.cc:
+    - use the InstVer instead of the CurrentVer for the autobit transfer
+
+ -- David Kalnischkies <kalnischkies@gmail.com>  Fri, 20 Aug 2010 19:06:29 +0200
+
+apt (0.8.0~pre1) experimental; urgency=low
+
+  [ Programs translations ]
+  * Swedish translation update. Closes: #592366
+
+  [ Michael Vogt ]
+  * merge of the debian-expermental-ma branch
+  * refresh po/pot files in doc/ and po/
+  * apt-pkg/pkgcache.cc:
+    - re-evaluate the architectures cache when the cache is (re)opened
+
+  [ Colin Watson ]
+  * apt-pkg/cdrom.cc:
+    - fix off-by-one error in DropBinaryArch
+
+  [ Julian Andres Klode ]
+  * apt-pkg/contrib/fileutl.cc:
+    - Add WriteAtomic mode.
+    - Revert WriteEmpty to old behavior (LP: #613211)
+  * apt-pkg, methods:
+    - Convert users of WriteEmpty to WriteAtomic.
+  * apt-pkg/depcache.cc:
+    - Only try upgrade for Breaks if there is a newer version, otherwise
+      handle it as Conflicts (by removing it) (helps for #591882).
+  * debian/control:
+    - Add dependency on gnupg to apt, apt-key uses it.
+
+  [ David Kalnischkies ]
+  * apt-pkg/algorithms.cc:
+    - let the problem resolver install packages to fix or-groups
+      as a needed remove nuked another or-member (helps for #591882)
+    - change the debug outputs to display also arch of the
+      package and version dependencies information
+  * cmdline/apt-get.cc:
+    - let APT::Get::Arch-Only in build-dep default to false again
+      (Closes: #592628) Thanks Mohamed Amine IL Idrissi for report!
+    - purge packages in 'rc' state, thanks Rogier! (Closes: #150831)
+  * apt-pkg/pkgcache.cc:
+    - fix LongDesc handling in LANG=C environment
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 13 Aug 2010 17:00:49 +0200
+
+apt (0.7.26~exp12) experimental; urgency=low
+
+  [ Michael Vogt ]
+  * debian/control:
+    - add dependency on zlib-dev for libapt-pkg-dev
+
+  [ David Kalnischkies ]
+  * apt-pkg/cacheset.cc:
+    - [ABI BREAK] add an ErrorType option to CacheSetHelper
+  * cmdline/apt-cache.cc:
+    - use Notice instead of Error in the CacheSetHelper messages
+      for compat reasons. Otherwise tools like sbuild blow up
+    - return success in show if a virtual package was given
+  * debian/control:
+    - remove libcurl3-gnutls-dev alternative as the package is gone
+    - increase needed version of libcurl4-gnutls-dev to >= 7.19.0
+      as we use CURLOPT_{ISSUERCERT,CRLFILE} (Closes: #589642)
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 30 Jul 2010 11:55:48 +0200
+
+apt (0.7.26~exp11) experimental; urgency=low
+
+  [ Julian Andres Klode ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - Write architecture information to history file.
+    - Add to history whether a change was automatic or not.
+  * apt-pkg/contrib/fileutl.cc:
+    - Add FileFd::OpenDescriptor() (needed for python-apt's #383617).
+  * cmdline/apt-get.cc:
+    - Support large filesystems by using statvfs64() instead of statvfs()
+      and statfs64() instead of statfs() (Closes: #590513).
+  * apt-pkg/cdrom.cc:
+    - Use link() instead of rename() for creating the CD database backup;
+      otherwise there would be a short time without any database.
+
+  [ David Kalnischkies ]
+  * apt-pkg/depcache.cc:
+    - handle "circular" conflicts for "all" packages correctly
+  * cmdline/apt-cache.cc:
+    - be able to omit dependency types in (r)depends (Closes: #319006)
+    - show in (r)depends the canidate per default instead of newest
+    - share the (r)depends code instead of codecopy
+  * apt-pkg/cacheset.cc:
+    - move them back to the library as they look stable now
+    - add a 'newest' pseudo target release as in pkg/newest
+  * apt-pkg/pkgcache.cc:
+    - prefer non-virtual packages in FindPreferredPkg (Closes: #590041)
+  * test/integration/*:
+    - add with bug#590041 testcase a small test "framework"
+  * apt-pkg/orderlist.cc:
+    - try to install another or-group member in DepRemove before
+      breaking the or group (Closes: #590438)
+    - configure also the replacement before remove by adding Immediate flag
+  
+  [ Michael Vogt ]
+  * apt-pkg/contrib/error.{cc,h}
+    - docstring cleanup
+    - add inline DumpError() to avoid subtle API break
+
+ -- Michael Vogt <mvo@debian.org>  Thu, 29 Jul 2010 16:40:58 +0200
+
+apt (0.7.26~exp10) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * apt-pkg/contrib/error.{cc,h}:
+    - remove constness of va_list parameter to fix build on amd64 and co
+      Thanks Eric Valette! (Closes: #588610)
+  * apt-pkg/deb/debmetaindex.cc:
+    - do not query each architecture for flat file archives
+    - fix typo preventing display of architecture in Info()
+  * methods/bzip2.cc:
+    - add a copycat of the old gzip.cc as we need it for bzip2 and lzma
+
+  [ Martin Pitt ]
+  * debian/rules:
+    - Make DEB_BUILD_OPTIONS=noopt actually work by passing the right
+      CXXFLAGS.
+  * apt-pkg/contrib/fileutl.{h,cc}:
+    - Add support for reading of gzipped files with the new "ReadOnlyGzip"
+      OpenMode. (Closes: #188407)
+    - Link against zlib (in apt-pkg/makefile) and add zlib build dependency.
+    - [ABI BREAK] This adds a new private member to FileFd, but its
+      initialization is in the public header file.
+  * configure.in:
+    - Check for zlib library and headers.
+  * apt-pkg/acquire-item.cc, apt-pkg/deb/debindexfile.cc,
+    apt-pkg/deb/debrecords.cc, apt-pkg/deb/debsrcrecords.h,
+    cmdline/apt-cache.cc:
+    - Open Packages, Sources, and Translations indexes in "ReadOnlyGzip" mode.
+  * apt-pkg/deb/debindexfile.cc:
+    - If we do not find uncompressed package/source/translation indexes, look
+      for gzip compressed ones.
+  * apt-pkg/acquire-item.cc:
+    - If the Acquire::GzipIndexes option is true and we download a gzipped
+      index file, keep it as it is (and rename to .gz) instead of
+      uncompressing it.
+  * doc/apt.conf.5.xml:
+    - Document the new Acquire::GzipIndexes option.
+  * doc/po/apt-doc.pot, doc/po/de.po:
+    - German translation of new Acquire::GzipIndexes option.
+  * Add test/test-indexes.sh:
+    - Test behaviour of index retrieval and usage, in particular with
+      uncompressed and gzip compressed indexes.
+  * methods/gzip.cc: With FileFd now being able to read gzipped files, there
+    is no need for the gzip method any more to spawn an external gzip process.
+    Rewrite it to use FileFd directly, which makes the code a lot simpler, and
+    also using less memory and overhead.
+
+ -- Michael Vogt <mvo@debian.org>  Mon, 12 Jul 2010 11:41:01 +0200
+
+apt (0.7.26~exp9) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * doc/apt.conf.5.xml:
+    - add and document APT::Cache-{Start,Grow,Limit} options for mmap control
+  * apt-pkg/contrib/fileutl.cc:
+    - do not fail von double close()
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 09 Jul 2010 21:51:55 +0200
+
+apt (0.7.26~exp8) experimental; urgency=low
+
+  [ David Kalnischkies ]
+  * cmdline/cacheset.cc:
+    - doesn't include it in the library for now as it is too volatile
+    - get the candidate either from an already built depcache
+      or use the policy which is a bit faster than depcache generation
+    - get packages by task^ with FromTask()
+    - only print errors if all tries to get a package by string failed
+    - factor out code to get a single package FromName()
+    - check in Grouped* first without modifier interpretation
+  * cmdline/apt-get.cc:
+    - use the cachsets in the install commands
+    - make the specify order of packages irrelevant (Closes: #196021)
+  * apt-pkg/orderlist.cc:
+    - untouched packages are never missing
+  * apt-pkg/packagemanager.cc:
+    - packages that are not touched doesn't need to be unpacked
+  * debian/control:
+    - remove intltool's dependency as it is an ubuntu artefact
+  * apt-pkg/depcache.cc:
+    - SetCandidateVer for all pseudo packages
+    - SetReInstall for the "all" package of a pseudo package
+    - use the new MatchAgainstConfig for the DefaultRootSetFunc
+    - always mark the all package if a pseudo package is marked for install
+  * apt-pkg/contrib/error.{cc,h}:
+    - complete rewrite but use the same API
+    - add NOTICE and DEBUG as new types of a message
+    - add a simple stack handling to be able to delay error handling
+  * apt-pkg/aptconfiguration.cc:
+    - show a deprecation notice for APT::Acquire::Translation
+  * apt-pkg/contrib/configuration.{cc,h}:
+    - add a wrapper to match strings against configurable regex patterns
+  * apt-pkg/contrib/fileutl.cc:
+    - show notice about ignored file instead of being always silent
+    - add a Dir::Ignore-Files-Silently list option to control the notice
+  * apt-pkg/policy.h:
+    - add another round of const& madness as the previous round accidentally
+      NOT overrides the virtual GetCandidateVer() method (Closes: #587725)
+  * apt-pkg/pkgcachegen.{cc,h}:
+    - make the used MMap moveable (and therefore dynamic resizeable) by
+      applying (some) mad pointer magic (Closes: #195018)
+
+  [ Michael Vogt ]
+  * apt-pkg/deb/dpkgpm.cc:
+    - make the apt/term.log output unbuffered (thanks to Matt Zimmerman)
+
+  [ Julian Andres Klode ]
+  * methods/ftp.h:
+    - Handle different logins on the same server (Closes: #586904).
+  * apt-pkg/deb/deblistparser.cc:
+    - Handle architecture wildcards (Closes: #547724).
+  * apt-pkg/versionmatch.cc:
+    - Support matching pins by regular expressions or glob() like patterns,
+      regular expressions have to be put between to slashes; for example,
+      /.*/.
+  * apt-pkg/contrib/fileutl.cc:
+    - Make FileFd replace files atomically in WriteTemp mode (for cache, etc).
+  * debian/control:
+    - Set Standards-Version to 3.9.0
+
+ -- Michael Vogt <mvo@debian.org>  Fri, 09 Jul 2010 19:16:20 +0200
+
+apt (0.7.26~exp7) experimental; urgency=low
+
+  * apt-pkg/cachefile.h:
+    - make pkgPolicy public again, libapt-pkg-perl (and probably
+      others) get unhappy without that
+
+ -- Michael Vogt <mvo@debian.org>  Thu, 10 Jun 2010 15:33:24 +0200
+
+apt (0.7.26~exp6) experimental; urgency=low
+
+  [ Michael Vogt ]
+  * merge the remaining Ubuntu change:
+    - on gpg verification failure warn and restore the last known
+      good state
+    - on failure display the IP of the server (useful for servers
+      that use round robin DNS)
+    - support Original-Maintainer in RewritePackageOrder
+    - enable cdrom autodetection via libudev by default
+    - show message about Vcs in use when apt-get source is run for
+      packages maintained in a Vcs
+    - better support transitional packages with mark auto-installed. 
+      when the transitional package is in "oldlibs" the new package
+      is not marked auto installed (same is true for section
+      metapackages)
+    - provide new "deb mirror://archive.foo/mirrors.list sid main"
+      method expects a list of mirrors (generated on the server e.g.
+      via geoip) and will use that, including cycle on failure
+    - write apport crash file on package failure (disabled by default
+      on debian until apport is available)
+    - support mirror failure reporting (disabled by default on debian)
+  
   [ David Kalnischkies ]
   * apt-pkg/deb/dpkgpm.cc:
     - write Disappeared also to the history.log
@@ -20,9 +294,13 @@ apt (0.7.26~exp6) UNRELEASED; urgency=low
   * apt-pkg/aptconfiguration.cc:
     - remove duplicate architectures in getArchitectures()
   * apt-pkg/indexrecords.{cc,h}:
+    - backport forgotten Valid-Until patch from the obsolete experimental
+      branch to prevent replay attacks better, thanks to Thomas Viehmann
+      for the initial patch! (Closes: #499897)
     - add a constant Exists check for MetaKeys
   * apt-pkg/acquire-item.cc:
     - do not try PDiff if it is not listed in the Meta file
+    - sent Last-Modified header also for Translation files
   * apt-pkg/cacheiterator.h:
     - let pkgCache::Iterator inherent std::iterator
   * ftparchive/writer.h:
@@ -48,8 +326,22 @@ apt (0.7.26~exp6) UNRELEASED; urgency=low
     - split Open() into submethods to be able to build only parts
     - make the OpProgress optional in the Cache buildprocess
     - store also the SourceList we use internally for export
+  * doc/apt.conf.5.xml:
+    - document the new Valid-Until related options
+  * apt-pkg/contrib/strutl.cc:
+    - split StrToTime() into HTTP1.1 and FTP date parser methods and
+      use strptime() instead of some self-made scanf mangling
+    - use the portable timegm shown in his manpage instead of a strange
+      looking code copycat from wget
+  * ftparchive/writer.cc:
+    - add ValidTime option to generate a Valid-Until header in Release file
+  * apt-pkg/policy.cc:
+    - get the candidate right for a not-installed pseudo package if
+      his non-pseudo friend is installed
+  * apt-pkg/indexcopy.cc:
+    - move the gpg codecopy to a new method and use it also in methods/gpgv.cc
 
- -- David Kalnischkies <kalnischkies@gmail.com>  Wed, 09 Jun 2010 10:50:12 +0200
+ -- Michael Vogt <mvo@debian.org>  Thu, 10 Jun 2010 14:02:22 +0200
 
 apt (0.7.26~exp5) experimental; urgency=low
 
@@ -112,6 +404,7 @@ apt (0.7.26~exp5) experimental; urgency=low
   [ Christian Perrier ]
   * Slovak translation update. Closes: #581159
   * Italian translation update. Closes: #581742
+  * Swedish translation update. Closes: #592366
 
  -- Michael Vogt <mvo@debian.org>  Tue, 25 May 2010 16:01:42 +0200