fix documentation for APT::Periodic::MaxSize "0" (closes: #740551)
[ntk/apt.git] / debian / rules
index fc44d5a..eec0166 100755 (executable)
@@ -3,6 +3,9 @@
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
 # Some lines taken from debmake, by Christoph Lameter.
 
+# build in verbose mode by default to make it easy to diangose issues
+export NOISY=1
+
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 export DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
@@ -115,7 +118,7 @@ clean:
        [ ! -f Makefile ] || $(MAKE) clean distclean
        rm -rf build
        rm -f debian/$(LIBAPT_PKG).install debian/$(LIBAPT_INST).install \
-             debian/libapt-pkg-dev.install
+             debian/libapt-pkg-dev.install debian/apt.install
        test ! -L buildlib/config.guess || rm -f buildlib/config.guess
        test ! -L buildlib/config.sub || rm -f buildlib/config.sub
 
@@ -131,6 +134,7 @@ libapt-pkg-doc: build-debiandoc
 #
 # libapt-pkg-doc install
 #
+       rm -f $(BLD)/doc/doxygen/html/*.map $(BLD)/doc/doxygen/html/*.md5
        dh_installdocs -p$@ $(BLD)/docs/design* \
                            $(BLD)/docs/dpkg-tech* \
                            $(BLD)/docs/files* \
@@ -142,7 +146,7 @@ libapt-pkg-doc: build-debiandoc
 
        dh_installchangelogs -p$@
        dh_strip -p$@
-       dh_compress -p$@
+       dh_compress -p$@ -X.xhtml
        dh_fixperms -p$@
        dh_installdeb -p$@
        dh_gencontrol -p$@
@@ -174,7 +178,7 @@ apt-doc: build-debiandoc
 # Build architecture-dependent files here.
 
 apt_MANPAGES = apt apt-cache apt-cdrom apt-config apt-get apt-key apt-mark apt-secure apt apt.conf apt_preferences sources.list
-apt: build-binary build-manpages
+apt: build-binary build-manpages debian/apt.install
        dh_testdir -p$@
        dh_testroot -p$@
        dh_prep -p$@
@@ -203,6 +207,9 @@ apt: build-binary build-manpages
        #mv debian/$@/usr/bin/apt-report-mirror-failure \
        #   debian/$@/usr/lib/apt/apt-report-mirror-failure \
 
+       # move the apt-helper in place
+       mv debian/$@/usr/bin/apt-helper debian/$@/usr/lib/apt/apt-helper 
+
        dh_bugfiles -p$@
        dh_lintian -p$@
        dh_installexamples -p$@ $(BLD)/docs/examples/*
@@ -214,9 +221,10 @@ apt: build-binary build-manpages
        dh_strip -p$@
        dh_compress -p$@
        dh_fixperms -p$@
+       dh_makeshlibs -p$@
        dh_installdeb -p$@
        dh_shlibdeps -p$@
-       dh_gencontrol -p$@
+       dh_gencontrol -p$@ -- -Vapt:keyring="$(shell ./vendor/getinfo keyring-package)"
        dh_md5sums -p$@
        dh_builddeb -p$@