gnu: Add ocrodjvu.
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
index fb5712a..98acc3c 100644 (file)
@@ -1,5 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages gsasl)
   #:use-module (gnu packages)
-  #:use-module ((gnu packages compression)
-                #:renamer (symbol-prefix-proc 'guix:))
-  #:use-module (gnu packages gnutls)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages libidn)
+  #:use-module (gnu packages gnupg)
   #:use-module (gnu packages nettle)
-  #:use-module (gnu packages shishi)
-  #:use-module (guix licenses)
+  #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages tls)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
 
 (define-public libntlm
   (package
-   (name "libntlm")
-   (version "1.3")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "http://www.nongnu.org/libntlm/releases/libntlm-" version
-                                ".tar.gz"))
-            (sha256 (base32
-                     "101pr110ardcj2di940g6vaqifsaxc44h6hjn81l63dvmkj5a6ga"))))
-   (build-system gnu-build-system)
-   (synopsis "Libntlm, a library that implements NTLM authentication")
-   (description
-    "Libntlm is a library that implements NTLM authentication")
-   (license lgpl2.1+)
-   (home-page "http://www.nongnu.org/libntlm/")))
+    (name "libntlm")
+    (version "1.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.nongnu.org/libntlm/releases/"
+                                  "libntlm-" version ".tar.gz"))
+              (sha256
+               (base32
+                "08b83nss16jsn213j326yhn1vnrz10k15fwq6jm5b1vdn23nndzj"))))
+    (build-system gnu-build-system)
+    (synopsis "Library that implements NTLM authentication")
+    (description
+     "Libntlm is a library that implements NTLM authentication.")
+    (license license:lgpl2.1+)
+    (home-page "https://www.nongnu.org/libntlm/")))
 
 (define-public gss
   (package
    (name "gss")
-   (version "1.0.2")
+   (version "1.0.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gss/gss-" version
                                 ".tar.gz"))
             (sha256 (base32
-                     "1qa8lbkzi6ilfggx7mchfzjnchvhwi68rck3jf9j4425ncz7zsd9"))))
+                     "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
    (build-system gnu-build-system)
    (inputs `(("nettle" ,nettle)
              ("shishi" ,shishi)
-             ("zlib" ,guix:zlib)
-            ))
+             ("zlib" ,zlib)))
    (synopsis "Generic Security Service library")
    (description
-    "GNU GSS is an implementation of the Generic Security Service Application
-Program Interface (GSS-API). GSS-API is used by network servers to provide
-security services, e.g., to authenticate SMTP/IMAP clients against
-SMTP/IMAP servers. GSS consists of a library and a manual.")
-   (license gpl3+)
-   (home-page "http://www.gnu.org/software/gss/")))
+    "The GNU Generic Security Service provides a free implementation of the
+GSS-API specification.  It provides a generic application programming
+interface for programs to access security services.  Security services present
+a generic, GSS interface, with which the calling application interacts via
+this library, freeing the application developer from needing to know about
+the underlying security implementation.")
+   (license license:gpl3+)
+   (home-page "https://www.gnu.org/software/gss/")))
 
 (define-public gsasl
   (package
    (name "gsasl")
-   (version "1.8.0")
+   (version "1.8.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gsasl/gsasl-" version
                                 ".tar.gz"))
-            (sha256 (base32
-                     "1rci64cxvcfr8xcjpqc4inpfq7aw4snnsbf5xz7d30nhvv8n40ii"))))
+            (sha256
+             (base32
+              "1lnqfbaajkj1r2fx1db1qgcxy69pfgbyq7xd2kpvyxhra4m1dnjd"))))
    (build-system gnu-build-system)
-   (inputs `(("libidn" ,libidn)
-             ("libntlm" ,libntlm)
-             ("gnutls" ,gnutls)
-             ("gss" ,gss)
-             ("zlib" ,guix:zlib)
-             ))
+   (arguments
+    `(#:configure-flags '("--with-gssapi-impl=mit"
+                          "--disable-static")))
+   (inputs
+    `(("libgcrypt" ,libgcrypt)
+      ("libidn" ,libidn)
+      ("libntlm" ,libntlm)
+      ("mit-krb5" ,mit-krb5)
+      ("zlib" ,zlib)))
+   (propagated-inputs
+    ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
+    ;; propagated input of GnuTLS.
+    `(("gnutls" ,gnutls)))
    (synopsis "Simple Authentication and Security Layer library")
    (description
-    "GNU SASL is an implementation of the Simple Authentication and Security
-Layer framework and a few common SASL mechanisms. SASL is used by network
-servers (e.g., IMAP, SMTP) to request authentication from clients, and in
-clients to authenticate against servers.
-
-GNU SASL consists of a library (libgsasl), a command line utility (gsasl)
-to access the library from the shell, and a manual. The library includes
-support for the framework (with authentication functions and application
-data privacy and integrity functions) and at least partial support for the
-CRAM-MD5, EXTERNAL, GSSAPI, ANONYMOUS, PLAIN, SECURID, DIGEST-MD5,
-SCRAM-SHA-1, SCRAM-SHA-1-PLUS, LOGIN, and NTLM mechanisms.
-
-The library is portable because it does not do network communication by
-itself, but rather leaves it up to the calling application. The library is
-flexible with regards to the authorization infrastructure used, as it
-utilises callbacks into the application to decide whether an user is
-authorised or not.
-
-The gsasl package distribution includes the library part as well,
-so there is no need to install two packages.")
-   (license gpl3+)
-   (home-page "http://www.gnu.org/software/gsasl/")))
+    "GNU SASL is an implementation of the Simple Authentication and
+Security Layer framework.  On network servers such as IMAP or SMTP servers,
+SASL is used to handle client/server authentication.  This package contains
+both a library and a command-line tool to access the library.")
+   (license license:gpl3+)
+   (home-page "https://www.gnu.org/software/gsasl/")))