hydra: Fix typo in core package list.
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
index dbdfa22..6fff0db 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xml))
 
+(define-public gvpe
+  (package
+    (name "gvpe")
+    (version "2.25")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gvpe/gvpe-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1gsipcysvsk80gvyn9jnk9g0xg4ng9yd5zp066jnmpgs52d2vhvk"))))
+    (build-system gnu-build-system)
+    (home-page "http://software.schmorp.de/pkg/gvpe.html")
+    (inputs `(("openssl" ,openssl)
+              ("zlib" ,zlib)))
+    (synopsis "Secure VPN among multiple nodes over an untrusted network")
+    (description
+     "The GNU Virtual Private Ethernet creates a virtual network
+with multiple nodes using a variety of transport protocols.  It works
+by creating encrypted host-to-host tunnels between multiple
+endpoints.")
+    (license license:gpl3+)))
+
 (define-public vpnc
   (package
    (name "vpnc")
@@ -57,7 +81,7 @@
            (substitute* "Makefile"
              (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out "/etc/vpnc")))))
        %standard-phases)))
-   (synopsis "vpnc, a client for cisco vpn concentrators")
+   (synopsis "Client for Cisco VPN concentrators")
    (description
     "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
 It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
@@ -80,12 +104,13 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
                      "1rd8pap455wzkx19i0sy3cqap524b6fwcjvqynxp6lhm01di4bd6"))))
    (build-system gnu-build-system)
    (inputs
-    `(("gettext" ,gnu-gettext)
-      ("libxml2" ,libxml2)
+    `(("libxml2" ,libxml2)
       ("openssl" ,openssl)
-      ("pkg-config" ,pkg-config)
       ("vpnc" ,vpnc)
       ("zlib" ,zlib)))
+   (native-inputs
+    `(("gettext" ,gnu-gettext)
+      ("pkg-config" ,pkg-config)))
    (arguments
     `(#:phases
       (alist-replace
@@ -100,7 +125,7 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
                                                      vpnc
                                                      "/etc/vpnc/vpnc-script")))))))
        %standard-phases)))
-   (synopsis "client for cisco vpn")
+   (synopsis "Client for Cisco VPN")
    (description
     "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,