gnu: hidapi: Fix 'license'.
[jackhill/guix/guix.git] / gnu / packages / imagemagick.scm
index 095f662..071d42a 100644 (file)
@@ -2,6 +2,8 @@
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23,6 +25,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system perl)
   #:use-module (guix download)
+  #:use-module (guix hg-download)
   #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages)
 (define-public imagemagick
   (package
     (name "imagemagick")
-    (version "6.9.3-10")
+    (version "6.9.6-3")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://imagemagick/ImageMagick-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0sik2jl1cywnpr5xm28mjhs1l8kxry65f3v2kqzp0cczhwf04gz3"))))
+               "0min87mdhv6bni5hz99i3j1wkrjrqp88dx4ckjzmilg28p9ick63"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--with-frozenpaths")
+     `(#:configure-flags '("--with-frozenpaths" "--without-gcc-arch")
+       ;; FIXME: The test suite succeeded before version 6.9.6-2.
+       ;; Try enabling it again with newer releases.
+       #:tests? #f
        #:phases (modify-phases %standard-phases
                   (add-before
                    'build 'pre-build
     (home-page "http://www.imagemagick.org/")
     (synopsis "Create, edit, compose, or convert bitmap images")
     (description
-     "ImageMagick® is a software suite to create, edit, compose, or convert
+     "ImageMagick is a software suite to create, edit, compose, or convert
 bitmap images.  It can read and write images in a variety of formats (over 100)
 including DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript, SVG,
 and TIFF.  Use ImageMagick to resize, flip, mirror, rotate, distort, shear and
@@ -123,7 +129,8 @@ text, lines, polygons, ellipses and Bézier curves.")
     (native-inputs `(("pkg-config" ,pkg-config)))
     (inputs `(("imagemagick" ,imagemagick)))
     (arguments
-     `(#:phases
+     `(#:tests? #f ;;Failed 2/23 test programs. 2/353 subtests failed.
+       #:phases
        (modify-phases %standard-phases
          (add-before
           'configure 'image-magick-flags
@@ -152,48 +159,55 @@ script.")
     (license (package-license imagemagick))))
 
 (define-public graphicsmagick
-  (package
-    (name "graphicsmagick")
-    (version "1.3.23")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "ftp://ftp.graphicsmagick.org/pub/"
-                                 "GraphicsMagick/" (version-major+minor version)
-                                 "/GraphicsMagick-" version ".tar.xz"))
-             (sha256
-              (base32
-               "03g6l2h8cmf231y1vma0z7x85070jm1ysgs9ppqcd3jj56jka9gx"))))
-    (build-system gnu-build-system)
-    (arguments
-     `(#:configure-flags
-       (list "--with-frozenpaths"
-             "--enable-shared=yes"
-             "--with-x=yes"
-             (string-append "--with-gs-font-dir="
-                            (assoc-ref %build-inputs "gs-fonts")
-                            "/share/fonts/type1/ghostscript"))))
-    (inputs
-     `(("graphviz" ,graphviz)
-       ("ghostscript" ,ghostscript)
-       ("gs-fonts" ,gs-fonts)
-       ("lcms" ,lcms)
-       ("libx11" ,libx11)
-       ("libxml2" ,libxml2)
-       ("libtiff" ,libtiff)
-       ("libpng" ,libpng)
-       ("libjpeg" ,libjpeg)
-       ("freetype" ,freetype)
-       ("bzip2" ,bzip2)
-       ("xz" ,xz)
-       ("zlib" ,zlib)))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (outputs '("out"   ; 13 MiB
-               "doc")) ; ~7 MiB
-    (home-page "http://www.graphicsmagick.org")
-    (synopsis "Create, edit, compose, or convert bitmap images")
-    (description
-     "GraphicsMagick provides a comprehensive collection of utilities,
+  (let ((changeset "56c8cae")  ; 3e01b
+        (revision "1"))
+    (package
+      (name "graphicsmagick")
+      (version (string-append "1.3.25-" revision "." changeset))
+      (source (origin
+                (method hg-fetch)
+                (uri (hg-reference
+                      (url "http://hg.code.sf.net/p/graphicsmagick/code")
+                      (changeset changeset)))
+                (file-name (string-append name "-" version "-checkout"))
+                ;;(method url-fetch)
+                ;;(uri (string-append "ftp://ftp.graphicsmagick.org/pub/"
+                ;;                    "GraphicsMagick/" (version-major+minor version)
+                ;;                    "/GraphicsMagick-" version ".tar.xz"))
+                (sha256
+                 (base32
+                  "1s9apvkn0kxr6i4i5wlkfw1prja02rgk689n3cf822zc0dkycxdh"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:configure-flags
+         (list "--with-frozenpaths"
+               "--enable-shared=yes"
+               "--with-x=yes"
+               (string-append "--with-gs-font-dir="
+                              (assoc-ref %build-inputs "gs-fonts")
+                              "/share/fonts/type1/ghostscript"))))
+      (inputs
+       `(("graphviz" ,graphviz)
+         ("ghostscript" ,ghostscript)
+         ("gs-fonts" ,gs-fonts)
+         ("lcms" ,lcms)
+         ("libx11" ,libx11)
+         ("libxml2" ,libxml2)
+         ("libtiff" ,libtiff)
+         ("libpng" ,libpng)
+         ("libjpeg" ,libjpeg)
+         ("freetype" ,freetype)
+         ("bzip2" ,bzip2)
+         ("xz" ,xz)
+         ("zlib" ,zlib)))
+      (native-inputs
+       `(("pkg-config" ,pkg-config)))
+      (outputs '("out"                  ; 13 MiB
+                 "doc"))                ; ~7 MiB
+      (home-page "http://www.graphicsmagick.org")
+      (synopsis "Create, edit, compose, or convert bitmap images")
+      (description
+       "GraphicsMagick provides a comprehensive collection of utilities,
 programming interfaces, and GUIs, to support file format conversion, image
 processing, and 2D vector rendering.")
-    (license license:expat)))
+      (license license:expat))))