gnu: python-pathpy: Build documentation.
[jackhill/guix/guix.git] / gnu / packages / openldap.scm
index 429078f..627319b 100644 (file)
@@ -34,9 +34,8 @@
 
 (define-public openldap
   (package
-   (replacement openldap-2.4.44)
    (name "openldap")
-   (version "2.4.42")
+   (version "2.4.44")
    (source (origin
             (method url-fetch)
 
                         "openldap-release/openldap-" version ".tgz")))
             (sha256
              (base32
-              "0qwfpb5ipp2l76v11arghq5mr0sjc6xhjfg8a0kgsaw5qpib1dzf"))))
+              "0044p20hx07fwgw2mbwj1fkx04615hhs1qyx4mawj2bhqvrnppnp"))))
    (build-system gnu-build-system)
-   (inputs `(("bdb" ,bdb)
-             ("openssl" ,openssl)
+   (inputs `(("bdb" ,bdb-5.3)
              ("cyrus-sasl" ,cyrus-sasl)
+             ("gnutls" ,gnutls)
              ("groff" ,groff)
              ("icu4c" ,icu4c)
              ("libgcrypt" ,libgcrypt)
-             ;; FIXME: currently, openldap requires openssl or gnutls<3, see
-             ;; http://www.openldap.org/its/index.cgi/Incoming?id=7430;page=17
-             ;; Once this is fixed, switch to gnutls.
              ("zlib" ,zlib)))
    (native-inputs `(("libtool" ,libtool)))
    (arguments
     "OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")
    (license openldap2.8)
    (home-page "http://www.openldap.org/")))
-
-(define openldap-2.4.44
-  (package
-    (inherit openldap)
-    (replacement #f)
-    (source
-      (let ((version "2.4.44"))
-        (origin
-          (method url-fetch)
-          (uri (list (string-append
-                      "ftp://mirror.switch.ch/mirror/OpenLDAP/"
-                      "openldap-release/openldap-" version ".tgz")
-                     (string-append
-                      "ftp://ftp.OpenLDAP.org/pub/OpenLDAP/"
-                      "openldap-release/openldap-" version ".tgz")
-                     (string-append
-                      "ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/"
-                      "openldap-release/openldap-" version ".tgz")))
-          (sha256
-           (base32
-            "0044p20hx07fwgw2mbwj1fkx04615hhs1qyx4mawj2bhqvrnppnp")))))))