gnu: watchexec: Update to 1.14.1.
[jackhill/guix/guix.git] / gnu / packages / printers.scm
index 2d608bf..e03582c 100644 (file)
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2019, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -42,7 +42,7 @@
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/Timmmm/robocut.git")
+             (url "https://github.com/Timmmm/robocut")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
@@ -75,20 +75,20 @@ with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
     (license license:gpl3+)))
 
 (define-public brlaser
-  (let ((commit "779f71e80fcc583f4537c844de141cf8e6a738fe")
+  (let ((commit "9d7ddda8383bfc4d205b5e1b49de2b8bcd9137f1")
         (revision "1"))
     (package
       (name "brlaser")
-      (version (git-version "4" revision commit))
+      (version (git-version "6" revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
-                      (url "https://github.com/pdewacht/brlaser.git")
+                      (url "https://github.com/pdewacht/brlaser")
                       (commit commit)))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0yrz9706660hdfi2y0ndp254r0vw9y665hwmxbbzfnz4ai13vj50"))))
+                  "1drh0nk7amn9a8wykki4l9maqa4vy7vwminypfy1712alwj31nd4"))))
       (build-system cmake-build-system)
       (arguments
        `(#:configure-flags
@@ -108,19 +108,35 @@ with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
 driver is known to work with these printers:
 
 @enumerate
-@item Brother DCP-1510
+@item Brother DCP-1510 series
+@item Brother DCP-1600 series
 @item Brother DCP-7030
 @item Brother DCP-7040
 @item Brother DCP-7055
 @item Brother DCP-7055W
+@item Brother DCP-7060D
 @item Brother DCP-7065DN
 @item Brother DCP-7080
+@item Brother DCP-L2500D series
+@item Brother DCP-L2520D series
+@item Brother DCP-L2540DW series
+@item Brother HL-1110 series
 @item Brother HL-1200 series
+@item Brother HL-2030 series
+@item Brother HL-2140 series
+@item Brother HL-2220 series
+@item Brother HL-2270DW series
+@item Brother HL-5030 series
+@item Brother HL-L2300D series
 @item Brother HL-L2320D series
+@item Brother HL-L2340D series
 @item Brother HL-L2360D series
+@item Brother MFC-1910W
 @item Brother MFC-7240
 @item Brother MFC-7360N
-@end enumerate
-
-It partially works with printers from the Brother HL-L2300D series.")
+@item Brother MFC-7365DN
+@item Brother MFC-7840W
+@item Brother MFC-L2710DW series
+@item Lenovo M7605D
+@end enumerate")
       (license license:gpl2+))))