gnu: rust-clap-3: Update to 3.1.18.
[jackhill/guix/guix.git] / gnu / packages / crates-io.scm
index 7281053..8db968a 100644 (file)
@@ -4427,7 +4427,7 @@ asynchronous logging.")
         ("rust-syn" ,rust-syn-0.15))))
     (home-page "https://github.com/rustasync/runtime")
     (synopsis
-     "Proc Macro attributes for the async-log crate.")
+     "Proc Macro attributes for the async-log crate")
     (description
      "This package provides proc macro attributes for the @code{async-log}
 crate.")
@@ -4901,7 +4901,7 @@ methods.")
      `(#:cargo-inputs
        (("rust-critical-section" ,rust-critical-section-1))))
     (home-page "https://github.com/embassy-rs/atomic-polyfill")
-    (synopsis "Atomic polyfills, for targets where they're not available.")
+    (synopsis "Atomic polyfills, for targets where they're not available")
     (description "This package provides atomic polyfills, for targets where
 they're not available.")
     (license (list license:expat license:asl2.0))))
@@ -9417,7 +9417,7 @@ optional dependency graph analysis.")
 (define-public rust-cargo-platform-0.1
   (package
     (name "rust-cargo-platform")
-    (version "0.1.2")
+    (version "0.1.1")
     (source
      (origin
        (method url-fetch)
@@ -9426,7 +9426,7 @@ optional dependency graph analysis.")
         (string-append name "-" version ".tar.gz"))
        (sha256
         (base32
-         "09zsf76b9yr02jh17xq925xp1w824w2bwvb78fd0gpx5m1fq5nyb"))))
+         "1mzi60pf0z83qkzqp7jwd61xnqz2b5ydsj7rnnikbgyicd5989h2"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -10458,23 +10458,20 @@ traits.")
 (define-public rust-clap-derive-3
   (package
     (name "rust-clap-derive")
-    (version "3.0.0-beta.2")
+    (version "3.1.18")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "clap_derive" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "18cn82jhcha7m0nkpi1a03jx8k7aaq5kxfcxnsqpaa8ih5dp23rp"))))
+        (base32 "0g53w6qkqcc122bqh51jzfg51147il643idvq1czxkr2x5306ci5"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
-       (("rust-heck" ,rust-heck-0.3)
-        ("rust-proc-macro-error"
-         ,rust-proc-macro-error-1)
+       (("rust-heck" ,rust-heck-0.4)
+        ("rust-proc-macro-error" ,rust-proc-macro-error-1)
         ("rust-proc-macro2" ,rust-proc-macro2-1)
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))
@@ -10489,36 +10486,41 @@ derive crate.")
 (define-public rust-clap-3
   (package
     (name "rust-clap")
-    (version "3.0.0-beta.2")
+    (version "3.1.18")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "clap" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "0hm1kivw6190rxbfqhdr4hqwlrijvwh90i3d9dyyw0d5k0chdlab"))))
+        (base32 "02s4hk9hrmm2s1j7dkbwpyd75mfzx3p8ks2chmp4ccybv95xznyj"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
+     `(#:skip-build? #t
+       #:cargo-inputs
        (("rust-atty" ,rust-atty-0.2)
+        ("rust-backtrace" ,rust-backtrace-0.3)
         ("rust-bitflags" ,rust-bitflags-1)
         ("rust-clap-derive" ,rust-clap-derive-3)
+        ("rust-clap-lex" ,rust-clap-lex-0.2)
         ("rust-indexmap" ,rust-indexmap-1)
-        ("rust-os-str-bytes" ,rust-os-str-bytes-2)
+        ("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-regex" ,rust-regex-1)
         ("rust-strsim" ,rust-strsim-0.10)
         ("rust-termcolor" ,rust-termcolor-1)
         ("rust-terminal-size" ,rust-terminal-size-0.1)
-        ("rust-textwrap" ,rust-textwrap-0.12)
-        ("rust-unicode-width" ,rust-unicode-width-0.1)
-        ("rust-vec-map" ,rust-vec-map-0.8)
+        ("rust-textwrap" ,rust-textwrap-0.15)
+        ("rust-unicase" ,rust-unicase-2)
         ("rust-yaml-rust" ,rust-yaml-rust-0.4))
        #:cargo-development-inputs
        (("rust-criterion" ,rust-criterion-0.3)
+        ("rust-humantime" ,rust-humantime-2)
         ("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-regex" ,rust-regex-1)
-        ("rust-version-sync" ,rust-version-sync-0.8))))
+        ("rust-rustversion" ,rust-rustversion-1)
+        ("rust-shlex" ,rust-shlex-1)
+        ("rust-snapbox" ,rust-snapbox-0.4)
+        ("rust-trybuild" ,rust-trybuild-1))))
     (home-page "https://clap.rs/")
     (synopsis "Command Line Argument Parser")
     (description
@@ -10734,7 +10736,7 @@ pitfalls in Rust.")
         ("rust-toml" ,rust-toml-0.4)
         ("rust-unicode-normalization" ,rust-unicode-normalization-0.1))))
     (home-page "https://github.com/rust-lang-nursery/rust-clippy")
-    (synopsis "A bunch of helpful lints to avoid common pitfalls in Rust")
+    (synopsis "helpful lints to avoid common pitfalls in Rust")
     (description
      "This package provides a bunch of helpful lints to avoid common pitfalls
 in Rust")
@@ -23244,7 +23246,7 @@ getters and setters on fields.")
 (define-public rust-gfa-0.10
   (package
     (name "rust-gfa")
-    (version "0.10.0")
+    (version "0.10.1")
     (source
       (origin
         (method url-fetch)
@@ -23253,7 +23255,7 @@ getters and setters on fields.")
          (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "1hadm6vfjwyqw41bqci18wb4wv80rydmrag7a5c02pdp1gid14fw"))))
+          "1x996rpfnflgi2j4dgaj5sdxdbf24zfm9d2ha0zy8aid0cd60cln"))))
     (build-system cargo-build-system)
     (arguments
      `(#:cargo-inputs
@@ -23507,7 +23509,7 @@ dirty state into your program.")
      `(("pkg-config" ,pkg-config)
        ("git" ,git-minimal)))           ;for a single test
     (inputs
-     (list libgit2-1.3 libssh2 openssl zlib))
+     (list libgit2 libssh2 openssl zlib))
     (home-page "https://github.com/rust-lang/git2-rs")
     (synopsis "Rust bindings to libgit2")
     (description
@@ -23571,7 +23573,9 @@ reading and writing git repositories.")
        #:cargo-development-inputs
        (("rust-paste" ,rust-paste-1)
         ("rust-structopt" ,rust-structopt-0.3)
-        ("rust-time" ,rust-time-0.1))))))
+        ("rust-time" ,rust-time-0.1))))
+    (inputs
+     (list libgit2-1.3 libssh2 openssl zlib))))
 
 (define-public rust-git2-0.11
   (package
@@ -33236,7 +33240,7 @@ checking.")
     (build-system cargo-build-system)
     (home-page "https://github.com/reem/rust-modifier")
     (synopsis
-      "Chaining APIs for both self -> Self and &mut self methods.")
+      "Chaining APIs for both self -> Self and &mut self methods")
     (description
       "Chaining APIs for both self -> Self and &mut self methods.")
     (license license:expat)))
@@ -37174,7 +37178,7 @@ the default program configured on the system.")
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))
     (home-page "https://github.com/sfackler/rust-openssl")
-    (synopsis "Internal macros used by the openssl crate.")
+    (synopsis "Internal macros used by the openssl crate")
     (description "This package provides internal macros used by the openssl
 crate.")
     (license (list license:expat license:asl2.0))))
@@ -41013,41 +41017,6 @@ applications.")
         ("rust-regex" ,rust-regex-1)
         ("rust-simdutf8" ,rust-simdutf8-0.1))))))
 
-(define-public rust-polars-io-0.14
-  (package
-    (inherit rust-polars-io-0.15)
-    (name "rust-polars-io")
-    (version "0.14.8")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "polars-io" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0fha62dln5xv2sa38jrfmd7amj9557y66dy8v44gn9j896mqm6fd"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-ahash" ,rust-ahash-0.7)
-        ("rust-anyhow" ,rust-anyhow-1)
-        ("rust-arrow" ,rust-arrow-4)
-        ("rust-csv" ,rust-csv-1)
-        ("rust-csv-core" ,rust-csv-core-0.1)
-        ("rust-dirs" ,rust-dirs-3)
-        ("rust-fast-float" ,rust-fast-float-0.2)
-        ("rust-flate2" ,rust-flate2-1)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-lexical" ,rust-lexical-5)
-        ("rust-memmap2" ,rust-memmap2-0.2)
-        ("rust-num" ,rust-num-0.4)
-        ("rust-num-cpus" ,rust-num-cpus-1)
-        ("rust-parquet" ,rust-parquet-4)
-        ("rust-polars-arrow" ,rust-polars-arrow-0.14)
-        ("rust-polars-core" ,rust-polars-core-0.14)
-        ("rust-rayon" ,rust-rayon-1)
-        ("rust-regex" ,rust-regex-1)
-        ("rust-simdutf8" ,rust-simdutf8-0.1))))))
-
 (define-public rust-polars-lazy-0.17
   (package
     (name "rust-polars-lazy")
@@ -41100,29 +41069,6 @@ library.")
         ("rust-rayon" ,rust-rayon-1)
         ("rust-regex" ,rust-regex-1))))))
 
-(define-public rust-polars-lazy-0.15
-  (package
-    (inherit rust-polars-lazy-0.16)
-    (name "rust-polars-lazy")
-    (version "0.15.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "polars-lazy" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0xh3a0gjsisx62zwjmawxg9giin7bwmh7z7y4cc2d3ygy8nk19jh"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-ahash" ,rust-ahash-0.7)
-        ("rust-itertools" ,rust-itertools-0.10)
-        ("rust-polars-arrow" ,rust-polars-arrow-0.15)
-        ("rust-polars-core" ,rust-polars-core-0.15)
-        ("rust-polars-io" ,rust-polars-io-0.15)
-        ("rust-rayon" ,rust-rayon-1)
-        ("rust-regex" ,rust-regex-1))))))
-
 (define-public rust-polling-2
   (package
     (name "rust-polling")
@@ -46745,8 +46691,7 @@ table-based tests.")
      (list bash-minimal m4))
     (home-page "https://gitlab.com/tspiteri/rug")
     (synopsis
-      "Arbitrary-precision integers, rational, floating-point and complex numbers based
-on GMP, MPFR and MPC")
+      "Arbitrary-precision integers, rational, floating-point and complex numbers")
     (description "This is a Rust library of arbitrary-precision integers, rational,
 floating-point, and complex numbers based on GMP, MPFR and MPC.")
     (license license:lgpl3+)))
@@ -47391,35 +47336,6 @@ the file-system during development.")
 library.")
     (license license:expat)))
 
-(define-public rust-rustc-ap-arena-654
-  (package
-    (name "rust-rustc-ap-arena")
-    (version "654.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "rustc-ap-arena" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "18yc4i5m2vf6w8na29i5jv8l4l0yknsf6xn0z2mk7mfz1nxwzpw1"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-rustc-ap-rustc-data-structures"
-         ,rust-rustc-ap-rustc-data-structures-654)
-        ("rust-smallvec" ,rust-smallvec-1))))
-    (home-page  "https://github.com/alexcrichton/rustc-auto-publish")
-    (synopsis
-     "Automatically published version of the arena package used in rustc")
-    (description
-     "Use the arena library used in the Rust compiler with this crate.
-It is automatically published using the compiler repository at
-@url{https://www.github.com/rust-lang/rust}")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-rustc-ap-graphviz-654
   (package
     (name "rust-rustc-ap-graphviz")
@@ -47443,51 +47359,6 @@ It is automatically published using the compiler repository at
 @url{https://www.github.com/rust-lang/rust}")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-rustc-ap-rustc-data-structures-654
-  (package
-    (name "rust-rustc-ap-rustc-data-structures")
-    (version "654.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "rustc-ap-rustc_data_structures" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0fhppy18n1i2iykdihfs05d6s1ivwz882ipc9cpnjcvqcsbhj4yj"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-bitflags" ,rust-bitflags-1)
-        ("rust-cfg-if" ,rust-cfg-if-0.1)
-        ("rust-crossbeam-utils" ,rust-crossbeam-utils-0.7)
-        ("rust-ena" ,rust-ena-0.13)
-        ("rust-indexmap" ,rust-indexmap-1)
-        ("rust-jobserver" ,rust-jobserver-0.1)
-        ("rust-lazy-static" ,rust-lazy-static-1)
-        ("rust-libc" ,rust-libc-0.2)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-measureme" ,rust-measureme-0.7)
-        ("rust-parking-lot" ,rust-parking-lot-0.10)
-        ("rust-rustc-ap-graphviz" ,rust-rustc-ap-graphviz-654)
-        ("rust-rustc-ap-rustc-index" ,rust-rustc-ap-rustc-index-654)
-        ("rust-rustc-ap-serialize" ,rust-rustc-ap-serialize-654)
-        ("rust-rustc-hash" ,rust-rustc-hash-1)
-        ("rust-rustc-rayon" ,rust-rustc-rayon-0.3)
-        ("rust-rustc-rayon-core" ,rust-rustc-rayon-core-0.3)
-        ("rust-smallvec" ,rust-smallvec-1)
-        ("rust-stable-deref-trait" ,rust-stable-deref-trait-1)
-        ("rust-winapi" ,rust-winapi-0.3))))
-    (home-page "https://github.com/alexcrichton/rustc-auto-publish")
-    (synopsis "Automatically published versions of rustc data structures")
-    (description
-     "Use data structures used in the Rust compiler with this crate.
-It is automatically published using the compiler repository at
-@url{https://www.github.com/rust-lang/rust}.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-rustc-ap-rustc-index-654
   (package
     (name "rust-rustc-ap-rustc-index")
@@ -47544,27 +47415,6 @@ It is automatically published using the compiler repository at
 @url{https://www.github.com/rust-lang/rust}.")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-rustc-ap-rustc-lexer-721
-  (package
-    (inherit rust-rustc-ap-rustc-lexer-725)
-    (name "rust-rustc-ap-rustc-lexer")
-    (version "721.0.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "rustc-ap-rustc_lexer" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "1ldk41a4vxgh39p9650vhw1j7fng06pfmvb4xb2pvp22547gd89b"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-unicode-xid" ,rust-unicode-xid-0.2))
-       #:cargo-development-inputs
-       (("rust-expect-test" ,rust-expect-test-1))))))
-
 (define-public rust-rustc-ap-serialize-654
   (package
     (name "rust-rustc-ap-serialize")
@@ -50225,17 +50075,18 @@ macOS and iOS.")
 (define-public rust-semver-1
   (package
     (name "rust-semver")
-    (version "1.0.14")
+    (version "1.0.3")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "semver" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "1i193dd6xkhh2fi1x7rws9pvv2ff3jfl9qjvvd9y6y6pcg2glpg2"))))
+        (base32 "1gna1p10i86sf1pqfqndkwl0wks35x84yvjw77c74ckzxrbsqfjz"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
+     `(#:skip-build? #t
+       #:cargo-inputs
        (("rust-serde" ,rust-serde-1))))
     (home-page "https://docs.rs/crate/semver")
     (synopsis "Semantic version parsing and comparison")
@@ -51903,26 +51754,6 @@ functions core functionality.")
        (sha256
         (base32 "0y4n8r4362y2fa6p2j0dgny4zfi194gdf01l6j850n9vf8ha3kwj"))))))
 
-(define-public rust-sha2-asm-0.3
-  (package
-    (inherit rust-sha2-asm-0.5)
-    (name "rust-sha2-asm")
-    (version "0.3.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "sha2-asm" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "09id310ngbcv98bww7ns1zmilcagnzhqx2s2skpmf23lzl890c9y"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-gcc" ,rust-gcc-0.3)
-        ("rust-generic-array" ,rust-generic-array-0.8))))))
-
 (define-public rust-sha3-0.9
   (package
     (name "rust-sha3")
@@ -52676,7 +52507,7 @@ diff output.")
         ("rust-paris" ,rust-paris-1)
         ("rust-termcolor" ,rust-termcolor-1))))
     (home-page "https://github.com/drakulix/simplelog.rs")
-    (synopsis "A simple and easy-to-use logging facility for Rust's log crate")
+    (synopsis "Simple and easy-to-use logging facility for Rust's log crate")
     (description
      "This package provides a simple and easy-to-use logging facility for Rust's
 @code{log} crate.  It aims to be a maintainable, easy to integrate facility for
@@ -53358,21 +53189,6 @@ stack.")
        #:cargo-development-inputs
        (("rust-bincode" ,rust-bincode-1))))))
 
-(define-public rust-smallvec-0.2
-  (package
-    (inherit rust-smallvec-1)
-    (name "rust-smallvec")
-    (version "0.2.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "smallvec" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "04z0bv5pcnwnvij8kfzw56lnib9mjq8bafp120i7q48yvzbbr32c"))))
-    (build-system cargo-build-system)
-    (arguments `(#:skip-build? #t))))
-
 (define-public rust-smart-default-0.6
   (package
     (name "rust-smart-default")
@@ -54153,7 +53969,7 @@ SPIR-V.")
     (arguments `(#:skip-build? #t #:cargo-inputs (("rust-der" ,rust-der-0.4))))
     (home-page "https://github.com/RustCrypto/formats/tree/master/spki")
     (synopsis
-     "X.509 Subject Public Key Info (RFC5280) describing public keys ")
+     "X.509 Subject Public Key Info (RFC5280) describing public keys")
     (description
      "This package provides X.509 Subject Public Key Info (RFC5280)
 describing public keys as well as their associated AlgorithmIdentifiers (i.e.
@@ -55911,25 +55727,24 @@ values without proliferating generics.")
     (description "This package provides custom derive for @code{sval}.")
     (license (list license:asl2.0 license:expat))))
 
-(define-public rust-swayipc-2
+(define-public rust-swayipc-3
   (package
     (name "rust-swayipc")
-    (version "2.7.2")
+    (version "3.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "swayipc" version))
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32 "03r15c2sijyrxmpsyjgma4gz7zmdl1g8akjnjkw6hrml91d5dilj"))))
+        (base32 "16pf4r6svf99p73b8dhdannkvhfvmbjb4rx7gifxh8xj53rwy7db"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:tests? #f                      ; test sync::tests::connect ... FAILED
+     `(#:skip-build? #t
        #:cargo-inputs
        (("rust-serde" ,rust-serde-1)
-        ("rust-async-std" ,rust-async-std-1)
-        ("rust-swayipc-command-builder" ,rust-swayipc-command-builder-0.1)
-        ("rust-serde-json" ,rust-serde-json-1))))
+        ("rust-serde-json" ,rust-serde-json-1)
+        ("rust-swayipc-types" ,rust-swayipc-types-1))))
     (home-page "https://github.com/jaycefayne/swayipc-rs")
     (synopsis "Library for controlling sway through its IPC interface")
     (description
@@ -55937,6 +55752,26 @@ values without proliferating generics.")
 interface.")
     (license license:expat)))
 
+(define-public rust-swayipc-2
+  (package
+    (inherit rust-swayipc-3)
+    (name "rust-swayipc")
+    (version "2.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "swayipc" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "03r15c2sijyrxmpsyjgma4gz7zmdl1g8akjnjkw6hrml91d5dilj"))))
+    (arguments
+     `(#:tests? #f                      ; test sync::tests::connect ... FAILED
+       #:cargo-inputs
+       (("rust-serde" ,rust-serde-1)
+        ("rust-async-std" ,rust-async-std-1)
+        ("rust-swayipc-command-builder" ,rust-swayipc-command-builder-0.1)
+        ("rust-serde-json" ,rust-serde-json-1))))))
+
 (define-public rust-swayipc-command-builder-0.1
   (package
     (name "rust-swayipc-command-builder")
@@ -55956,6 +55791,31 @@ interface.")
 executed by swayipc.")
     (license license:expat)))
 
+(define-public rust-swayipc-types-1
+  (package
+   (name "rust-swayipc-types")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "swayipc-types" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "13lj6jyyxg41r9g0b07y8yd7ygy5gih61w5v48bpksvfdzhwwn55"))))
+   (build-system cargo-build-system)
+   (arguments
+    `(#:skip-build? #t
+      #:cargo-inputs
+      (("rust-serde" ,rust-serde-1)
+       ("rust-serde-json" ,rust-serde-json-1)
+       ("rust-thiserror" ,rust-thiserror-1))))
+   (home-page "https://github.com/jaycefayne/swayipc-rs")
+   (synopsis "A library containing Type defintions from sway's IPC interface")
+   (description
+    "This package provides a library containing Type defintions from sway's IPC
+interface")
+   (license license:expat)))
+
 (define-public rust-syn-1
   (package
     (name "rust-syn")
@@ -56112,7 +55972,7 @@ a syntax tree of Rust source code.")
         ("rust-quote" ,rust-quote-1))))
     (home-page "https://github.com/taiki-e/syn-mid")
     (synopsis
-     "Provide the features between \"full\" and \"derive\" of syn.")
+     "Provide the features between \"full\" and \"derive\" of syn")
     (description
      "This package provides the features between \"full\" and \"derive\" of syn.")
     (license (list license:asl2.0 license:expat))))
@@ -58169,25 +58029,25 @@ unstable language features.")
     (description "This package provides a newtypes for text offsets")
     (license (list license:expat license:asl2.0))))
 
-(define-public rust-textwrap-0.12
+(define-public rust-textwrap-0.15
   (package
     (name "rust-textwrap")
-    (version "0.12.1")
+    (version "0.15.0")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "textwrap" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "12978qmkl5gcp94lxndpvp9qxq8mxp7hm9xbrw3422dgikchhc10"))))
+        (base32 "1yw513k61lfiwgqrfvsjw1a5wpvm0azhpjr2kr0jhnq9c56is55i"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
        (("rust-hyphenation" ,rust-hyphenation-0.8)
+        ("rust-smawk" ,rust-smawk-0.3)
         ("rust-terminal-size" ,rust-terminal-size-0.1)
+        ("rust-unicode-linebreak" ,rust-unicode-linebreak-0.1)
         ("rust-unicode-width" ,rust-unicode-width-0.1))))
     (home-page
      "https://github.com/mgeisler/textwrap")
@@ -58199,6 +58059,27 @@ for display in commandline applications.  It is designed to be efficient and
 handle Unicode characters correctly.")
     (license license:expat)))
 
+(define-public rust-textwrap-0.12
+  (package
+    (inherit rust-textwrap-0.15)
+    (name "rust-textwrap")
+    (version "0.12.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "textwrap" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "12978qmkl5gcp94lxndpvp9qxq8mxp7hm9xbrw3422dgikchhc10"))))
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-hyphenation" ,rust-hyphenation-0.8)
+        ("rust-terminal-size" ,rust-terminal-size-0.1)
+        ("rust-unicode-width" ,rust-unicode-width-0.1))))))
+
 (define-public rust-textwrap-0.11
   (package
     (inherit rust-textwrap-0.12)
@@ -58248,16 +58129,14 @@ handle Unicode characters correctly.")
 (define-public rust-thiserror-1
   (package
     (name "rust-thiserror")
-    (version "1.0.26")
+    (version "1.0.37")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "thiserror" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "1qmz542pq4wmz3p0s4kavsqv09h0x99klkf3k33ydjy1x97rw4ck"))))
+        (base32 "0gky83x4i87gd87w3fknnp920wvk9yycp7dgkf5h3jg364vb7phh"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
@@ -58276,16 +58155,14 @@ handle Unicode characters correctly.")
 (define-public rust-thiserror-impl-1
   (package
     (name "rust-thiserror-impl")
-    (version "1.0.26")
+    (version "1.0.37")
     (source
      (origin
        (method url-fetch)
        (uri (crate-uri "thiserror-impl" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
        (sha256
-        (base32
-         "0ia72qiynlws5avb8f1xqlazp4g6bqgzjbwy5vs6nyg7myh6j386"))))
+        (base32 "1fydmpksd14x1mkc24zas01qjssz8q43sbn2ywl6n527dda1fbcq"))))
     (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
@@ -58646,7 +58523,7 @@ fixed set of worker threads.")
     (home-page
      "https://github.com/tikv/jemallocator")
     (synopsis
-     "safe wrapper over jemalloc's control and introspection APIs")
+     "Safe wrapper over jemalloc's control and introspection APIs")
     (description
      "This package provides a safe wrapper over jemalloc's control and
 introspection APIs.")
@@ -60175,28 +60052,6 @@ Rustls.")
        (("rust-lazy-static" ,rust-lazy-static-1)
         ("rust-tokio" ,rust-tokio-0.1))))))
 
-(define-public rust-tokio-service-0.1
-  (package
-    (name "rust-tokio-service")
-    (version "0.1.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "tokio-service" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0qjinhax0y164kxp887mj8c5ih9829kdrnrb2ramzwg0fz825ni4"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-futures" ,rust-futures-0.1))))
-    (home-page "https://github.com/tokio-rs/tokio-service")
-    (synopsis "Core @code{Service} trait for Tokio")
-    (description
-     "This package provides the core @code{Service} trait for Tokio.")
-    (license (list license:expat license:asl2.0))))
-
 (define-public rust-tokio-signal-0.2
   (package
     (name "rust-tokio-signal")
@@ -60925,7 +60780,7 @@ serializing Rust structures.")
          ("rust-pretty-assertions" ,rust-pretty-assertions-1)
          ("rust-snapbox" ,rust-snapbox-0.2))))
     (home-page "https://github.com/ordian/toml_edit")
-    (synopsis "Yet another format-preserving TOML parser.")
+    (synopsis "Yet another format-preserving TOML parser")
     (description "This package provides yet another format-preserving TOML
 parser.")
     (license (list license:expat license:asl2.0))))
@@ -62968,7 +62823,7 @@ Unicode character database.")
           "13ng291mkc9b132jjf4laj76f5nqm5qd2447rm8bry3wxbdc5kaw"))))
     (build-system cargo-build-system)
     (home-page "https://github.com/BurntSushi/ucd-generate")
-    (synopsis "library for working with the Unicode character database")
+    (synopsis "Library for working with the Unicode character database")
     (description "This package provides a small utility library for working
 with the Unicode character database.")
     (license (list license:asl2.0
@@ -64287,7 +64142,7 @@ a part of rav1e.")
         ("rust-quote" ,rust-quote-1)
         ("rust-syn" ,rust-syn-1))))
     (home-page "https://github.com/tokio-rs/valuable")
-    (synopsis "Macros for the valuable crate.")
+    (synopsis "Macros for the valuable crate")
     (description "This package provides macros for the @code{valuable}
 crate.")
     (license license:expat)))
@@ -68418,11 +68273,37 @@ Rust.")
     (build-system cargo-build-system)
     (home-page #f)
     (synopsis
-      "High performance inflection transformation library for changing properties of words like the case.")
+      "Inflection transformation library for changing properties of words")
     (description
       "High performance inflection transformation library for changing properties of words like the case.")
     (license license:expat)))
 
+(define-public rust-rt-format-0.3
+  (package
+    (name "rust-rt-format")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "rt-format" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1qjjwh9ny95xck1kp99gi6hfm9glrx54jx8npnj6yccxc7p7q225"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs
+       (("rust-lazy-static" ,rust-lazy-static-1)
+        ("rust-regex" ,rust-regex-1))))
+    (home-page "https://github.com/vstojkovic/rt-format")
+    (synopsis "Runtime equivalent of the Rust format! macro")
+    (description "This package provides a runtime equivalent of the Rust
+format! macro. It allows formatting strings like the format! macro, with the
+formatting string and the arguments provided at runtime.  This crate supports
+all the formatting features of the format! macro, except for the fill
+character.")
+    (license license:asl2.0)))
+
 (define-public rust-rustc-workspace-hack-1
   (package
     (name "rust-rustc-workspace-hack")
@@ -68589,11 +68470,33 @@ Rust.")
     (home-page
       "https://github.com/storyfeet/clap_conf")
     (synopsis
-      "Library to unify commandline arguments with config files and environment variables. And make it easier for users to tell your program how to behave across the three main input sources")
+      "Library to unify commandline arguments, config files and environment variables")
     (description
       "This package provides a library to unify commandline arguments with config files and environment variables.  And make it easier for users to tell your program how to behave across the three main input sources")
     (license license:expat)))
 
+(define-public rust-clap-lex-0.2
+  (package
+    (name "rust-clap-lex")
+    (version "0.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "clap_lex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1ib1a9v55ybnaws11l63az0jgz5xiy24jkdgsmyl7grcm3sz4l18"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-os-str-bytes" ,rust-os-str-bytes-6))))
+    (home-page "https://github.com/clap-rs/clap/tree/master/clap_lex")
+    (synopsis "Command-line parser for Rust")
+    (description "This package provides a command-line parser for Rust.  As
+opposed to a declarative parser, @code{rust-clap-lex} processes arguments as a
+stream of tokens.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public svd2rust
   (package
     (name "svd2rust")