gnu: Simplify package inputs.
[jackhill/guix/guix.git] / gnu / packages / lua.scm
index 22dc7c6..85def0d 100644 (file)
@@ -73,7 +73,7 @@
              (patches (search-patches "lua-pkgconfig.patch"
                                       "lua-liblua-so.patch"))))
     (build-system gnu-build-system)
-    (inputs `(("readline" ,readline)))
+    (inputs (list readline))
     (arguments
      `(#:modules ((guix build gnu-build-system)
                   (guix build utils)
@@ -229,8 +229,7 @@ some projects.")))
              (invoke "lua" "tests/test.lua")
              (invoke "lua" "tests/test-lom.lua"))))))
     (inputs
-     `(("lua" ,lua)
-       ("expat" ,expat)))
+     (list lua expat))
     (home-page "https://matthewwild.co.uk/projects/luaexpat/")
     (synopsis "SAX XML parser based on the Expat library")
     (description "LuaExpat is a SAX XML parser based on the Expat library.")
@@ -273,7 +272,7 @@ some projects.")))
                (invoke "lua" "test/testsrvr.lua"))
              (invoke "lua" "test/testclnt.lua"))))))
     (inputs
-     `(("lua" ,lua)))
+     (list lua))
     (home-page "http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/")
     (synopsis "Socket library for Lua")
     (description "LuaSocket is a Lua extension library that is composed by two
@@ -323,7 +322,7 @@ handy.")
        (modify-phases %standard-phases
          (delete 'configure))))
     (inputs
-     `(("lua" ,lua)))
+     (list lua))
     (home-page "https://keplerproject.github.io/luafilesystem/index.html")
     (synopsis "File system library for Lua")
     (description "LuaFileSystem is a Lua library developed to complement the
@@ -379,8 +378,7 @@ directory structure and file attributes.")
                            (find-files "." "^[0-9].*\\.lua$"))))
              #t)))))
     (inputs
-     `(("lua" ,lua)
-       ("openssl" ,openssl)))
+     (list lua openssl))
     (home-page "https://25thandclement.com/~william/projects/luaossl.html")
     (synopsis "OpenSSL bindings for Lua")
     (description "The luaossl extension module for Lua provides comprehensive,
@@ -427,8 +425,7 @@ binds OpenSSL's bignum, message digest, HMAC, cipher, and CSPRNG interfaces.")
        (modify-phases %standard-phases
          (delete 'configure))))
     (inputs
-     `(("lua" ,lua)
-       ("openssl" ,openssl)))
+     (list lua openssl))
     (propagated-inputs
      `(("lua-socket"
         ,(make-lua-socket
@@ -531,12 +528,11 @@ secure session between the peers.")
 
                (apply invoke "make" "check" make-flags)))))))
     (native-inputs
-     `(("m4" ,m4)))
+     (list m4))
     (inputs
-     `(("lua" ,lua)
-       ("openssl" ,openssl)))
+     (list lua openssl))
     (propagated-inputs
-     `(("lua-ossl" ,lua-ossl)))
+     (list lua-ossl))
     (home-page "https://25thandclement.com/~william/projects/cqueues.html")
     (synopsis "Event loop for Lua using continuation queues")
     (description "The cqueues extension module for Lua implements an event loop
@@ -568,9 +564,9 @@ to be non-intrusive, composable, and embeddable within existing applications.")
         (base32 "0qc2d1riyr4b5a0gnsmdw2lz5pw65s4ac60hc34w3mmk9l6yg6nl"))))
     (build-system trivial-build-system)
     (inputs
-     `(("lua" ,lua)))
+     (list lua))
     (propagated-inputs
-     `(("lua-filesystem" ,lua-filesystem)))
+     (list lua-filesystem))
     (arguments
      `(#:modules ((guix build utils))
        #:builder
@@ -608,9 +604,9 @@ standard libraries.")
         (base32 "1h0cf7bp4am54r0j8lhjs2l1c7q5vz74ba0jvw9qdbaqimls46g8"))))
     (build-system gnu-build-system)
     (inputs
-     `(("lua" ,lua)))
+     (list lua))
     (propagated-inputs
-     `(("lua-penlight" ,lua-penlight)))
+     (list lua-penlight))
     (arguments
      `(#:tests? #f                 ;tests must run after installation.
        #:phases
@@ -698,8 +694,8 @@ describing the commented declarations and functions.")
              (setenv "DISPLAY" ":1")
              #t)))))
     (native-inputs
-     `(("dbus" ,dbus)                   ;tests use 'dbus-run-session'
-       ("pkg-config" ,pkg-config)))
+     (list dbus ;tests use 'dbus-run-session'
+           pkg-config))
     (inputs
      `(("cairo" ,cairo)
        ("glib" ,glib)
@@ -752,7 +748,7 @@ Notable examples are GTK+, GStreamer and Webkit.")
                              (string-append out "/share/lua/" lua-version))
                #t))))
        #:test-target "test"))
-    (inputs `(("lua" ,lua)))
+    (inputs (list lua))
     (synopsis "Pattern-matching library for Lua")
     (description
      "LPeg is a pattern-matching library for Lua, based on Parsing Expression
@@ -804,8 +800,7 @@ Grammars (PEGs).")
                                     (or (getenv "CPATH") "")))
              #t)))))
     (inputs
-     `(("lua" ,lua)
-       ("libuv" ,libuv)))
+     (list lua libuv))
     (native-inputs
      `(("lua-compat"
         ,(origin
@@ -857,7 +852,7 @@ Grammars (PEGs).")
        #:phases
        (modify-phases %standard-phases
          (delete 'configure))))
-    (inputs `(("lua" ,lua)))
+    (inputs (list lua))
     (home-page "https://bitop.luajit.org/index.html")
     (synopsis "Bitwise operations on numbers for Lua")
     (description
@@ -918,8 +913,7 @@ on numbers.")
                (chdir "./runner")
                (invoke "./test_runner")))))))
     (native-inputs
-     `(("lua" ,lua)
-       ("pkg-config" ,pkg-config)))
+     (list lua pkg-config))
     (home-page "https://github.com/jeremyong/Selene")
     (synopsis "Lua C++11 bindings")
     (description
@@ -1133,26 +1127,26 @@ shell command executions.")
             "-Denable_manpages=false"
             "-Dversion_suffix=-guix1")))
    (native-inputs
-    `(("gcc" ,gcc-10) ; gcc-7 is too old for our C++17 needs
-      ("luajit-lua52-openresty" ,luajit-lua52-openresty)
-      ("pkg-config" ,pkg-config)
-      ("re2c" ,re2c)
-      ("xxd" ,xxd)))
+    (list gcc-10 ; gcc-7 is too old for our C++17 needs
+          luajit-lua52-openresty
+          pkg-config
+          re2c
+          xxd))
    (inputs
-    `(("boost" ,boost)
-      ("boost-static" ,boost-static)
-      ("fmt" ,fmt-7)
-      ;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
-      ;; fork. Emilua is severely affected by this limit, so the upstream package
-      ;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT
-      ;; configure flag[2] for some features to work (e.g. __pairs on HTTP
-      ;; headers).
-      ;;
-      ;; [1] <http://hacksoflife.blogspot.com/2012/12/integrating-luajit-with-x-plane-64-bit.html>
-      ;; [2] <http://luajit.org/extensions.html#lua52>
-      ("luajit-lua52-openresty" ,luajit-lua52-openresty)
-      ("ncurses" ,ncurses)
-      ("openssl" ,openssl)))
+    (list boost
+          boost-static
+          fmt-7
+          ;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
+          ;; fork. Emilua is severely affected by this limit, so the upstream package
+          ;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT
+          ;; configure flag[2] for some features to work (e.g. __pairs on HTTP
+          ;; headers).
+          ;;
+          ;; [1] <http://hacksoflife.blogspot.com/2012/12/integrating-luajit-with-x-plane-64-bit.html>
+          ;; [2] <http://luajit.org/extensions.html#lua52>
+          luajit-lua52-openresty
+          ncurses
+          openssl))
    (native-search-paths
     (list
      (search-path-specification
@@ -1196,7 +1190,7 @@ enabled.")
          (delete 'check)
          (add-after 'install 'check
            (assoc-ref %standard-phases 'check)))))
-    (inputs `(("lua" ,lua)))
+    (inputs (list lua))
     (home-page "https://fennel-lang.org/")
     (synopsis "Lisp that compiles to Lua")
     (description