gnu: Simplify package inputs.
[jackhill/guix/guix.git] / gnu / packages / file-systems.scm
index 30beb36..3c61e64 100644 (file)
                (("ln -fs lookup_yp.so" match)
                 (string-append "# " match))))))))
     (native-inputs
-     `(("bison" ,bison)
-       ("flex" ,flex)
-       ("pkg-config" ,pkg-config)
-       ("rpcsvc-proto" ,rpcsvc-proto)))
+     (list bison flex pkg-config rpcsvc-proto))
     (inputs
-     `(("cyrus-sasl" ,cyrus-sasl)
-       ("e2fsprogs" ,e2fsprogs)         ; for e[234]fsck
-       ("libtirpc" ,libtirpc)
-       ("libxml2" ,libxml2)             ; needed for LDAP, SASL
-       ("mit-krb5" ,mit-krb5)           ; needed for LDAP, SASL
-       ("nfs-utils" ,nfs-utils)         ; for mount.nfs
-       ("openldap" ,openldap)
-       ("openssl" ,openssl)             ; needed for SASL
-       ("sssd" ,sssd)
-       ("util-linux" ,util-linux)))     ; for mount, umount
+     (list cyrus-sasl
+           e2fsprogs ; for e[234]fsck
+           libtirpc
+           libxml2 ; needed for LDAP, SASL
+           mit-krb5 ; needed for LDAP, SASL
+           nfs-utils ; for mount.nfs
+           openldap
+           openssl ; needed for SASL
+           sssd
+           util-linux))     ; for mount, umount
     ;; XXX A directory index is the closest thing this has to a home page.
     (home-page "https://www.kernel.org/pub/linux/daemons/autofs/")
     (synopsis "Kernel-based automounter for Linux")
@@ -184,9 +181,9 @@ large and/or frequently changing (network) environment.")
        ;; ("ruby" ,ruby)
        ;; ("valgrind" ,valgrind)
        ;; ("which" ,which)
-     `(("pkg-config" ,pkg-config)))
+     (list pkg-config))
     (inputs
-     `(("fuse" ,fuse)))
+     (list fuse))
     (home-page "https://bindfs.org")
     (synopsis "Bind mount a directory and alter permission bits")
     (description
@@ -292,11 +289,10 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
                       (string-append "pkgsysconfdir=" out "/etc")
                       make-flags)))))))
     (inputs
-     `(("neon" ,neon)
-
-       ;; Neon requires but doesn't propagate zlib, nor would we want that.
-       ;; XZ as well, but that's already present in the build environment.
-       ("zlib" ,zlib)))
+     (list neon
+           ;; Neon requires but doesn't propagate zlib, nor would we want that.
+           ;; XZ as well, but that's already present in the build environment.
+           zlib))
     (home-page "https://savannah.nongnu.org/projects/davfs2")
     (synopsis "Mount remote WebDAV resources in the local file system")
     (description
@@ -356,9 +352,7 @@ ones.")
         (base32 "1ry2sdkfbg4bwcldk42g1i3wa3z4pr9yh9dil6ilhwcvhqiw41zc"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf automake pkg-config))
     (inputs
      `(("bzip2" ,bzip2)
        ("e2fsprogs" ,e2fsprogs)
@@ -399,11 +393,9 @@ is corrupted you'll lose the affected file(s) but not the whole back-up.")
          "04slwhr6ap9xcc27wphk22ad8yn79ngyy5z10lxams3k5liahvc2"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     (list pkg-config))
     (inputs
-     `(("fuse" ,fuse)
-       ("glib" ,glib)
-       ("libgphoto2" ,libgphoto2)))
+     (list fuse glib libgphoto2))
     (synopsis "Virtual file system for libgphoto2 using FUSE")
     (description "GPhotoFS is a FUSE file system module to mount your camera as
 a file system on Linux.  This allow using your camera with any tool able to read
@@ -457,15 +449,13 @@ from a mounted file system.")
                                          "util-linux"))))))))))
          #:tests? #f))                  ; XXX 6 valgrind tests fail
       (native-inputs
-       `(("pkg-config" ,pkg-config)
-
-         ;; For tests.
-         ("python-pytest" ,python-pytest)
-         ("valgrind" ,valgrind)
-
-         ;; For generating documentation with rst2man.
-         ("python" ,python)
-         ("python-docutils" ,python-docutils)))
+       (list pkg-config
+             ;; For tests.
+             python-pytest
+             valgrind
+             ;; For generating documentation with rst2man.
+             python
+             python-docutils))
       (inputs
        `(("eudev" ,eudev)
          ("keyutils" ,keyutils)
@@ -574,10 +564,7 @@ from the bcachefs-tools package.  It is meant to be used in initrds.")
      `(#:configure-flags
        (list "--disable-static")))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf automake libtool pkg-config))
     (home-page "https://github.com/exfatprogs/exfatprogs")
     (synopsis "Tools to create, check, and repair exFAT file systems")
     (description
@@ -601,14 +588,9 @@ Extensible File Allocation Table} file systems.  Included are
          "1h8ggvhw30n2r6w11n1s458ypggdqx6ldwd61ma4yd7binrlpjq1"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("asciidoc" ,asciidoc)
-       ("docbook-xml" ,docbook-xml)
-       ("libxml2" ,libxml2)
-       ("libxslt" ,libxslt)
-       ("pkg-config" ,pkg-config)))
+     (list asciidoc docbook-xml libxml2 libxslt pkg-config))
     (inputs
-     `(("fuse" ,fuse)
-       ("gnutls" ,gnutls)))
+     (list fuse gnutls))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -661,7 +643,7 @@ single file can be mounted.")
                                 "jfsutils-include-systypes.patch"))))
     (build-system gnu-build-system)
     (inputs
-     `(("util-linux" ,util-linux "lib")))
+     (list `(,util-linux "lib")))
     (home-page "http://jfs.sourceforge.net/home.html")
     (synopsis "Utilities for managing JFS file systems")
     (description
@@ -737,10 +719,9 @@ from the jfsutils package.  It is meant to be used in initrds.")
          "1pnrj0h8sgqwgsc18vz3fkqsp6vhigdbi75vdj0si1r6wgslnr7z"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     (list pkg-config))
     (inputs
-     `(("fuse" ,fuse)
-       ("attr" ,attr)))
+     (list fuse attr))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (delete 'configure))  ; no configure script
@@ -845,11 +826,9 @@ All of this is accomplished without a centralized metadata server.")
               (("4426192") "12814800"))
              #t)))))
     (inputs
-     `(("curl" ,curl)
-       ("glib" ,glib)
-       ("fuse" ,fuse)))
+     (list curl glib fuse))
     (native-inputs
-     `(("pkg-config" ,pkg-config)))
+     (list pkg-config))
     (home-page "http://curlftpfs.sourceforge.net/")
     (synopsis "Mount remote file systems over FTP")
     (description
@@ -915,7 +894,7 @@ All of this is accomplished without a centralized metadata server.")
        ("strace" ,strace)
        ("which" ,which)))
     (inputs
-     `(("coreutils" ,coreutils)))
+     (list coreutils))
     (home-page "https://www.flamingspork.com/projects/libeatmydata/")
     (synopsis "Transparently ignore calls to synchronize data safely to disk")
     (description
@@ -956,10 +935,7 @@ A simple @command{eatmydata} script is included that does this for you.")
     (build-system gnu-build-system)
     (home-page "https://github.com/sahlberg/libnfs")
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf automake libtool pkg-config))
     (synopsis "Client library for accessing NFS shares")
     (description "LIBNFS is a client library for accessing NFS shares over a
 network.  LIBNFS offers three different APIs, for different use :
@@ -1014,9 +990,7 @@ network.  LIBNFS offers three different APIs, for different use :
                  (install-file "../source/README.md" doc)
                  #t))))))
       (inputs
-       `(("bzip2" ,bzip2)
-         ("fuse" ,fuse)
-         ("zlib" ,zlib)))
+       (list bzip2 fuse zlib))
       (synopsis "Read-only FUSE driver for the APFS file system")
       (description "APFS-FUSE is a read-only FUSE driver for the @dfn{Apple File
 System} (APFS).  It is currently in an experimental state — it may not be able
@@ -1148,9 +1122,7 @@ xfstest's \"~a\" command (with any OPTIONs) as documented below.\n\n"
                              status))))))
                  (chmod helper #o755)))))))
       (native-inputs
-       `(("autoconf" ,autoconf)
-         ("automake" ,automake)
-         ("libtool" ,libtool)))
+       (list autoconf automake libtool))
       (inputs
        `(("acl" ,acl)
          ("attr" ,attr)
@@ -1301,9 +1273,7 @@ with the included @command{xfstests-check} helper.")
                              (string-append out
                                             "/share/bash-completion/completions"))))))))
     (native-inputs
-     `(("attr" ,attr)
-       ("kmod" ,kmod)
-       ("pkg-config" ,pkg-config)))
+     (list attr kmod pkg-config))
     (inputs
      `(("eudev" ,eudev)
        ("kmod-runtime" ,kmod)
@@ -1344,7 +1314,7 @@ community.")
      ;; Note: if you are inheriting from the above zfs package in order
      ;; to provide a specific stable kernel version, you should also
      ;; inherit this package and replace the sole input below.
-     `(("zfs" ,zfs)))
+     (list zfs))
     (arguments
      `(#:tests? #f ; No tests
        #:phases
@@ -1442,8 +1412,7 @@ On Guix System, you will need to invoke the included shell scripts as
                 (string-append (assoc-ref inputs "bash-minimal") command))))))))
     ;; Mergerfs bundles a heavily modified copy of fuse.
     (inputs
-     `(("bash-minimal" ,bash-minimal)
-       ("util-linux" ,util-linux)))
+     (list bash-minimal util-linux))
     (home-page "https://github.com/trapexit/mergerfs")
     (synopsis "Featureful union file system")
     (description "mergerfs is a union file system geared towards simplifying
@@ -1472,9 +1441,7 @@ is similar to mhddfs, unionfs, and aufs.")
           (base32 "15pgym6c4viy57ccgp28dnqwh12f3gr02axg86y578aqa2yaa0ad"))))
       (build-system copy-build-system)
       (inputs
-       `(("python" ,python)
-         ("python-xattr" ,python-xattr)
-         ("rsync" ,rsync)))
+       (list python python-xattr rsync))
       (arguments
        '(#:install-plan
          '(("src/" "bin/"))
@@ -1515,12 +1482,9 @@ compatible directories.")
     (build-system python-build-system)
     (arguments '(#:tests? #f))  ; Tests require a network connection.
     (native-inputs
-     `(("python-pytest" ,python-pytest)
-       ("python-pytest-runner" ,python-pytest-runner)))
+     (list python-pytest python-pytest-runner))
     (propagated-inputs
-     `(("python-requests" ,python-requests)
-       ("python-six" ,python-six)
-       ("python-stone" ,python-stone)))
+     (list python-requests python-six python-stone))
     (home-page "https://www.dropbox.com/developers")
     (synopsis "Official Dropbox API Client")
     (description "This package provides a Python SDK for integrating with the
@@ -1547,13 +1511,13 @@ Dropbox API v2.")
     (arguments
      '(#:tests? #f)) ; tests requires safefs
     (propagated-inputs
-     `(("python-appdirs" ,python-appdirs)
-       ("python-block-tracing" ,python-block-tracing)
-       ("python-dropbox" ,python-dropbox)
-       ("python-keyring" ,python-keyring)
-       ("python-keyrings.alt" ,python-keyrings.alt)
-       ("python-privy" ,python-privy)
-       ("python-userspacefs" ,python-userspacefs)))
+     (list python-appdirs
+           python-block-tracing
+           python-dropbox
+           python-keyring
+           python-keyrings.alt
+           python-privy
+           python-userspacefs))
   (home-page "https://thelig.ht/code/dbxfs/")
   (synopsis "User-space file system for Dropbox")
   (description
@@ -1579,7 +1543,7 @@ local file system using FUSE.")
     (arguments
      `(#:import-path "github.com/hanwen/go-fuse"))
     (propagated-inputs
-     `(("go-golang-org-x-sys" ,go-golang-org-x-sys)))
+     (list go-golang-org-x-sys))
     (home-page "https://github.com/hanwen/go-fuse")
     (synopsis "FUSE bindings for Go")
     (description
@@ -1620,10 +1584,9 @@ local file system using FUSE.")
                  (for-each (cut install-file <> (string-append doc "/examples"))
                            (find-files "." "^config\\."))))))))
       (native-inputs
-       `(("pkg-config" ,pkg-config)))
+       (list pkg-config))
       (inputs
-       `(("fuse" ,fuse)
-         ("pcre" ,pcre)))
+       (list fuse pcre))
       (home-page "https://github.com/sloonz/rewritefs")
       (synopsis "FUSE file system that changes particular file names")
       (description
@@ -1664,8 +1627,7 @@ the XDG directory specification from @file{~/.@var{name}} to
                (rename-file (string-append out "/bin/TMSU")
                             (string-append out "/bin/tmsu"))))))))
     (inputs
-     `(("go-github-com-mattn-go-sqlite3" ,go-github-com-mattn-go-sqlite3)
-       ("go-github-com-hanwen-fuse" ,go-github-com-hanwen-fuse)))
+     (list go-github-com-mattn-go-sqlite3 go-github-com-hanwen-fuse))
     (home-page "https://github.com/oniony/TMSU")
     (synopsis "Tag files and access them through a virtual file system")
     (description
@@ -1697,10 +1659,7 @@ set up.")
        (list (string-append "--docdir=" (assoc-ref %outputs "out")
                             "/share/doc/" ,name "-" ,version))))
     (native-inputs
-     `(("automake" ,automake)
-       ("autoconf" ,autoconf)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list automake autoconf libtool pkg-config))
     (home-page "https://github.com/pali/udftools")
     (synopsis "Tools to manage UDF file systems and DVD/CD-R(W) drives")
     (description "@code{udftools} is a set of programs for reading