gnu: python-pathpy: Build documentation.
[jackhill/guix/guix.git] / gnu / packages / openldap.scm
index a4a28cc..627319b 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages openldap)
   #:use-module (gnu packages autotools)
-  #:use-module (gnu packages bdb)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages groff)
   #:use-module (gnu packages icu4c)
-  #:use-module (gnu packages openssl)
+  #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:select (openldap2.8))
   #:use-module (guix packages)
   #:use-module (guix download)
 (define-public openldap
   (package
    (name "openldap")
-   (version "2.4.33")
+   (version "2.4.44")
    (source (origin
             (method url-fetch)
-            (uri (string-append
-                   "ftp://sunsite.cnlab-switch.ch/mirror/OpenLDAP/openldap-release/openldap-"
-                   version ".tgz"))
-            (sha256 (base32
-                     "0k51mhrs7pkwph2j38w09x7xl1ii69mcdi7b2mfrm9hp1yifrsc1"))))
+
+            ;; See <http://www.openldap.org/software/download/> for a list of
+            ;; mirrors.
+            (uri (list (string-append
+                        "ftp://mirror.switch.ch/mirror/OpenLDAP/"
+                        "openldap-release/openldap-" version ".tgz")
+                       (string-append
+                        "ftp://ftp.OpenLDAP.org/pub/OpenLDAP/"
+                        "openldap-release/openldap-" version ".tgz")
+                       (string-append
+                        "ftp://ftp.dti.ad.jp/pub/net/OpenLDAP/"
+                        "openldap-release/openldap-" version ".tgz")))
+            (sha256
+             (base32
+              "0044p20hx07fwgw2mbwj1fkx04615hhs1qyx4mawj2bhqvrnppnp"))))
    (build-system gnu-build-system)
-   (inputs `(("bdb" ,bdb)
-             ("openssl" ,openssl)
+   (inputs `(("bdb" ,bdb-5.3)
              ("cyrus-sasl" ,cyrus-sasl)
+             ("gnutls" ,gnutls)
              ("groff" ,groff)
              ("icu4c" ,icu4c)
              ("libgcrypt" ,libgcrypt)
-             ;; FIXME: currently, openldap requires openssl or gnutls<3, see
-             ;; http://www.openldap.org/its/index.cgi/Incoming?id=7430;page=17
-             ;; Once this is fixed, switch to gnutls.
-             ("libtool" ,libtool "bin")
              ("zlib" ,zlib)))
+   (native-inputs `(("libtool" ,libtool)))
    (arguments
     `(#:tests? #f
       #:phases
-       (alist-replace
-        'configure
-        (lambda* (#:key #:allow-other-keys #:rest args)
-         (let ((configure (assoc-ref %standard-phases 'configure)))
-           (apply configure args)
-           (copy-file (which "libtool") "libtool")))
+       (alist-cons-after
+        'configure 'provide-libtool
+        (lambda _ (copy-file (which "libtool") "libtool"))
        %standard-phases)))
-   (synopsis "openldap, an implementation of the Lightweight Directory Access Protocol")
+   (synopsis "Implementation of the Lightweight Directory Access Protocol")
    (description
     "OpenLDAP is a free implementation of the Lightweight Directory Access Protocol.")
    (license openldap2.8)