gnu: Add sbcl-stumpwm-ttf-fonts.
[jackhill/guix/guix.git] / gnu / packages / rush.scm
index f14e2f7..f46bb50 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public rush
   (package
     (name "rush")
-    (version "1.7")
+    (version "2.1")
     (source (origin
              (method url-fetch)
-             (uri (string-append
-                   "mirror://gnu/rush/rush-"
-                   version
-                   ".tar.gz"))
+             (uri (string-append "mirror://gnu/rush/rush-"
+                                 version ".tar.gz"))
              (sha256
               (base32
-               "0fh0gbbp0iiq3wbkf503xb40r8ljk42vyj9bnlflbz82d6ipy1rm"))
-             (patches (list (search-patch "cpio-gets-undeclared.patch")))))
+               "17i4mggr3rnfz0xbhqvd86jqva40c535fhlwkb2l4hjcbpg8blcf"))))
     (build-system gnu-build-system)
-    (home-page "http://www.gnu.org/software/rush/")
+    (home-page "https://www.gnu.org/software/rush/")
     (synopsis "Restricted user (login) shell")
     (description
-     "Rush is a restricted user shell, for systems on which users are to be
-provided with only limited functionality or resources. Administrators set
+     "GNU Rush is a restricted user shell, for systems on which users are to
+be provided with only limited functionality or resources.  Administrators set
 user rights via a configuration file which can be used to limit, for example,
 the commands that can be executed, CPU time, or virtual memory usage.")
     (license gpl3+)))