gnu: python-pathpy: Build documentation.
[jackhill/guix/guix.git] / gnu / packages / pth.scm
index e7068a5..50385b1 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
        (base32
         "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
     (build-system gnu-build-system)
-    (arguments '(#:parallel-build? #f))
+    (arguments
+     '(#:parallel-build? #f))
     (home-page "http://www.gnu.org/software/pth")
     (synopsis "Portable thread library")
     (description
-     "Pth is a portable library providing non-preemptive, priority-based
+     "GNU Pth is a portable library providing non-preemptive, priority-based
 scheduling for multiple execution threads.  Each thread has its own
-program-counter, run-time stack, signal mask and errno variable. Threads are
+program-counter, run-time stack, signal mask and errno variable.  Threads are
 scheduled in a cooperative way, rather than in the standard preemptive way,
 such that they are managed according to priority and events.  However, Pth
-also features emulation of POSIX.1c threads (\"Pthreads\") for backwards
+also features emulation of POSIX.1c threads (\"pthreads\") for backwards
 compatibility.")
     (license lgpl2.1+)))