gnu: guile: Add 2.2.6-1 with a finalization crash bug-fix.
[jackhill/guix/guix.git] / gnu / packages / guile.scm
index 3396899..9df008c 100644 (file)
@@ -250,6 +250,18 @@ without requiring the source code to be rewritten.")
             (variable "GUILE_LOAD_COMPILED_PATH")
             (files '("lib/guile/2.2/site-ccache")))))))
 
+(define-public guile-2.2/bug-fix
+  ;; This variant contains a bug fix for a relatively rare crash that could
+  ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
+  (package
+    (inherit guile-2.2)
+    (version (string-append (package-version guile-2.2) "-1"))
+    (source (origin
+              (inherit (package-source guile-2.2))
+              (patches
+               (append (search-patches "guile-finalization-crash.patch")
+                       (origin-patches (package-source guile-2.2))))))))
+
 (define-public guile-2.2/fixed
   ;; A package of Guile 2.2 that's rarely changed.  It is the one used
   ;; in the `base' module, and thus changing it entails a full rebuild.