gnu: Add python-pyshp.
[jackhill/guix/guix.git] / gnu / packages / perl.scm
index 47d64e2..d449abc 100644 (file)
@@ -667,6 +667,25 @@ presence, and the first one found is executed.  With an optional parameter,
 all known commands are checked.")
     (license (package-license perl))))
 
+(define-public perl-bsd-resource
+  (package
+   (name "perl-bsd-resource")
+   (version "1.2911")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://cpan.metacpan.org/authors/id/J/JH/JHI/BSD-Resource-"
+           version ".tar.gz"))
+     (sha256
+      (base32 "0g8c7825ng2m0yz5sy6838rvfdl8j3vm29524wjgf66ccfhgn74x"))))
+   (build-system perl-build-system)
+   (home-page "https://metacpan.org/release/BSD-Resource")
+   (synopsis "BSD process resource limit and priority functions")
+   (description "This package provides procedures to get and set resource
+limits like @code{getrlimit} and @code{setpriority}.")
+   (license license:artistic2.0)))
+
 (define-public perl-b-hooks-endofscope
   (package
     (name "perl-b-hooks-endofscope")
@@ -4226,6 +4245,27 @@ and alternative installers with the `installler` option.  But it's written in
 only about 40% as many lines of code and with zero non-core dependencies.")
     (license (package-license perl))))
 
+(define-public perl-extutils-manifest
+  (package
+    (name "perl-extutils-manifest")
+    (version "1.73")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://cpan.metacpan.org/authors/id/E/ET/ETHER/"
+                    "ExtUtils-Manifest-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1y5siyw9sbxq6kdmsjfsx0mrbqb6xr8kmniwli7xc6hbmhyhcp6w"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/ExtUtils-Manifest")
+    (synopsis "Utilities to write and check a MANIFEST file")
+    (description "This package contains functions to manipulate a MANIFEST
+file.  The package exports no functions by default.  The following are exported
+on request: mkmanifest, manifind, manicheck, filecheck, fullcheck, skipcheck,
+maniread, maniskip, manicopy, maniadd.")
+    (license (package-license perl))))
+
 (define-public perl-extutils-installpaths
   (package
     (name "perl-extutils-installpaths")
@@ -5809,6 +5849,52 @@ logging mechanism.")
 @code{Log::Any} adapter using @code{Log::Log4perl} for logging.")
     (license (package-license perl))))
 
+(define-public perl-log-message
+  (package
+   (name "perl-log-message")
+   (version "0.08")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append
+                  "mirror://cpan/authors/id/B/BI/BINGOS/Log-Message-"
+                  version ".tar.gz"))
+            (sha256
+             (base32
+              "0ipyk7zbvz31kf3mj5ahwi2cbcfy54s8387hx4cd29mg5bb7ssdx"))))
+   (build-system perl-build-system)
+   (home-page "https://metacpan.org/release/Log-Message")
+   (synopsis "Powerful and flexible message logging mechanism")
+   (description "This package enables you to do generic message logging
+throughout programs and projects.  Every message will be logged with
+stacktraces, timestamps and so on.  You can use built-in handlers
+immediately, or after the fact when you inspect the error stack.  It
+is highly configurable and let's you even provide your own handlers
+for dealing with messages.")
+   (license (package-license perl))))
+
+(define-public perl-log-message-simple
+  (package
+   (name "perl-log-message-simple")
+   (version "0.10")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "mirror://cpan/authors/id/B/BI/BINGOS/Log-Message-Simple-"
+           version ".tar.gz"))
+     (sha256
+      (base32
+       "15nxi935nfrf8dkdrgvcrf2qlai4pbz03yj8sja0n9mcq2jd24ma"))))
+   (build-system perl-build-system)
+   (inputs
+    `(("perl-log-message" ,perl-log-message)))
+   (home-page "https://metacpan.org/release/Log-Message-Simple")
+   (synopsis "Simplified interface to @code{Log::Message}")
+   (description "This package provides a simplified frontend to
+@code{Log::Message}, offering most common use for logging, and easy access to
+the stack (in both raw and pretty-printable form).")
+   (license (package-license perl))))
+
 (define-public perl-log-log4perl
   (package
     (name "perl-log-log4perl")
@@ -8828,6 +8914,27 @@ collector.")
     (description "Set::Infinite is a set theory module for infinite sets.")
     (license (package-license perl))))
 
+(define-public perl-set-intervaltree
+  (package
+   (name "perl-set-intervaltree")
+   (version "0.12")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "mirror://cpan/authors/id/S/SL/SLOYD/Set-IntervalTree-"
+           version ".tar.gz"))
+     (sha256
+      (base32 "0jf3vdmdgxx6a9xrfwnbbs9g37i1i6qhfg5qwln8x5i280701m3g"))))
+   (build-system perl-build-system)
+   (native-inputs
+    `(("perl-extutils-cppguess" ,perl-extutils-cppguess)))
+   (home-page "https://metacpan.org/release/Set-IntervalTree")
+   (synopsis "Perform range-based lookups on sets of ranges")
+   (description "This package provides an efficient mechanism to look up
+ranges in Interval Trees.")
+   (license (package-license perl))))
+
 (define-public perl-set-intspan
   (package
     (name "perl-set-intspan")