gnu: python-deepmerge: Use pyproject-build-system.
[jackhill/guix/guix.git] / gnu / packages / electronics.scm
index 24bb4b0..15e7318 100644 (file)
@@ -56,7 +56,8 @@
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sdl)
   #:use-module (gnu packages sqlite)
-  #:use-module (gnu packages stb))
+  #:use-module (gnu packages stb)
+  #:use-module (gnu packages toolkits))
 
 (define-public libserialport
   (package
@@ -111,7 +112,7 @@ to take care of the OS-specific details when writing software that uses serial p
                                               "/share/doc/libsigrokdecode"))
              #t)))))
     (native-inputs
-     (list check-0.14 doxygen graphviz pkg-config automake autoconf))
+     (list check doxygen graphviz pkg-config automake autoconf))
     ;; libsigrokdecode.pc lists "python" in Requires.private, and "glib" in Requires.
     (propagated-inputs
      (list glib python))
@@ -251,32 +252,29 @@ supported devices, as well as input/output file format support.")
 (define-public openboardview
   (package
     (name "openboardview")
-    (version "8.95.1")
+    (version "8.95.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/OpenBoardView/OpenBoardView")
-                    (commit version)
-                    (recursive? #t)))   ;for the "src/imgui" submodule
+                    (commit version)))
               (file-name (git-file-name name version))
               (modules '((ice-9 ftw)
                          (srfi srfi-26)
                          (guix build utils)))
               (snippet
                '(with-directory-excursion "src"
-                  ;; Keep the bundled ImGui for now, as in the current version
-                  ;; (~1.79), it requires the glad loader generated at build
-                  ;; time as an input.
-                  (define keep (list "." ".." "imgui" "openboardview"))
+                  (define keep (list "." ".." "openboardview"))
                   (for-each (lambda (f)
                               (when (eq? 'directory (stat:type (lstat f)))
                                 (delete-file-recursively f)))
                             (scandir "." (negate (cut member <> keep))))))
               (patches
-               (search-patches "openboardview-use-system-utf8.patch"))
+               (search-patches "openboardview-use-system-imgui.patch"
+                               "openboardview-use-system-utf8.patch"))
               (sha256
                (base32
-                "16mrs7bimwp8a8lb2wqhfisy6j0hl9574l4h9yb66v46aglvmd3h"))))
+                "1n2yfi8wpky0y231kq2zdgwn7f7kff8m53m904hxi5ppmwhx1d6q"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -288,17 +286,6 @@ supported devices, as well as input/output file format support.")
                   ((guix build glib-or-gtk-build-system) #:prefix gtk:))
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'remove-timestamps
-            (lambda _
-              ;; The __TIMESTAMP__ CPP macro does apparently not honor
-              ;; SOURCE_EPOCH_DATE.  Patch it to use __DATE__ instead, which
-              ;; does (see:
-              ;; https://github.com/OpenBoardView/OpenBoardView/issues/229 and
-              ;; https://issues.guix.gnu.org/53647).
-              (substitute* '("src/openboardview/BoardView.cpp"
-                             "src/openboardview/main_opengl.cpp")
-                (("__TIMESTAMP__")
-                 "__DATE__"))))
           (add-before 'configure 'configure-glad
             (lambda* (#:key inputs #:allow-other-keys)
               (substitute* "src/CMakeLists.txt"
@@ -340,6 +327,7 @@ supported devices, as well as input/output file format support.")
     (inputs
      (list fontconfig
            gtk+
+           imgui
            sdl2
            sqlite
            zlib))
@@ -385,7 +373,7 @@ such as:
                  (rmdir "doc/pulseview")
                  (rmdir "doc"))))))))
     (native-inputs
-     (list pkg-config qttools))
+     (list pkg-config qttools-5))
     (inputs
      (list boost
            glib
@@ -393,7 +381,7 @@ such as:
            libsigrok
            libsigrokdecode
            qtbase-5
-           qtsvg))
+           qtsvg-5))
     (home-page "https://www.sigrok.org/wiki/PulseView")
     (synopsis "Qt based logic analyzer, oscilloscope and MSO GUI for sigrok")
     (description "PulseView is a Qt based logic analyzer, oscilloscope and MSO GUI