gnu: Generalize the variable name of the test-only tzdata package.
[jackhill/guix/guix.git] / gnu / packages / pth.scm
index 5b8edc6..1908ce7 100644 (file)
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
         "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:parallel-build? #f))
+     `(#:parallel-build? #f
+       #:configure-flags (list 
+                           ,@(if (string=? "aarch64-linux"
+                                           (%current-system))
+                               '("--host=aarch64-unknown-linux-gnu")
+                               '()))))
     (home-page "https://www.gnu.org/software/pth/")
     (synopsis "Portable thread library")
     (description