Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / tls.scm
index 73bd0de..76370b7 100644 (file)
@@ -391,8 +391,7 @@ required structures.")
   (package
     (inherit openssl)
     (name "openssl")
-    (version "1.0.2s")
-    (replacement openssl-1.0.2t)
+    (version "1.0.2t")
     (source (origin
               (method url-fetch)
               (uri (list (string-append "https://www.openssl.org/source/openssl-"
@@ -404,7 +403,7 @@ required structures.")
                                         "/openssl-" version ".tar.gz")))
               (sha256
                (base32
-                "15mbmg8hf7s12vr3v2bdc0pi9y4pdbnsxhzk4fyyap42jaa5rgfa"))
+                "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))
               (patches (search-patches "openssl-runpath.patch"
                                        "openssl-c-rehash-in.patch"))))
     (outputs '("out"
@@ -412,6 +411,8 @@ required structures.")
                "static"))               ;6MiB of .a files
     (arguments
      (substitute-keyword-arguments (package-arguments openssl)
+       ;; Parallel build is not supported in 1.0.x.
+       ((#:parallel-build? _ #f) #f)
        ((#:phases phases)
         `(modify-phases ,phases
            (add-before 'patch-source-shebangs 'patch-tests
@@ -474,27 +475,6 @@ required structures.")
                                                          ,version "/misc"))
                  #t)))))))))
 
-(define openssl-1.0.2t
-  (package
-    (inherit openssl)
-    (version "1.0.2t")
-    (source (origin
-              (inherit (package-source openssl-1.0))
-              (uri (list (string-append "https://www.openssl.org/source/openssl-"
-                                        version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/"
-                                        "openssl-" version ".tar.gz")
-                         (string-append "ftp://ftp.openssl.org/source/old/"
-                                        (string-trim-right version char-set:letter)
-                                        "/openssl-" version ".tar.gz")))
-              (sha256
-               (base32
-                "1g67ra0ph7gpz6fgvv1i96d792jmd6ymci5kk53vbikszr74djql"))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments openssl-1.0)
-       ;; Parallel build is not supported in 1.0.x.
-       ((#:parallel-build? _ #f) #f)))))
-
 (define-public libressl
   (package
     (name "libressl")