gnu: bqn-sources: Update to commit 71ce3614...
[jackhill/guix/guix.git] / gnu / packages / bqn.scm
index 5029beb..58e27b8 100644 (file)
@@ -55,7 +55,6 @@
       (arguments
        (list
         #:imported-modules `(,@%gnu-build-system-modules
-                             (guix build syscalls)
                              (guix build ant-build-system))
         #:modules `((guix build gnu-build-system)
                     ((guix build ant-build-system)
@@ -114,7 +113,7 @@ the same author.")
   ;; Aside from dbqn above, the main bqn repository is used by other
   ;; implementations as a "known good" set of sources. CBQN uses dbqn to
   ;; generate an intermediate bytecode for its own compilation.
-    (let ((commit "e219af48401473a7bac49bdd8b89d69082cf5dd8"))
+    (let ((commit "71ce36141aaacfa714edca2e408ca522a3bc5554"))
       (origin
         (method git-fetch)
         (uri (git-reference
@@ -122,7 +121,7 @@ the same author.")
               (commit commit)))
         (file-name (git-file-name "bqn-sources" commit))
         (sha256
-         (base32 "0r6pa9lscl2395g4xlvmg90vpdsjzhin4f1r0s7brymmpvmns2yc")))))
+         (base32 "060a3r5m7hynzxj4iz1av2kj5jf8w3j8yswzzx9wkx31rdrsiv2c")))))
 
 (define cbqn-bootstrap
   (let* ((revision "1")
@@ -198,10 +197,12 @@ by APL.")
                        (lib (string-append (assoc-ref outputs "lib")
                                            "/lib")))
                   (mkdir-p bin)
-                  (copy-recursively "BQN"
-                                    (string-append bin "/bqn"))
+                  (rename-file "BQN" "bqn")
+                  (install-file "bqn" bin)
                   (install-file "libcbqn.so" lib))))))))
     (native-inputs (list dbqn
                          bqn-sources
                          libffi
-                         linux-libre-headers))))
+                         linux-libre-headers))
+    (properties
+     `((tunable? . #t)))))