gnu: ungoogled-chromium: Update to 81.0.4044.129-0.c2a89fb [security fixes].
[jackhill/guix/guix.git] / gnu / packages / vulkan.scm
index 0c7e22b..6a2c219 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -32,7 +32,6 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages freedesktop)
-  #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages xorg))
 
 (define-public spirv-headers
-  ;; Keep updated in accordance with
-  ;; https://github.com/google/shaderc/blob/known-good/known_good.json
-  (let ((commit "8bea0a266ac9b718aa0818d9e3a47c0b77c2cb23")
-        (revision "4"))
-    (package
-      (name "spirv-headers")
-      (version (string-append "0.0-" revision "." (string-take commit 9)))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/KhronosGroup/SPIRV-Headers")
-               (commit commit)))
-         (sha256
-          (base32
-           "01qyjghjz42hmyw9111zz20a1paf37ps39p4xbj8abjba65d8lqx"))
-         (file-name (string-append name "-" version "-checkout"))))
-      (build-system cmake-build-system)
-      (arguments
-       `(#:tests? #f ;; No tests
-         #:phases (modify-phases %standard-phases
-                    (replace 'install
-                      (lambda* (#:key outputs #:allow-other-keys)
-                        (invoke "cmake" "-E" "copy_directory"
-                                        "../source/include/spirv"
-                                        (string-append (assoc-ref outputs "out")
-                                                       "/include/spirv")))))))
-      (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
-      (synopsis "Machine-readable files from the SPIR-V Registry")
-      (description
-       "SPIRV-Headers is a repository containing machine-readable files from
+  (package
+    (name "spirv-headers")
+    (version "1.3.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/KhronosGroup/SPIRV-Headers")
+             (commit version)))
+       (sha256
+        (base32
+         "0m56smanfcczjfif4yfcqhjj4d4sc088kwg6dgia8fwdsjavdm4d"))
+      (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f ;; No tests
+       #:phases (modify-phases %standard-phases
+                  (replace 'install
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (invoke "cmake" "-E" "copy_directory"
+                                      "../source/include/spirv"
+                                      (string-append (assoc-ref outputs "out")
+                                                     "/include/spirv")))))))
+    (home-page "https://github.com/KhronosGroup/SPIRV-Headers")
+    (synopsis "Machine-readable files from the SPIR-V Registry")
+    (description
+     "SPIRV-Headers is a repository containing machine-readable files from
 the SPIR-V Registry.  This includes:
 @itemize
 @item Header files for various languages.
@@ -79,14 +74,14 @@ the SPIR-V Registry.  This includes:
 and for the GLSL.std.450 extended instruction set.
 @item The XML registry file.
 @end itemize\n")
-      (license (license:x11-style
-                (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
-                               commit "/LICENSE"))))))
+    (license (license:x11-style
+              (string-append "https://github.com/KhronosGroup/SPIRV-Headers/blob/"
+                             version "/LICENSE")))))
 
 (define-public spirv-tools
   (package
     (name "spirv-tools")
-    (version "2019.1")
+    (version "2019.2")
     (source
      (origin
       (method git-fetch)
@@ -94,24 +89,15 @@ and for the GLSL.std.450 extended instruction set.
             (url "https://github.com/KhronosGroup/SPIRV-Tools")
             (commit (string-append "v" version))))
       (sha256
-       (base32
-        "0vddjzhkrhrm3l3i57nxmq2smv3r1s0ka5ff2kziaahr4hqb479r"))
-      (file-name (string-append name "-" version "-checkout"))))
+       (base32 "0zwz6qg8g8165h7cw52agryjrdb29gbmsbziw3pwiddfkyma8vvg"))
+      (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ; FIXME: Tests fail.
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'fixgcc7
-           (lambda _
-             (unsetenv "C_INCLUDE_PATH")
-             (unsetenv "CPLUS_INCLUDE_PATH")
-             #t)))
        #:configure-flags (list (string-append "-DSPIRV-Headers_SOURCE_DIR="
                                (assoc-ref %build-inputs "spirv-headers")))))
     (inputs `(("spirv-headers" ,spirv-headers)))
-    (native-inputs `(("gcc" ,gcc-7)
-                     ("pkg-config" ,pkg-config)
+    (native-inputs `(("pkg-config" ,pkg-config)
                      ("python" ,python)))
     (home-page "https://github.com/KhronosGroup/SPIRV-Tools")
     (synopsis "API and commands for processing SPIR-V modules")
@@ -124,7 +110,7 @@ parser,disassembler, validator, and optimizer for SPIR-V.")
 (define-public glslang
   (package
     (name "glslang")
-    (version "7.11.3113")
+    (version "7.11.3214")
     (source
      (origin
        (method git-fetch)
@@ -133,7 +119,7 @@ parser,disassembler, validator, and optimizer for SPIR-V.")
              (commit version)))
        (sha256
         (base32
-         "1kzv2b4q1fddxd7c0hc754nd6rw6y9vijb9fsi13xzzq9dficgb6"))
+         "0dqjga0lcza006fhac26zp2plbq4gx8a6nsmrwkqlzji6lw1jins"))
        (file-name (string-append name "-" version "-checkout"))))
     (build-system cmake-build-system)
     (arguments
@@ -163,7 +149,7 @@ interpretation of the specifications for these languages.")
 (define-public vulkan-headers
   (package
     (name "vulkan-headers")
-    (version "1.1.103")
+    (version "1.1.121")
     (source
      (origin
        (method git-fetch)
@@ -173,7 +159,7 @@ interpretation of the specifications for these languages.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1q3c79rf3mma0vqmwnxwps588pnyzap4nn49hk41m39k79vniaz8"))))
+         "0hbgbdxj7lrm37phb0pkq5zgss3h21znj3mivnyva5f60i2wgr73"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f))                    ; No tests.
@@ -187,7 +173,7 @@ interpretation of the specifications for these languages.")
 (define-public vulkan-loader
   (package
     (name "vulkan-loader")
-    (version "1.1.102")
+    (version (package-version vulkan-headers))
     (source
      (origin
        (method git-fetch)
@@ -197,7 +183,7 @@ interpretation of the specifications for these languages.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0ccpklv251jcz2lxvd5ix5i3cg4wb7qq5xi6cwvniy1rw52z7h00"))))
+         "1gbrppfxrncvva30fikgzm7f15xs527sb4lf1sswdyxj3h5cw741"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f ;FIXME: 23/39 tests fail.  Try "tests/run_all_tests.sh".
@@ -232,13 +218,10 @@ and the ICD.")
                    (license:x11-style "file://COPYRIGHT.txt")
                    license:bsd-3))))
 
-(define-public vulkan-icd-loader
-  (deprecated-package "vulkan-icd-loader" vulkan-loader))
-
 (define-public vulkan-tools
   (package
     (name "vulkan-tools")
-    (version "1.1.102")
+    (version (package-version vulkan-headers))
     (source
      (origin
        (method git-fetch)
@@ -248,7 +231,7 @@ and the ICD.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0a8vmgyn7an21bb9vxba9laf9ghvk905vn7rm8frdl8qr2b7vyw3"))))
+         "1jndlz3n35zlz44p1b4cgl2alvsmgrqnkxdn5mpahg0zb8dgwmm8"))))
     (build-system cmake-build-system)
     (inputs
      `(("glslang" ,glslang)
@@ -275,7 +258,7 @@ API.")
 (define-public shaderc
   (package
     (name "shaderc")
-    (version "2018.0")
+    (version "2019.0")
     (source
      (origin
        (method git-fetch)
@@ -285,7 +268,7 @@ API.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0qigmj0riw43pgjn5f6kpvk72fajssz1lc2aiqib5qvmj9rqq3hl"))))
+         "1l5mmyxhzsbp0a6y2d86i8jmf46c6bjgjkdgkr5l8hmhflmm7gi2"))))
     (build-system meson-build-system)
     (arguments
      `(#:tests? #f ; FIXME: Tests fail.
@@ -330,7 +313,7 @@ API.")
      `(("googletest" ,googletest)
        ("python" ,python)))
     (native-inputs
-     `(("cmake" ,cmake)
+     `(("cmake" ,cmake-minimal)
        ("glslang-source" ,(package-source glslang))
        ("pkg-config" ,pkg-config)
        ("spirv-headers-source" ,(package-source spirv-headers))
@@ -362,7 +345,7 @@ shader compilation.")
      (native-inputs
       `(("autoconf" ,autoconf)
         ("automake" ,automake)
-        ("gettext" ,gnu-gettext)
+        ("gettext" ,gettext-minimal)
         ("libtool" ,libtool)
         ("pkg-config" ,pkg-config)))
      (inputs