hydra: Fix typo in core package list.
[jackhill/guix/guix.git] / gnu / packages / readline.scm
index 8623e63..f35a52f 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages readline)
   #:use-module (guix licenses)
-  #:use-module (distro)
+  #:use-module (gnu packages)
   #:use-module (gnu packages ncurses)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 (define-public readline
                         (find-files lib "\\.a"))))))
     (package
       (name "readline")
-      (version "6.2")
+      (version "6.3")
       (source (origin
                (method url-fetch)
                (uri (string-append "mirror://gnu/readline/readline-"
                                    version ".tar.gz"))
                (sha256
                 (base32
-                 "10ckm2bd2rkxhvdmj7nmbsylmihw0abwcsnxf8y27305183rd9kr"))))
+                 "0hzxr9jxqqx5sxsv9vmlxdnvlr9vi4ih1avjb869hbs6p5qn1fjn"))
+               (patches (list (search-patch "readline-link-ncurses.patch")))
+               (patch-flags '("-p0"))))
       (build-system gnu-build-system)
       (propagated-inputs `(("ncurses" ,ncurses)))
-      (inputs `(("patch/link-ncurses"
-                 ,(search-patch "readline-link-ncurses.patch"))))
-      (arguments `(#:patches (list (assoc-ref %build-inputs
-                                              "patch/link-ncurses"))
-                   #:patch-flags '("-p0")
-                   #:configure-flags
+      (arguments `(#:configure-flags
                    (list (string-append "LDFLAGS=-Wl,-rpath -Wl,"
                                         (assoc-ref %build-inputs "ncurses")
-                                        "/lib"))
+                                        "/lib")
+
+                         ;; This test does an 'AC_TRY_RUN', which aborts when
+                         ;; cross-compiling, so provide the correct answer.
+                         ,@(if (%current-target-system)
+                               '("bash_cv_wcwidth_broken=no")
+                               '()))
 
                    #:phases (alist-cons-after
                              'install 'post-install
                              ,post-install-phase
                              %standard-phases)))
-      (synopsis "GNU Readline, a library for interactive line editing")
+      (synopsis "Edit command lines while typing, with history support")
       (description
-       "The GNU Readline library provides a set of functions for use by
-applications that allow users to edit command lines as they are typed in.
-Both Emacs and vi editing modes are available.  The Readline library includes
-additional functions to maintain a list of previously-entered command lines,
-to recall and perhaps reedit those lines, and perform csh-like history
-expansion on previous commands.
-
-The history facilites are also placed into a separate library, the History
-library, as part of the build process.  The History library may be used
-without Readline in applications which desire its capabilities.")
+       "The GNU readline library allows users to edit command lines as they
+are typed in.  It can maintain a searchable history of previously entered
+commands, letting you easily recall, edit and re-enter past commands.  It
+features both Emacs-like and vi-like keybindings, making its usage
+comfortable for anyone.")
       (license gpl3+)
       (home-page "http://savannah.gnu.org/projects/readline/"))))