gnu: Add r-assessorf.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
index 2926e4c..67a62fa 100644 (file)
@@ -1384,6 +1384,29 @@ genomation package.  Included are Chip Seq, Methylation and Cage data,
 downloaded from Encode.")
     (license license:gpl3+)))
 
+(define-public r-macrophage
+  (package
+    (name "r-macrophage")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "macrophage" version
+                                     'experiment))
+              (sha256
+               (base32
+                "0ml8v92w021fmzsn4yl90ap3l4l3b9c1pk8pzsrm122p82wzlyms"))))
+    (properties `((upstream-name . "macrophage")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/macrophage")
+    (synopsis "Human macrophage immune response data")
+    (description
+     "This package provides the output of running @code{Salmon} on a set of 24
+RNA-seq samples from Alasoo, et al. \"Shared genetic effects on chromatin and
+gene expression indicate a role for enhancer priming in immune response\", published
+in Nature Genetics, January 2018.")
+    (license license:gpl2+)))
+
 (define-public r-msdata
   (package
     (name "r-msdata")
@@ -1605,6 +1628,30 @@ cultures from 4 patients at 2 time points over 3 conditions (DPN, OHT and contro
 TCGAbiolinksGUI package.")
     (license license:gpl3)))
 
+(define-public r-tximportdata
+  (package
+    (name "r-tximportdata")
+    (version "1.24.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "tximportData" version
+                                     'experiment))
+              (sha256
+               (base32
+                "0mgbwpybg2xd6x1ijrflmjh5w63qz6ylnzszbbyp437n618m7riy"))))
+    (properties `((upstream-name . "tximportData")))
+    (build-system r-build-system)
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/tximportData")
+    (synopsis "Data for the tximport package")
+    (description
+     "This package provides the output of running various transcript abundance
+quantifiers on a set of 6 RNA-seq samples from the GEUVADIS project.  The
+quantifiers were @code{Cufflinks}, @code{RSEM}, @code{kallisto}, @code{Salmon}
+and @code{Sailfish}.  Alevin example output is also included.")
+    (license license:gpl2+)))
+
+
 \f
 ;;; Packages
 
@@ -2270,6 +2317,507 @@ reproducible gene expression signatures capable of accurately distinguishing
 tumor samples from healthy controls.")
     (license license:artistic2.0)))
 
+(define-public r-assessorf
+  (package
+    (name "r-assessorf")
+    (version "1.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "AssessORF" version))
+              (sha256
+               (base32
+                "1l87bpny9k3jbzbzmb9h2ijvblrj471gqv26fyzbvb3vr6y406z7"))))
+    (properties `((upstream-name . "AssessORF")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biostrings
+           r-decipher
+           r-genomicranges
+           r-iranges))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/AssessORF")
+    (synopsis "Assess gene predictions using proteomics and evolutionary conservation")
+    (description
+     "In order to assess the quality of a set of predicted genes for a genome,
+evidence must first be mapped to that genome.  Next, each gene must be
+categorized based on how strong the evidence is for or against that gene.  The
+AssessORF package provides the functions and class structures necessary for
+accomplishing those tasks, using proteomics hits and evolutionarily conserved
+start codons as the forms of evidence.")
+    (license license:gpl3)))
+
+(define-public r-asset
+  (package
+    (name "r-asset")
+    (version "2.14.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "ASSET" version))
+              (sha256
+               (base32
+                "029acl5k9d4hnvy3jia9cr4rk6w31zn8b5s79i6lazq1cp236hbg"))))
+    (properties `((upstream-name . "ASSET")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-mass r-msm r-rmeta))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/ASSET")
+    (synopsis
+     "Subset-based association analysis of heterogeneous traits and subtypes")
+    (description
+     "This package is an R program for the subset-based analysis of
+heterogeneous traits and disease subtypes.  ASSET allows the user to search
+through all possible subsets of z-scores to identify the subset of traits
+giving the best meta-analyzed z-score.  Further, it returns a p-value
+adjusting for the multiple-testing involved in the search.  It also allows for
+searching for the best combination of disease subtypes associated with each
+variant.")
+    (license license:gpl2)))
+
+(define-public r-atena
+  (package
+    (name "r-atena")
+    (version "1.2.2")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "atena" version))
+              (sha256
+               (base32
+                "0b89wb7cc44c8jd6868dn8pwgid768bprkncsi87qkdz0abbhzhp"))))
+    (properties `((upstream-name . "atena")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-annotationhub
+           r-biocgenerics
+           r-biocparallel
+           r-genomeinfodb
+           r-genomicalignments
+           r-genomicranges
+           r-iranges
+           r-matrix
+           r-rsamtools
+           r-s4vectors
+           r-scales
+           r-sparsematrixstats
+           r-squarem
+           r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/functionalgenomics/atena")
+    (synopsis "Analysis of transposable elements")
+    (description
+     "The atena package quantifies expression of @dfn{TEs} (transposable
+elements) from RNA-seq data through different methods, including ERVmap,
+TEtranscripts and Telescope.  A common interface is provided to use each of
+these methods, which consists of building a parameter object, calling the
+quantification function with this object and getting a
+@code{SummarizedExperiment} object as an output container of the quantified
+expression profiles.  The implementation allows quantifing TEs and gene
+transcripts in an integrated manner.")
+    (license license:artistic2.0)))
+
+(define-public r-atsnp
+  (package
+    (name "r-atsnp")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "atSNP" version))
+              (sha256
+               (base32
+                "0dmv34xqwr3l2rznapxmyrkyf1w78qzxdv88s5nn8s1m8qdkgwkz"))))
+    (properties `((upstream-name . "atSNP")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocfilecache
+           r-biocparallel
+           r-bsgenome
+           r-data-table
+           r-ggplot2
+           r-lifecycle
+           r-motifstack
+           r-rappdirs
+           r-rcpp
+           r-testthat))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/sunyoungshin/atSNP")
+    (synopsis
+     "Affinity test for identifying regulatory single nucleotide polymorphisms")
+    (description
+     "The atSNP package performs affinity tests of motif matches with the
+@dfn{SNP} (single nucleotide polymorphism) or the reference genomes and
+SNP-led changes in motif matches.")
+    (license license:gpl2)))
+
+(define-public r-attract
+  (package
+    (name "r-attract")
+    (version "1.48.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "attract" version))
+              (sha256
+               (base32
+                "0f1fsv278kpnxvqg9qa5rw2k3zr8zws0ab73ldl60h6pv9cy8x82"))))
+    (properties `((upstream-name . "attract")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-annotationdbi
+           r-biobase
+           r-cluster
+           r-gostats
+           r-keggrest
+           r-limma
+           r-org-hs-eg-db
+           r-reactome-db))
+    (home-page "https://bioconductor.org/packages/attract")
+    (synopsis "Finding drivers of Kauffman's attractor landscape")
+    (description
+     "This package contains the functions to find the gene expression modules
+that represent the drivers of Kauffman's attractor landscape.  The modules are
+the core attractor pathways that discriminate between different cell types of
+groups of interest.  Each pathway has a set of synexpression groups, which show
+transcriptionally-coordinated changes in gene expression.")
+    (license license:lgpl2.0+)))
+
+(define-public r-awfisher
+  (package
+    (name "r-awfisher")
+    (version "1.10.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "AWFisher" version))
+              (sha256
+               (base32
+                "050k7w0azsl7rqx2pxgccihzc2q8pmh6fyy4gib2d42sdyijr2n1"))))
+    (properties `((upstream-name . "AWFisher")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-edger
+           r-limma))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/AWFisher")
+    (synopsis  "Fast computing for adaptively weighted fisher's method")
+    (description
+     "This package is an implementation of the Adaptively Weighted Fisher's
+method, including fast p-value computing, variability index, and
+meta-pattern.")
+    (license license:gpl3)))
+
+(define-public r-awst
+  (package
+    (name "r-awst")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "awst" version))
+              (sha256
+               (base32
+                "0iw3zycmj95rmdx7f2w0j4yxkzd90y87lrzgdn9cyvvzi5avflav"))))
+    (properties `((upstream-name . "awst")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-summarizedexperiment))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/drisso/awst")
+    (synopsis "Asymmetric within-sample transformation")
+    (description
+     "This package @dfn{awst} (Asymmetric Within-Sample Transformation) that
+regularizes RNA-seq read counts and reduces the effect of noise on the
+classification of samples.  AWST comprises two main steps: standardization and
+smoothing.  These steps transform gene expression data to reduce the noise of
+the lowly expressed features, which suffer from background effects and low
+signal-to-noise ratio, and the influence of the highly expressed features,
+which may be the result of amplification bias and other experimental
+artifacts.")
+    (license license:expat)))
+
+(define-public r-baalchip
+  (package
+    (name "r-baalchip")
+    (version "1.22.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BaalChIP" version))
+              (sha256
+               (base32
+                "02qwk9n2fyg5f9xxjiiha9mi6p9ii3zi5x7w84sh5d5g58s27g6q"))))
+    (properties `((upstream-name . "BaalChIP")))
+    (build-system r-build-system)
+    (inputs (list perl)) ; extra/get.overlaps.v2_chrXY.perl
+    (propagated-inputs
+     (list r-coda
+           r-doby
+           r-doparallel
+           r-foreach
+           r-genomeinfodb
+           r-genomicalignments
+           r-genomicranges
+           r-ggplot2
+           r-iranges
+           r-reshape2
+           r-rsamtools
+           r-scales))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/BaalChIP")
+    (synopsis
+     "Analysis of allele-specific transcription factor binding in cancer genomes")
+    (description
+     "This package offers functions to process multiple @code{ChIP-seq BAM}
+files and detect allele-specific events.  It computes allele counts at
+individual variants (SNPs/SNVs), implements extensive @dfn{QC} (quality
+control) steps to remove problematic variants, and utilizes a Bayesian
+framework to identify statistically significant allele-specific events.
+BaalChIP is able to account for copy number differences between the two
+alleles, a known phenotypical feature of cancer samples.")
+    (license license:artistic2.0)))
+
+(define-public r-basespacer
+  (package
+    (name "r-basespacer")
+    (version "1.40.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BaseSpaceR" version))
+              (sha256
+               (base32
+                "0jyw4pnybsd6ywpaamk5ywkrcib2z48farsnszmwq97zlbmra7fj"))))
+    (properties `((upstream-name . "BaseSpaceR")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-rcurl r-rjsonio))
+    (home-page "https://bioconductor.org/packages/BaseSpaceR")
+    (synopsis "R SDK for BaseSpace RESTful API")
+    (description
+     "This package provides an R interface to Illumina's BaseSpace cloud
+computing environment, enabling the fast development of data analysis and
+visualization tools.  Besides providing an easy to use set of tools for
+manipulating the data from BaseSpace, it also facilitates the access to R's
+rich environment of statistical and data analysis tools.")
+    (license license:asl2.0)))
+
+(define-public r-bac
+  (package
+    (name "r-bac")
+    (version "1.56.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BAC" version))
+              (sha256
+               (base32
+                "0dkw7438d2sf6nb577dnzija54qs0nhlr47lb73li60fhlnvqmh2"))))
+    (properties `((upstream-name . "BAC")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/BAC")
+    (synopsis "Bayesian analysis of Chip-chip experiment")
+    (description
+     "This package uses a Bayesian hierarchical model to detect enriched
+regions from ChIP-chip experiments.  The common goal in analyzing this
+ChIP-chip data is to detect DNA-protein interactions from ChIP-chip
+experiments.  The BAC package has mainly been tested with Affymetrix tiling
+array data.  However, we expect it to work with other platforms (e.g. Agilent,
+Nimblegen, cDNA, etc.).  Note that BAC does not deal with normalization, so
+you will have to normalize your data beforehand.")
+    (license license:artistic2.0)))
+
+(define-public r-bader
+  (package
+    (name "r-bader")
+    (version "1.34.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BADER" version))
+              (sha256
+               (base32
+                "0i5x1r2ns1hxhqk5jyfqird81hck1hllvvgx5bn0rb5vl99g8spm"))))
+    (properties `((upstream-name . "BADER")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/BADER")
+    (synopsis
+     "Bayesian analysis of differential expression in RNA sequencing data")
+    (description
+     "The BADER package is intended for the analysis of RNA sequencing data.
+The algorithm fits a Bayesian hierarchical model for RNA sequencing count
+data.  BADER returns the posterior probability of differential expression for
+each gene between two groups A and B.  The joint posterior distribution of the
+variables in the model can be returned in the form of posterior samples, which
+can be used for further down-stream analyses such as gene set enrichment.")
+    (license license:gpl2)))
+
+(define-public r-badregionfinder
+  (package
+    (name "r-badregionfinder")
+    (version "1.24.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BadRegionFinder" version))
+              (sha256
+               (base32
+                "1a1pqmh5ak9s3k1lxw6flanchk24zyznwm34ixi2b78wdc3hqgm9"))))
+    (properties `((upstream-name . "BadRegionFinder")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biomart
+           r-genomicranges
+           r-rsamtools
+           r-s4vectors
+           r-variantannotation))
+    (home-page "https://bioconductor.org/packages/BadRegionFinder")
+    (synopsis "Identifying regions with bad coverage in sequence alignment data")
+    (description
+     "BadRegionFinder is a package for identifying regions with a bad,
+acceptable and good coverage in sequence alignment data available as bam
+files.  The whole genome may be considered as well as a set of target regions.
+Various visual and textual types of output are available.")
+    (license license:lgpl3)))
+
+(define-public r-bambu
+  (package
+    (name "r-bambu")
+    (version "2.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "bambu" version))
+              (sha256
+               (base32
+                "0dc2hpnykr575jbrq9whmdabknl70s2hcs6gkmkl4kpv7xfqdq6w"))))
+    (properties `((upstream-name . "bambu")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocgenerics
+           r-biocparallel
+           r-bsgenome
+           r-data-table
+           r-dplyr
+           r-genomeinfodb
+           r-genomicalignments
+           r-genomicfeatures
+           r-genomicranges
+           r-iranges
+           r-rcpp
+           r-rcpparmadillo
+           r-rsamtools
+           r-s4vectors
+           r-summarizedexperiment
+           r-tidyr
+           r-xgboost))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/GoekeLab/bambu")
+    (synopsis
+     "Isoform reconstruction and quantification for long read RNA-Seq data")
+    (description
+     "This R package is for multi-sample transcript discovery and
+quantification using long read RNA-Seq data.  You can use bambu after read
+alignment to obtain expression estimates for known and novel transcripts and
+genes.  The output from bambu can directly be used for visualisation and
+downstream analysis, such as differential gene expression or transcript
+usage.")
+    (license license:gpl3)))
+
+(define-public r-bandits
+  (package
+    (name "r-bandits")
+    (version "1.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BANDITS" version))
+              (sha256
+               (base32
+                "1423djb7cij68y0q2dcp8q7lrcn2fxjn6d25v4qy3w00b2w8ppg9"))))
+    (properties `((upstream-name . "BANDITS")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocparallel
+           r-data-table
+           r-doparallel
+           r-dorng
+           r-drimseq
+           r-foreach
+           r-ggplot2
+           r-mass
+           r-r-utils
+           r-rcpp
+           r-rcpparmadillo))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/SimoneTiberi/BANDITS")
+    (synopsis "Bayesian analysis of differential splicing")
+    (description
+     "BANDITS is a Bayesian hierarchical model for detecting differential
+splicing of genes and transcripts, via @dfn{DTU} (differential transcript
+usage), between two or more conditions.  The method uses a Bayesian
+hierarchical framework, which allows for sample specific proportions in a
+Dirichlet-Multinomial model, and samples the allocation of fragments to the
+transcripts.  Parameters are inferred via @dfn{MCMC} (Markov chain Monte
+Carlo) techniques and a DTU test is performed via a multivariate Wald test on
+the posterior densities for the average relative abundance of transcripts.")
+    (license license:gpl3+)))
+
+(define-public r-banocc
+  (package
+    (name "r-banocc")
+    (version "1.20.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "banocc" version))
+              (sha256
+               (base32
+                "10vaggq1w5jkxd8r2k1mhymzvb7x3h8afwn2pvmcpj022ka7xhbx"))))
+    (properties `((upstream-name . "banocc")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-coda
+           r-mvtnorm
+           r-rstan
+           r-stringr))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/banocc")
+    (synopsis "Bayesian analysis of compositional covariance")
+    (description
+     "BAnOCC is a package designed for compositional data, where each sample
+sums to one.  It infers the approximate covariance of the unconstrained data
+using a Bayesian model coded with @code{rstan}.  It provides as output the
+@code{stanfit} object as well as posterior median and credible interval
+estimates for each correlation element.")
+    (license license:expat)))
+
+(define-public r-barcodetrackr
+  (package
+    (name "r-barcodetrackr")
+    (version "1.4.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "barcodetrackR" version))
+              (sha256
+               (base32
+                "0yxa15xkgqazw31vq4wm8v747bw4qb18m6i602pvynk0n5bgg3d3"))))
+    (properties `((upstream-name . "barcodetrackR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-circlize
+           r-cowplot
+           r-dplyr
+           r-ggdendro
+           r-ggplot2
+           r-ggridges
+           r-magrittr
+           r-plyr
+           r-proxy
+           r-rcolorbrewer
+           r-rlang
+           r-s4vectors
+           r-scales
+           r-shiny
+           r-summarizedexperiment
+           r-tibble
+           r-tidyr
+           r-vegan
+           r-viridis))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/dunbarlabNIH/barcodetrackR")
+    (synopsis "Functions for analyzing cellular barcoding data")
+    (description
+     "This package is developed for the analysis and visualization of clonal
+tracking data.  The required data is formed by samples and tag abundances in
+matrix form, usually from cellular barcoding experiments, integration site
+retrieval analyses, or similar technologies.")
+    (license license:cc0)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")
@@ -11735,14 +12283,14 @@ manipulation of flow cytometry data.")
 (define-public r-ggcyto
   (package
     (name "r-ggcyto")
-    (version "1.24.0")
+    (version "1.24.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "ggcyto" version))
        (sha256
         (base32
-         "0sycyvdpa77mykzr709a7padh6478zmnzapibbq90qkc7bxnj359"))))
+         "1cw60x78vqzjmgb5xd3sxyz6zwdaffp3byk34z8d4b3wkh530325"))))
     (properties `((upstream-name . "ggcyto")))
     (build-system r-build-system)
     (propagated-inputs
@@ -11772,14 +12320,14 @@ statistics to the plot.")
 (define-public r-flowviz
   (package
     (name "r-flowviz")
-    (version "1.60.0")
+    (version "1.60.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "flowViz" version))
        (sha256
         (base32
-         "175ygncrv6q6mb8pahixs89m9wm6hdpzx489gc9s8lgad2vrvz8f"))))
+         "08rwzc26jns0wwjsqqmf60bpxsckr5x8skdn9iwl8grp81npcc95"))))
     (properties `((upstream-name . "flowViz")))
     (build-system r-build-system)
     (propagated-inputs
@@ -11920,14 +12468,14 @@ matches the flowJo analysis.")
 (define-public r-flowstats
   (package
     (name "r-flowstats")
-    (version "4.8.0")
+    (version "4.8.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "flowStats" version))
        (sha256
         (base32
-         "1jbc92ah2mlpnd7v3k0207v4qz3rg9g9yy6r6y0s0cc5nifdyhwj"))))
+         "1x01gg5ifxh3wp0cp5a23lr9v6l9q5qg8145q2pgn904jkx5wldc"))))
     (properties `((upstream-name . "flowStats")))
     (build-system r-build-system)
     (propagated-inputs
@@ -11958,14 +12506,14 @@ package.")
 (define-public r-opencyto
   (package
     (name "r-opencyto")
-    (version "2.8.0")
+    (version "2.8.4")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "openCyto" version))
        (sha256
         (base32
-         "1nz5fra0jf70jwyfbcz5ksnz5xb62vfnfwfasr0zwwvjvmmvrs1y"))))
+         "0fa3hbbrjw458dhmxdjypcjgyxmphp9kdr3r62qqf803i4wsxfk0"))))
     (properties `((upstream-name . "openCyto")))
     (build-system r-build-system)
     (propagated-inputs
@@ -12002,14 +12550,14 @@ sequential way to mimic the manual gating strategy.")
 (define-public r-cytoml
   (package
     (name "r-cytoml")
-    (version "2.8.0")
+    (version "2.8.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "CytoML" version))
        (sha256
         (base32
-         "0vp7advfh1d8596hjpzayasjhga4mx0l104sgz2asscbrjm4v7rr"))))
+         "01yzdljpyq92bv318b5qs29f190226zwbqjnckvxmbb0k8m7s5hw"))))
     (properties `((upstream-name . "CytoML")))
     (build-system r-build-system)
     (inputs
@@ -13761,13 +14309,13 @@ monograph.")
 (define-public r-bioccheck
   (package
     (name "r-bioccheck")
-    (version "1.32.0")
+    (version "1.32.1")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "BiocCheck" version))
               (sha256
                (base32
-                "1k1gxzmxx26hmwdxgagv93mv4jwyygkk8703ds6nvryzhqffzkbc"))))
+                "0bq4xrz1spp0bmbccxydkw6yw03by5dysz85mn152ab6xixm52lw"))))
     (properties
      `((upstream-name . "BiocCheck")))
     (build-system r-build-system)
@@ -13836,13 +14384,13 @@ functionality.")
 (define-public r-biocviews
   (package
     (name "r-biocviews")
-    (version "1.64.0")
+    (version "1.64.1")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "biocViews" version))
               (sha256
                (base32
-                "1lahla53awdqiglfiygbxg5pkzfabym7n5abgyp1nvqsvsj0g126"))))
+                "0ixcx9qqpmwmnhml3klk5z075km8g2l4q0iqc1dbniga87qgyl38"))))
     (properties
      `((upstream-name . "biocViews")))
     (build-system r-build-system)
@@ -14032,14 +14580,14 @@ gene selection, testing relationships, and so on.")
 (define-public r-biocpkgtools
   (package
     (name "r-biocpkgtools")
-    (version "1.14.0")
+    (version "1.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "BiocPkgTools" version))
        (sha256
         (base32
-         "1v0824vmg49q9lh0igdyniryyknw6vmh462rn25kmg9hdna0w99h"))))
+         "0akryshjdn227a8ir8r0lb59v060h58rhy5vjmdxax8p81ajzxkd"))))
     (properties `((upstream-name . "BiocPkgTools")))
     (build-system r-build-system)
     (propagated-inputs
@@ -14522,6 +15070,44 @@ data manipulation and visualization.")
 objects from the @code{graph} package.")
     (license license:epl1.0)))
 
+(define-public r-fishpond
+  (package
+    (name "r-fishpond")
+    (version "2.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "fishpond" version))
+              (sha256
+               (base32
+                "0svp4yh0srhzbbxy1grchzdd9yzchadjp3d2sy2n9xpwxzpkhrym"))))
+    (properties `((upstream-name . "fishpond")))
+    (build-system r-build-system)
+    (inputs (list zlib))
+    (propagated-inputs
+     (list r-abind
+           r-genomicranges
+           r-gtools
+           r-iranges
+           r-jsonlite
+           r-matrix
+           r-matrixstats
+           r-qvalue
+           r-rcpp
+           r-s4vectors
+           r-singlecellexperiment
+           r-summarizedexperiment
+           r-svmisc))
+    (native-inputs (list r-knitr))
+    (home-page "https://github.com/mikelove/fishpond")
+    (synopsis "Downstream methods and tools for expression data")
+    (description
+     "The @code{fishpond} package contains methods for differential transcript
+and gene expression analysis of RNA-seq data using inferential replicates for
+uncertainty of abundance quantification, as generated by Gibbs sampling or
+bootstrap sampling.  Also the package contains a number of utilities for
+working with Salmon and Alevin quantification files.")
+    (license license:gpl2)))
+
 (define-public r-fithic
   (package
     (name "r-fithic")
@@ -14578,14 +15164,14 @@ provided.")
 (define-public r-hdf5array
   (package
     (name "r-hdf5array")
-    (version "1.24.1")
+    (version "1.24.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "HDF5Array" version))
        (sha256
         (base32
-         "1r1lg7k60qgb489xkypd4gvm1fmdlihvylb5va6xj58ipndbfday"))))
+         "1dzx5463ig3ag72a47slc4jbq5id11w77cj0zgzr85h0dbxklrr9"))))
     (properties `((upstream-name . "HDF5Array")))
     (build-system r-build-system)
     (inputs
@@ -14979,14 +15565,14 @@ cell types to infer the cell of origin of each single cell independently.")
 (define-public r-scuttle
   (package
     (name "r-scuttle")
-    (version "1.6.2")
+    (version "1.6.3")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "scuttle" version))
        (sha256
         (base32
-         "0nnmq3wf436xaw4arc4y3ldvn6ilsg52xzbccmid0icb8z3y2kzn"))))
+         "1w1jy5fqkp2d03lp84d49fsksnl0pcg0wgqyd49d5k1mipdw4671"))))
     (properties `((upstream-name . "scuttle")))
     (build-system r-build-system)
     (propagated-inputs
@@ -15056,14 +15642,14 @@ quality control.")
 (define-public r-scran
   (package
     (name "r-scran")
-    (version "1.24.0")
+    (version "1.24.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "scran" version))
        (sha256
         (base32
-         "0xg7dl35915a65pmzkxdacsm4iqf97ayljdjljcvqx1ycmn7x68w"))))
+         "1a6vlq8i5gh7zxm6igmy75187pkx42z28qjag50m49xy5valw3ni"))))
     (build-system r-build-system)
     (propagated-inputs
      (list r-beachmat
@@ -15124,14 +15710,14 @@ data in the column sparse format.")
 (define-public r-delayedmatrixstats
   (package
     (name "r-delayedmatrixstats")
-    (version "1.18.0")
+    (version "1.18.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "DelayedMatrixStats" version))
        (sha256
         (base32
-         "1qlwv69c0r2w3zkmsr8r7w6sr3hf1ha0sfcrsjx4ks8f0ww7aqsv"))))
+         "1kq643fmfzq1qjvpj3kc092ahc3qamqgx53layqsyvz5mil55jjv"))))
     (properties
      `((upstream-name . "DelayedMatrixStats")))
     (build-system r-build-system)
@@ -15806,13 +16392,13 @@ other functional sequencing data.")
 (define-public r-pathview
   (package
     (name "r-pathview")
-    (version "1.36.0")
+    (version "1.36.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "pathview" version))
        (sha256
-        (base32 "1472k107f21cflbx2fip92g8gl9wlwxgwfvgvl73ma0y0jzs0qdq"))))
+        (base32 "11g4zhy4qfq0gmy588334f7s2w1acs2dz9kimax5ya2b8jjibk71"))))
     (properties `((upstream-name . "pathview")))
     (build-system r-build-system)
     (propagated-inputs
@@ -16055,14 +16641,14 @@ real numbers.")
 (define-public r-bgeecall
   (package
     (name "r-bgeecall")
-    (version "1.12.1")
+    (version "1.12.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "BgeeCall" version))
        (sha256
         (base32
-         "1g12cms66zb45p347h3b358vjhnq76galvwqwq86xby4hnwpdzkh"))))
+         "0l6smwy55mm4clb71l4bpch3bayyyf87nq1asbrv6s6fd22mmwil"))))
     (properties `((upstream-name . "BgeeCall")))
     (build-system r-build-system)
     (propagated-inputs
@@ -16244,14 +16830,14 @@ package, primarily for creation of the underlying Conda instance.")
 (define-public r-basilisk
   (package
     (name "r-basilisk")
-    (version "1.8.0")
+    (version "1.8.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "basilisk" version))
        (sha256
         (base32
-         "1p90wq8a9wrpqpgmcy4zgh5skdw65gg2gsb3lnx78zk9khq0yyzh"))))
+         "134xix2iq5l7783dng2jjklxd3m5lh4snb7bjhslrs2r1j3p8jpk"))))
     (properties `((upstream-name . "basilisk")))
     (build-system r-build-system)
     (propagated-inputs
@@ -16304,14 +16890,14 @@ Bioconductor-friendly.")
 (define-public r-biocdockermanager
   (package
     (name "r-biocdockermanager")
-    (version "1.8.0")
+    (version "1.8.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "BiocDockerManager" version))
        (sha256
         (base32
-         "0kl6r8ad728a8dvqx0safj7v5gj1rxxcdiw44jkr1pd5ddv0xbi6"))))
+         "0a4dcga18bw5mvzmsml28bf4zclz32pp9iflnbvps7pdxvhmmg9d"))))
     (properties
      `((upstream-name . "BiocDockerManager")))
     (build-system r-build-system)
@@ -16334,14 +16920,14 @@ the Bioconductor project.")
 (define-public r-biodb
   (package
     (name "r-biodb")
-    (version "1.4.0")
+    (version "1.4.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "biodb" version))
        (sha256
         (base32
-         "02i0n29bp9d9p1ibslxca5m37qsgny2hlgg7d364lf7kc6y2bqni"))))
+         "0f3clqmrpaawhjjyb4x5mnbhsam56r0av05b5cl5p4waylp8qbs1"))))
     (properties `((upstream-name . "biodb")))
     (build-system r-build-system)
     (propagated-inputs
@@ -16475,32 +17061,32 @@ using aCGH or sequencing.")
 (define-public r-bionero
   (package
     (name "r-bionero")
-    (version "1.4.0")
+    (version "1.4.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "BioNERO" version))
        (sha256
         (base32
-         "1nyzjbl0gcwvbj2nxfwykirikf8j3rsx5ny45bqjbcb4r23k65kj"))))
+         "0dsznfnhidbmf52rv8l26f1ms2k9yy4q4c6cf3x8ylc79c1sjrcp"))))
     (properties `((upstream-name . "BioNERO")))
     (build-system r-build-system)
     (propagated-inputs
      (list r-biocparallel
            r-complexheatmap
-           r-deseq2
            r-dynamictreecut
            r-genie3
            r-ggnetwork
            r-ggnewscale
            r-ggplot2
-           r-ggpubr
+           r-ggrepel
            r-igraph
            r-intergraph
            r-matrixstats
            r-minet
            r-netrep
            r-networkd3
+           r-patchwork
            r-rcolorbrewer
            r-reshape2
            r-summarizedexperiment
@@ -16743,6 +17329,43 @@ ensemble machine learning for the estimation of nuisance functions.")
 visualizing bisulfite sequencing data.")
     (license license:artistic2.0)))
 
+(define-public r-dada2
+  (package
+    (name "r-dada2")
+    (version "1.24.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "dada2" version))
+              (sha256
+               (base32
+                "0nvjnmcjh0i660y8s3rh9b3zl163wxdx7qm2n36m6vf0iy987l4x"))))
+    (properties `((upstream-name . "dada2")))
+    (build-system r-build-system)
+    (propagated-inputs
+     (list r-biocgenerics
+           r-biostrings
+           r-ggplot2
+           r-iranges
+           r-rcpp
+           r-rcppparallel
+           r-reshape2
+           r-shortread
+           r-xvector))
+    (native-inputs (list r-knitr))
+    (home-page "https://benjjneb.github.io/dada2/")
+    (synopsis
+     "Accurate, high-resolution sample inference from amplicon sequencing data")
+    (description
+     "The dada2 package infers exact @dfn{amplicon sequence variants} (ASVs)
+from high-throughput amplicon sequencing data, replacing the coarser and less
+accurate OTU clustering approach.  The dada2 pipeline takes as input
+demultiplexed fastq files, and outputs the sequence variants and their
+sample-wise abundances after removing substitution and chimera errors.
+Taxonomic classification is available via a native implementation of the RDP
+naive Bayesian classifier, and species-level assignment to 16S rRNA gene
+fragments by exact matching.")
+    (license license:lgpl2.0)))
+
 (define-public r-dmrseq
   (package
     (name "r-dmrseq")
@@ -17010,14 +17633,14 @@ embeddings and functions to build new reference.")
 (define-public r-tximeta
   (package
     (name "r-tximeta")
-    (version "1.14.0")
+    (version "1.14.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "tximeta" version))
        (sha256
         (base32
-         "1vq7x1sf5h8iwdalalbrybxzbq47s2ymb75himj5wkv77mgcivfl"))))
+         "0hxq5lkrdiz0a3xpl88adrv4m55jr6g46a5m9pamc0w4bxddirr8"))))
     (properties `((upstream-name . "tximeta")))
     (build-system r-build-system)
     (propagated-inputs