gnu: watchexec: Update to 1.14.1.
[jackhill/guix/guix.git] / gnu / packages / lisp-xyz.scm
index 885c401..2d9ad8c 100644 (file)
@@ -455,6 +455,41 @@ compatible with ANSI-compliant Common Lisp implementations.")
 (define-public ecl-cl-ppcre
   (sbcl-package->ecl-package sbcl-cl-ppcre))
 
+(define-public sbcl-uax-15
+  (let ((commit "e7439a91b72f533fcf736643e3ff0677b56c2e7d")
+        (revision "1"))
+    (package
+      (name "sbcl-uax-15")
+      (version (git-version "0.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/sabracrolleton/uax-15")
+               (commit commit)))
+         (file-name (git-file-name "uax-15" version))
+         (sha256
+          (base32 "1vf8a2aikgx0l5bsq0z9s0dw3sgx1887xhagdlf66fwffa5jskg6"))))
+      (build-system asdf-build-system/sbcl)
+      (native-inputs
+       `(("fiveam" ,sbcl-fiveam)))
+      (inputs
+       `(("cl-ppcre" ,sbcl-cl-ppcre)
+         ("split-sequence" ,sbcl-split-sequence)))
+      (arguments
+       `(#:asd-systems '("uax-15")))
+      (home-page "https://github.com/sabracrolleton/uax-15")
+      (synopsis "Common Lisp implementation of unicode normalization functions")
+      (description "This package provides supports for unicode normalization,
+RFC8264 and RFC7564.")
+      (license license:expat))))
+
+(define-public cl-uax-15
+  (sbcl-package->cl-source-package sbcl-uax-15))
+
+(define-public ecl-uax-15
+  (sbcl-package->ecl-package sbcl-uax-15))
+
 (define-public sbcl-cl-unicode
   (package
     (name "sbcl-cl-unicode")
@@ -747,82 +782,79 @@ antialiased TrueType font rendering using CLX and XRender extension.")
   (sbcl-package->ecl-package sbcl-clx-truetype))
 
 (define-public sbcl-slynk
-  (let ((revision "4")
-        ;; Update together with emacs-sly.
-        (commit "68561f1b7b66fa0240766ece836bb04da31ea17d"))
-    (package
-      (name "sbcl-slynk")
-      (version (git-version "1.0.0-beta" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri
-          (git-reference
-           (url "https://github.com/joaotavora/sly")
-           (commit commit)))
-         (sha256
-          (base32 "1xwx537dhgclngi6b0faf320i8pnac9309wvmk6z2g6dm3v652ds"))
-         (file-name (git-file-name "slynk" version))
-         (modules '((guix build utils)
-                    (ice-9 ftw)))
-         (snippet
-          '(begin
-             ;; Move the contribs into the main source directory for easier
-             ;; access
-             (substitute* "slynk/slynk.asd"
-               (("\\.\\./contrib")
-                "contrib"))
-             (rename-file "contrib" "slynk/contrib")
-             ;; Move slynk's contents into the base directory for easier
-             ;; access
-             (for-each (lambda (file)
-                         (unless (string-prefix? "." file)
-                           (rename-file (string-append "slynk/" file)
-                                        (string-append "./" (basename file)))))
-                       (scandir "slynk"))
-             #t))))
-      (build-system asdf-build-system/sbcl)
-      (outputs '("out" "image"))
-      (arguments
-       `(#:tests? #f ; No test suite
-         #:asd-systems '("slynk"
-                         "slynk/arglists"
-                         "slynk/fancy-inspector"
-                         "slynk/package-fu"
-                         "slynk/mrepl"
-                         "slynk/trace-dialog"
-                         "slynk/profiler"
-                         "slynk/stickers"
-                         "slynk/indentation"
-                         "slynk/retro")
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'create-asdf-configuration 'build-image
-             (lambda* (#:key outputs #:allow-other-keys)
-               (build-image (string-append
-                             (assoc-ref %outputs "image")
-                             "/bin/slynk")
-                            %outputs
-                            #:dependencies '("slynk"
-                                             "slynk/arglists"
-                                             "slynk/fancy-inspector"
-                                             "slynk/package-fu"
-                                             "slynk/mrepl"
-                                             "slynk/trace-dialog"
-                                             "slynk/profiler"
-                                             "slynk/stickers"
-                                             "slynk/indentation"
-                                             "slynk/retro"))
-               #t)))))
-      (synopsis "Common Lisp IDE for Emacs")
-      (description "SLY is a fork of SLIME, an IDE backend for Common Lisp.
+  (package
+    (name "sbcl-slynk")
+    (version "1.0.42")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/joaotavora/sly")
+         (commit version)))
+       (sha256
+        (base32 "10l867c4hgcpiajcfkz9g9vabp7y4bcgy51la6n9pqxrlg1fs455"))
+       (file-name (git-file-name "slynk" version))
+       (modules '((guix build utils)
+                  (ice-9 ftw)))
+       (snippet
+        '(begin
+           ;; Move the contribs into the main source directory for easier
+           ;; access
+           (substitute* "slynk/slynk.asd"
+             (("\\.\\./contrib")
+              "contrib"))
+           (rename-file "contrib" "slynk/contrib")
+           ;; Move slynk's contents into the base directory for easier
+           ;; access
+           (for-each (lambda (file)
+                       (unless (string-prefix? "." file)
+                         (rename-file (string-append "slynk/" file)
+                                      (string-append "./" (basename file)))))
+                     (scandir "slynk"))
+           #t))))
+    (build-system asdf-build-system/sbcl)
+    (outputs '("out" "image"))
+    (arguments
+     `(#:tests? #f                      ; No test suite
+       #:asd-systems '("slynk"
+                       "slynk/arglists"
+                       "slynk/fancy-inspector"
+                       "slynk/package-fu"
+                       "slynk/mrepl"
+                       "slynk/trace-dialog"
+                       "slynk/profiler"
+                       "slynk/stickers"
+                       "slynk/indentation"
+                       "slynk/retro")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'create-asdf-configuration 'build-image
+           (lambda* (#:key outputs #:allow-other-keys)
+             (build-image (string-append
+                           (assoc-ref %outputs "image")
+                           "/bin/slynk")
+                          %outputs
+                          #:dependencies '("slynk"
+                                           "slynk/arglists"
+                                           "slynk/fancy-inspector"
+                                           "slynk/package-fu"
+                                           "slynk/mrepl"
+                                           "slynk/trace-dialog"
+                                           "slynk/profiler"
+                                           "slynk/stickers"
+                                           "slynk/indentation"
+                                           "slynk/retro"))
+             #t)))))
+    (synopsis "Common Lisp IDE for Emacs")
+    (description "SLY is a fork of SLIME, an IDE backend for Common Lisp.
 It also features a completely redesigned REPL based on Emacs's own
 full-featured @code{comint-mode}, live code annotations, and a consistent interactive
 button interface.  Everything can be copied to the REPL.  One can create
 multiple inspectors with independent history.")
-      (home-page "https://github.com/joaotavora/sly")
-      (license license:public-domain)
-      (properties `((cl-source-variant . ,(delay cl-slynk)))))))
+    (home-page "https://github.com/joaotavora/sly")
+    (license license:public-domain)
+    (properties `((cl-source-variant . ,(delay cl-slynk))))))
 
 (define-public cl-slynk
   (sbcl-package->cl-source-package sbcl-slynk))
@@ -4377,8 +4409,8 @@ mime-type of a file.")
   (sbcl-package->ecl-package sbcl-ningle))
 
 (define-public sbcl-cl-fastcgi
-  (let ((commit "d576d20eeb12f225201074b28934ba395b15781a")
-        (revision "1"))
+  (let ((commit "de8b49b26de9863996ec18db28af8ab7e8ac4e20")
+        (revision "2"))
     (package
       (name "sbcl-cl-fastcgi")
       (version (git-version "0.2" revision commit))
@@ -4390,7 +4422,7 @@ mime-type of a file.")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "02mvzzyn0k960s38rbxaqqmdkwcfmyhf8dx6ynz8xyxflmp0s5zv"))))
+          (base32 "0xgmhx766q4nmrvn5z7ag3ikpr9phlh8ypi8b14azshq9lqbq0m7"))))
       (build-system asdf-build-system/sbcl)
       (inputs
        `(("usocket" ,sbcl-usocket)
@@ -4411,8 +4443,6 @@ mime-type of a file.")
       (description
        "CL-FastCGI is a generic version of SB-FastCGI, targeting to run on
 mostly Common Lisp implementation.")
-      ;; TODO: Upstream on specifies "BSD license":
-      ;; https://github.com/KDr2/cl-fastcgi/issues/4
       (license license:bsd-2))))
 
 (define-public cl-fastcgi
@@ -10647,8 +10677,8 @@ and saving 2-dimensional pixel-based images.")
   (sbcl-package->ecl-package sbcl-opticl))
 
 (define-public sbcl-mcclim
-  (let ((commit "27b4d7a667c9b3faa74cabcb57706b888314fff7")
-        (revision "0"))
+  (let ((commit "04cc542dd4b461b9d56406e40681d1a8f080730f")
+        (revision "1"))
     (package
       (name "sbcl-mcclim")
       (version (git-version "0.9.7" revision commit))
@@ -10660,7 +10690,7 @@ and saving 2-dimensional pixel-based images.")
                (commit commit)))
          (file-name (git-file-name name version))
          (sha256
-          (base32 "0jijfgkwas6xnpp5wiii6slcx9pgsalngacb8zm29x6pamx2193h"))))
+          (base32 "1xjly8i62z72hfhlnz5kjd9i8xhrwckc7avyizxvhih67pkjmsx0"))))
       (build-system asdf-build-system/sbcl)
       (native-inputs
        `(("fiveam" ,sbcl-fiveam)
@@ -10771,6 +10801,43 @@ Inflector module.")
 (define-public ecl-cl-inflector
   (sbcl-package->ecl-package sbcl-cl-inflector))
 
+(define-public sbcl-ixf
+  (let ((commit "ed26f87e4127e4a9e3aac4ff1e60d1f39cca5183")
+        (revision "1"))
+    (package
+      (name "sbcl-ixf")
+      (version (git-version "0.1.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/dimitri/cl-ixf")
+               (commit commit)))
+         (file-name (git-file-name "cl-ixf" version))
+         (sha256
+          (base32 "1wjdnf4vr9z7lcfc49kl43g6l2i23q9n81siy494k17d766cdvqa"))))
+      (build-system asdf-build-system/sbcl)
+      (inputs
+       `(("alexandria" ,sbcl-alexandria)
+         ("babel" ,sbcl-babel)
+         ("cl-ppcre" ,sbcl-cl-ppcre)
+         ("ieee-floats" ,sbcl-ieee-floats)
+         ("local-time" ,sbcl-local-time)
+         ("md5" ,sbcl-md5)
+         ("split-sequence" ,sbcl-split-sequence)))
+      (home-page "https://github.com/dimitri/cl-ixf")
+      (synopsis "Parse IBM IXF file format")
+      (description
+       "This is a Common Lisp library to handle the IBM PC version of the IXF
+(Integration Exchange Format) file format.")
+      (license license:public-domain))))
+
+(define-public ecl-ixf
+  (sbcl-package->ecl-package sbcl-ixf))
+
+(define-public cl-ixf
+  (sbcl-package->cl-source-package sbcl-ixf))
+
 (define-public sbcl-qbase64
   (package
     (name "sbcl-qbase64")