Merge branch 'debian' into hcoop_489
[hcoop/debian/exim4.git] / debian / patches / 80_Avoid-release-of-store-if-there-have-been-later-allo.patch
diff --git a/debian/patches/80_Avoid-release-of-store-if-there-have-been-later-allo.patch b/debian/patches/80_Avoid-release-of-store-if-there-have-been-later-allo.patch
new file mode 100644 (file)
index 0000000..1b55f79
--- /dev/null
@@ -0,0 +1,40 @@
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Fri, 24 Nov 2017 20:22:33 +0000
+Subject: Avoid release of store if there have been later allocations.  Bug
+ 2199
+Origin: https://git.exim.org/exim.git/commit/4090d62a4b25782129cc1643596dc2f6e8f63bde
+Bug: https://bugs.exim.org/show_bug.cgi?id=2199
+Bug-Debian: https://bugs.debian.org/882648
+Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2017-16943
+
+---
+diff --git a/src/receive.c b/src/receive.c
+index 95cf13e1..20672dbe 100644
+--- a/src/receive.c
++++ b/src/receive.c
+@@ -1772,8 +1772,8 @@ for (;;)
+   (and sometimes lunatic messages can have ones that are 100s of K long) we
+   call store_release() for strings that have been copied - if the string is at
+   the start of a block (and therefore the only thing in it, because we aren't
+-  doing any other gets), the block gets freed. We can only do this because we
+-  know there are no other calls to store_get() going on. */
++  doing any other gets), the block gets freed. We can only do this release if
++  there were no allocations since the once that we want to free. */
+   if (ptr >= header_size - 4)
+     {
+@@ -1782,9 +1782,10 @@ for (;;)
+     header_size *= 2;
+     if (!store_extend(next->text, oldsize, header_size))
+       {
++      BOOL release_ok = store_last_get[store_pool] == next->text;
+       uschar *newtext = store_get(header_size);
+       memcpy(newtext, next->text, ptr);
+-      store_release(next->text);
++      if (release_ok) store_release(next->text);
+       next->text = newtext;
+       }
+     }
+-- 
+2.15.0
+