Merge branch 'debian' into hcoop_489
[hcoop/debian/exim4.git] / debian / patches / 35_install.dpatch
index b926110..d0ab602 100755 (executable)
@@ -3,23 +3,20 @@ Description: Exim's installation scripts install the binary as
 Author: Andreas Metzler <ametzler@debian.org>
 Origin: vendor
 Forwarded: not-needed
-Last-Update: 2013-09-28
+Last-Update: 2016-09-25
 
---- exim4-4.82~rc1.orig/scripts/exim_install
-+++ exim4-4.82~rc1/scripts/exim_install
-@@ -217,8 +217,9 @@ while [ $# -gt 0 ]; do
-   # The exim binary is handled specially
-   if [ $name = exim${EXE} ]; then
--    version=exim-`./exim -bV -C /dev/null | \
--      awk '/Exim version/ { OFS=""; print $3,"-",substr($4,2,length($4)-1) }'`${EXE}
-+    version=exim
-+#    version=exim-`./exim -bV -C /dev/null | \
-+#      awk '/Exim version/ { OFS=""; print $3,"-",substr($4,2,length($4)-1) }'`${EXE}
+--- a/scripts/exim_install
++++ b/scripts/exim_install
+@@ -221,6 +221,8 @@ while [ $# -gt 0 ]; do
+     version=exim-`$exim 2>/dev/null | \
+       awk '/Exim version/ { OFS=""; print $3,"-",substr($4,2,length($4)-1) }'`${EXE}
  
++    version=exim
++
      if [ "${version}" = "exim-${EXE}" ]; then
        echo $com ""
-@@ -368,10 +369,8 @@ done
+       echo $com "*** Could not run $exim to find version number ***"
+@@ -370,10 +372,8 @@ done
  
  
  
@@ -32,7 +29,7 @@ Last-Update: 2013-09-28
  
  # However, if CONFIGURE_FILE specifies a list of files, skip this code.
  
-@@ -394,7 +393,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
+@@ -396,7 +396,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
    ${real} ${MKDIR} -p `${DIRNAME} ${CONFIGURE_FILE}`
  
    echo sed -e '\\'
@@ -41,7 +38,7 @@ Last-Update: 2013-09-28
    echo "  ../src/configure.default > \${CONFIGURE_FILE}"
  
    # I can't find a way of writing this using the ${real} feature because
-@@ -403,7 +402,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
+@@ -405,7 +405,7 @@ elif [ ! -f ${CONFIGURE_FILE} ]; then
  
    if [ "$real" = "" ] ; then
      sed -e \