Import Debian changes 4.92-8+deb10u3
[hcoop/debian/exim4.git] / debian / patches / 90_localscan_dlopen.dpatch
similarity index 93%
rename from debian/patches/50_localscan_dlopen.dpatch
rename to debian/patches/90_localscan_dlopen.dpatch
index 1e83b92..ce71bae 100644 (file)
@@ -1,7 +1,4 @@
-## 50_localscan_dlopen.dpatch by Marc MERLIN
-
-
-Description: Allow to use and switch between different local_scan functions
+Description: Allow one to use and switch between different local_scan functions
  without recompiling exim.
  http://marc.merlins.org/linux/exim/files/sa-exim-current/ Original patch from
  David Woodhouse, modified first by Derrick 'dman' Hudson and then by Marc
@@ -9,11 +6,11 @@ Description: Allow to use and switch between different local_scan functions
 Author: David Woodhouse, Derrick 'dman' Hudson, Marc MERLIN
 Origin: other, http://marc.merlins.org/linux/exim/files/sa-exim-current/
 Forwarded: no
-Last-Update: 2014-12-01
+Last-Update: 2018-12-12
 
 --- a/src/EDITME
 +++ b/src/EDITME
-@@ -785,6 +785,21 @@ HEADERS_CHARSET="ISO-8859-1"
+@@ -824,6 +824,21 @@ HEADERS_CHARSET="ISO-8859-1"
  
  
  #------------------------------------------------------------------------------
@@ -37,7 +34,7 @@ Last-Update: 2014-12-01
  # the documentation in "info" format, first fetch the Texinfo documentation
 --- a/src/config.h.defaults
 +++ b/src/config.h.defaults
-@@ -28,6 +28,8 @@ it's a default value. */
+@@ -32,6 +32,8 @@ Do not put spaces between # and the 'def
  
  #define AUTH_VARS                     3
  
@@ -48,7 +45,7 @@ Last-Update: 2014-12-01
  #define CONFIGURE_FILE
 --- a/src/globals.c
 +++ b/src/globals.c
-@@ -140,6 +140,10 @@ int     dsn_ret                = 0;
+@@ -141,6 +141,10 @@ int     dsn_ret                = 0;
  const pcre  *regex_DSN         = NULL;
  uschar *dsn_advertise_hosts    = NULL;
  
@@ -61,7 +58,7 @@ Last-Update: 2014-12-01
  BOOL    gnutls_allow_auto_pkcs11 = FALSE;
 --- a/src/globals.h
 +++ b/src/globals.h
-@@ -133,6 +133,9 @@ extern int      dsn_ret;               /
+@@ -138,6 +138,9 @@ extern int      dsn_ret;               /
  extern const pcre  *regex_DSN;         /* For recognizing DSN settings */
  extern uschar  *dsn_advertise_hosts;   /* host for which TLS is advertised */
  
@@ -73,7 +70,7 @@ Last-Update: 2014-12-01
  
 --- a/src/local_scan.c
 +++ b/src/local_scan.c
-@@ -5,60 +5,131 @@
+@@ -5,61 +5,131 @@
  /* Copyright (c) University of Cambridge 1995 - 2009 */
  /* See the file NOTICE for conditions of use and distribution. */
  
@@ -85,6 +82,7 @@ Last-Update: 2014-12-01
 -Local/local_scan.c, and edit the copy. To use your version instead of the
 -default, you must set
 -
+-HAVE_LOCAL_SCAN=yes
 -LOCAL_SCAN_SOURCE=Local/local_scan.c
 -
 -in your Local/Makefile. This makes it easy to copy your version for use with
@@ -271,13 +269,13 @@ Last-Update: 2014-12-01
  /* End of local_scan.h */
 --- a/src/readconf.c
 +++ b/src/readconf.c
-@@ -313,6 +313,9 @@ static optionlist optionlist_config[] =
+@@ -199,6 +199,9 @@ static optionlist optionlist_config[] =
    { "local_from_prefix",        opt_stringptr,   &local_from_prefix },
    { "local_from_suffix",        opt_stringptr,   &local_from_suffix },
    { "local_interfaces",         opt_stringptr,   &local_interfaces },
 +#ifdef DLOPEN_LOCAL_SCAN
 +  { "local_scan_path",          opt_stringptr,   &local_scan_path },
 +#endif
+ #ifdef HAVE_LOCAL_SCAN
    { "local_scan_timeout",       opt_time,        &local_scan_timeout },
-   { "local_sender_retain",      opt_bool,        &local_sender_retain },
-   { "localhost_number",         opt_stringptr,   &host_number_string },
+ #endif