Merge branch 'debian'
[hcoop/debian/exim4.git] / debian / patches / 32_exim4.dpatch
old mode 100755 (executable)
new mode 100644 (file)
index 84b39a1..967869d
@@ -1,11 +1,11 @@
-Description: Accomodate source for installing exim as exim4.
+Description: Accommodate source for installing exim as exim4.
 Author: Andreas Metzler <ametzler@debian.org>
 Origin: vendor
 Forwarded: not-needed
-Last-Update: 2013-09-28
+Last-Update: 2018-12-12
 
---- exim4-4.82~rc1.orig/OS/Makefile-Linux
-+++ exim4-4.82~rc1/OS/Makefile-Linux
+--- a/OS/Makefile-Linux
++++ b/OS/Makefile-Linux
 @@ -28,9 +28,9 @@ XLFLAGS=-L$(X11)/lib
  X11_LD_LIB=$(X11)/lib
  
@@ -18,9 +18,9 @@ Last-Update: 2013-09-28
  EXIWHAT_KILL_SIGNAL=-USR1
  
  # End
---- exim4-4.82~rc1.orig/src/exicyclog.src
-+++ exim4-4.82~rc1/src/exicyclog.src
-@@ -144,7 +144,7 @@ done
+--- a/src/exicyclog.src
++++ b/src/exicyclog.src
+@@ -149,7 +149,7 @@ done
  
  st='   '
  exim_path=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
@@ -29,8 +29,8 @@ Last-Update: 2013-09-28
  
  spool_directory=`$exim_path -C $config -bP spool_directory | sed 's/.*=[  ]*//'`
  
---- exim4-4.82~rc1.orig/src/exim_checkaccess.src
-+++ exim4-4.82~rc1/src/exim_checkaccess.src
+--- a/src/exim_checkaccess.src
++++ b/src/exim_checkaccess.src
 @@ -52,7 +52,7 @@ done
  # a tab to keep the tab in one place.
  
@@ -40,9 +40,9 @@ Last-Update: 2013-09-28
  
  
  #########################################################################
---- exim4-4.82~rc1.orig/src/eximon.src
-+++ exim4-4.82~rc1/src/eximon.src
-@@ -72,7 +72,7 @@ config=${EXIMON_EXIM_CONFIG-$config}
+--- a/src/eximon.src
++++ b/src/eximon.src
+@@ -79,7 +79,7 @@ config=${EXIMON_EXIM_CONFIG-$config}
  
  st='   '
  EXIM_PATH=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
@@ -51,9 +51,9 @@ Last-Update: 2013-09-28
  
  SPOOL_DIRECTORY=`$EXIM_PATH -C $config -bP spool_directory | sed 's/.*=[  ]*//'`
  LOG_FILE_PATH=`$EXIM_PATH -C $config -bP log_file_path | sed 's/.*=[  ]*//'`
---- exim4-4.82~rc1.orig/src/exinext.src
-+++ exim4-4.82~rc1/src/exinext.src
-@@ -90,7 +90,7 @@ if [ "$exim_path" = "" ]; then
+--- a/src/exinext.src
++++ b/src/exinext.src
+@@ -97,7 +97,7 @@ if [ "$exim_path" = "" ]; then
    exim_path=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
  fi
  
@@ -62,7 +62,7 @@ Last-Update: 2013-09-28
  spool_directory=`$exim_path $eximmacdef -C $config -bP spool_directory | sed 's/.*=[  ]*//'`
  qualify_domain=`$exim_path $eximmacdef -C $config -bP qualify_domain | sed 's/.*=[  ]*//'`
  
-@@ -171,7 +171,7 @@ perl - $exim_path "$eximmacdef" $argone
+@@ -181,7 +181,7 @@ perl - $exim_path "$eximmacdef" $argone
  
    # Run exim_dumpdb to get out the retry data and pick off what we want
  
@@ -71,10 +71,10 @@ Last-Update: 2013-09-28
      die "can't run exim_dumpdb";
  
    while (<DATA>)
---- exim4-4.82~rc1.orig/src/exiqgrep.src
-+++ exim4-4.82~rc1/src/exiqgrep.src
-@@ -21,7 +21,7 @@ use strict;
- use Getopt::Std;
+--- a/src/exiqgrep.src
++++ b/src/exiqgrep.src
+@@ -24,7 +24,7 @@ use Getopt::Std;
+ use File::Basename;
  
  # Have this variable point to your exim binary.
 -my $exim = 'BIN_DIRECTORY/exim';
@@ -82,9 +82,9 @@ Last-Update: 2013-09-28
  my $eargs = '-bpu';
  my %id;
  my %opt;
---- exim4-4.82~rc1.orig/src/exiwhat.src
-+++ exim4-4.82~rc1/src/exiwhat.src
-@@ -88,7 +88,7 @@ fi
+--- a/src/exiwhat.src
++++ b/src/exiwhat.src
+@@ -98,7 +98,7 @@ fi
  
  st='   '
  exim_path=`grep "^[$st]*exim_path" $config | sed "s/.*=[$st]*//"`
@@ -93,14 +93,14 @@ Last-Update: 2013-09-28
  spool_directory=`$exim_path -C $config -bP spool_directory | sed "s/.*=[ ]*//"`
  process_log_path=`$exim_path -C $config -bP process_log_path | sed "s/.*=[ ]*//"`
  
---- exim4-4.82~rc1.orig/src/globals.c
-+++ exim4-4.82~rc1/src/globals.c
-@@ -633,7 +633,7 @@ int     errors_sender_rc       = EXIT_FA
+--- a/src/globals.c
++++ b/src/globals.c
+@@ -906,7 +906,7 @@ const uschar *event_name         = NULL;
  
  gid_t   exim_gid               = EXIM_GID;
- BOOL    exim_gid_set           = TRUE;          /* This gid is always set */
 -uschar *exim_path              = US BIN_DIRECTORY "/exim"
 +uschar *exim_path              = US BIN_DIRECTORY "/exim4"
                          "\0<---------------Space to patch exim_path->";
  uid_t   exim_uid               = EXIM_UID;
BOOL    exim_uid_set           = TRUE;          /* This uid is always set */
int     expand_level         = 0;             /* Nesting depth, indent for debug */