Imported Debian patch 4.84-8
[hcoop/debian/exim4.git] / debian / patches / 84_Fix-truncation-of-items-in-headers_remove-lists-this.patch
1 From 97f83c7a669a525a5f5964a5c0708c311673b87f Mon Sep 17 00:00:00 2001
2 From: Jeremy Harris <jgh146exb@wizmail.org>
3 Date: Thu, 29 Jan 2015 17:42:47 +0000
4 Subject: [PATCH] Fix truncation of items in headers_remove lists, this time in
5 routers. Bug 1533
6
7 ---
8 src/src/routers/rf_get_munge_headers.c | 3 +--
9 1 file changed, 1 insertion(+), 2 deletions(-)
10
11 diff --git a/src/routers/rf_get_munge_headers.c b/src/routers/rf_get_munge_headers.c
12 index a4a13b0..3125f31 100644
13 --- a/src/routers/rf_get_munge_headers.c
14 +++ b/src/routers/rf_get_munge_headers.c
15 @@ -90,9 +90,8 @@ if (rblock->remove_headers)
16 uschar * list = rblock->remove_headers;
17 int sep = ':';
18 uschar * s;
19 - uschar buffer[128];
20
21 - while ((s = string_nextinlist(&list, &sep, buffer, sizeof(buffer))))
22 + while ((s = string_nextinlist(&list, &sep, NULL, 0)))
23 if (!(s = expand_string(s)))
24 {
25 if (!expand_string_forcedfail)
26 --
27 2.1.4
28