Imported Debian patch 4.84-8
[hcoop/debian/exim4.git] / debian / patches / 83_Remove-limit-on-remove_headers-item-size.-Bug-1533.patch
1 From 8bc732e8b03ebb4309f4b42626917148d176db49 Mon Sep 17 00:00:00 2001
2 From: Jeremy Harris <jgh146exb@wizmail.org>
3 Date: Sun, 5 Oct 2014 21:31:20 +0100
4 Subject: [PATCH] Remove limit on remove_headers item size. Bug 1533
5
6 ---
7 doc/doc-txt/ChangeLog | 5 +++++
8 src/src/transport.c | 3 +--
9 2 files changed, 6 insertions(+), 2 deletions(-)
10
11 | diff --git a/doc/doc-txt/ChangeLog b/doc/doc-txt/ChangeLog
12 | index 76ecc20..0b03894 100644
13 | --- a/doc/doc-txt/ChangeLog
14 | +++ b/doc/doc-txt/ChangeLog
15 | @@ -44,6 +44,11 @@ JH/05 Fix results-pipe from transport process. Several recipients, combined
16 | to notice due to the introduction of conection certificate information,
17 | the item size being so much larger. Found and fixed by Wolfgang Breyha.
18 |
19 | +JH/06 Bug 1533: Fix truncation of items in headers_remove lists. A fixed
20 | + size buffer was used, resulting in syntax errors when an expansion
21 | + exceeded it.
22 | +
23 | +
24 | Exim version 4.84
25 | -----------------
26 | TL/01 Bugzilla 1506: Re-add a 'return NULL' to silence complaints from static
27 diff --git a/src/transport.c b/src/transport.c
28 index 31437b1..15c30bf 100644
29 --- a/src/transport.c
30 +++ b/src/transport.c
31 @@ -643,8 +643,7 @@ for (h = header_list; h != NULL; h = h->next) if (h->type != htype_old)
32 {
33 int sep = ':'; /* This is specified as a colon-separated list */
34 uschar *s, *ss;
35 - uschar buffer[128];
36 - while ((s = string_nextinlist(&list, &sep, buffer, sizeof(buffer))))
37 + while ((s = string_nextinlist(&list, &sep, NULL, 0)))
38 {
39 int len;
40
41 --
42 2.1.4
43